View Full Version : [SOLVED] 10.04 server (no GUI) hangs on boot - probably not video issue

April 30th, 2010, 05:48 PM
Hi All,

I just installed 10.04 i386 Server (release version) last night on an older IBM workstation (sorry, for the life of me can't remember model and I'm at work now); P4 2.4, 512Mb RAM, generic Intel graphics. This was a base install (aside from OpenSSH) with no window mgr. The HDD was wiped during the install and GRUB2 wrote to the MBR.

The install went smoothly, and on the soft reboot after the install I got a shell and was able to login, etc. and even SSH in.

I unplugged the machine, moved it, booted, and got a cursor in the upper-left of the screen for about 3 seconds, and then the monitor would enter power save mode. (I tried 2 different models of monitor). While the cursor was on the screen the HDD access LED was blinking with activity, but that would stop right before the screen would enter standby. Tried a few reboots with the same result.

I'm thinking this is not a video driver issue (as similar threads have suggested), because the splash screen for the install disc renders properly and on the first successful boot the shell rendered appropriately at a high resolution.

I can hold down shift to enter the GRUB2 menu, which also renders at a higher-than-text resolution and is defaulted / displays the correct options.

Most other threads with a similar yet non-video issue centered around GRUB2 issues with a dual-boot machine, which mine is not.

I did go in via rescue mode (off the install CD -- the rescue option of the GRUB menu has the same result as a standard boot), and checked that my grub.cfg was correct, and I ran grub-install to no avail, and also ran grub-mkconfig on a subsequent boot to no avail, yet the grub.cfg generated appeared identical to the original generated during install.

The partition/file system is default layout.

20 Gb IDE (/dev/sda)
/dev/sda1 /boot ext2
/dev/sda2 Ext
/dev/sda5 LVM

/dev/hp-lb01/root / ext4
/dev/hp-lb01/swap_1 swap

I'd be happy to give more info if someone has a troubleshooting direction in which to go.

Apologies if this exact issue was covered in another thread, but I didn't find it.


May 1st, 2010, 01:06 AM
Solution is post #14 in this thread (scroll down to "Eureka"):


It's still beyond me why it worked on the first boot after install (login prompt/shell were definitely in a higher resolution than now, after the fix).

Sorry for clogging up with a dupe thread -- the cited one didn't show up on Google until this eve. :/