PDA

View Full Version : [SOLVED] 10.04 SSL issue



penguin_patrick
April 30th, 2010, 05:05 PM
I loaded 10.04 after the release, and am configuring for 8 virtual hosts, one of which is SSL (self signed, development use).

So you know, I use webmin for most configuration.

Created mount points, put in my files OK.

Created the virtual hosts, and turned on SSL and rewrite. One of which is port 443.

Created the self signed cert & key, and put them where the belong. Added lines to the ssl website conf file, pointing to correct crt & key file.

Couldn't hit my https website, so I started comparing my 9.10 server to the 10.04 server.

In the 10.04 ports.conf file, there's:


NameVirtualHost *:80
Listen *:80
Listen *:443

But on my 9.10 server it is listed as:


NameVirtualHost *:80
Listen 80

Once I changed the lines to the second entry, it worked.

I also added:


ServerName localhost

to the httpd.conf, so the 0.0.0.0:443 error would go away.

Hope this helps somebody, as without a running box next to the new one, I may have spent quite a while looking for this.

If anyone sees a problem with the above changes, or better ways to do this, please post and let me know.