View Full Version : [ubuntu] 10.4 upgrade frozen?

April 30th, 2010, 04:00 AM

Doing a distribution upgrade from 9. to 10.

the dialog is frozen at "installing upgrades",preparing, setting new channels, and getting new packages have green checks. Its saying 56 min remaning, and has been like that for about 8 hrs.

Whats the ***safest*** way to back out of this? There is no cancel option.


April 30th, 2010, 05:16 AM
I am not sure of any safe way to back out of this. It looks like something has caused a blockage but without further investigation is is hard to say what it is.

If it was me I would open a terminal. Look for the process that is stuck and kill it.

I would then look at /etc/apt/sources.list to make sure that the install had gotten as far as changing this from karmic to lucid (look for the word lucid in each line).

If this is so I would then run:

sudo aptitude safe-upgrade

April 30th, 2010, 03:14 PM
thanks for the reply

got it working here's what I did

I tried to open another instance of update manager, but it couldn't get a lock(i guess the frozen one was the problem)

finally I closed the frozen update manager dialog

I went into synaptic, and it told me i had 50 broken packages

I removed the broken packages

then I ran update manager again, (now it wants to update 10.4) it now installs all the missing files

all good now

April 30th, 2010, 10:50 PM
Had the same problem but I am unable to fix the broken packages by apt-get or synaptic>edit>fix broken packages. When I try it says: "E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies"

Did this happen to you, too. Can you please explain how you got around it.

May 1st, 2010, 01:05 AM
The following packages have unmet dependencies:
mountall: PreDepends: libc6 (< 2.11) but 2.11.1-0ubuntu7 is installed
ubuntu-desktop: Depends: usplash but it is not installed
usplash-theme-ubuntu: Depends: usplash (>= 0.5.30) but it is not installed

Now what?

May 2nd, 2010, 08:46 PM
I tried to upgrade mountall in Synaptic but got this error message:
E: Internal Error, Could not perform immediate configuration (2) on mountall

May 7th, 2010, 05:44 PM
During my upgrade, the installer stopped when installing flash_player. It was stopped for about an hour. It restarted installing when I opened Update Manager and chose the partial upgrade option presented. At this point, Lucid had been installed -- more /etc/apt/sources.list showed lucid at all uncommented lines.

May 7th, 2010, 07:19 PM
Not sure that his belongs in this thread - there are several frozen install possibilities and mine just one more....
I am upgrading (possibly in a dangerous attempt) from the image contained in a windows XP system. Still all was going well then I got a freeze at >INSTALLING THE UPGRADES.
I waited 4 hours (well I did other things :-) and 4 hours later resumed trying to fix it LOL
Its stopped in "Preparing memtest86+"

I am going to try some of the suggestions here. But if anyone has better input on this particular issue let me know..for instance is the memtest86 actually running memory test? My 4 G ought to be fairly normal size for this - what is the expected duration?

Some of the install script did mention multiple hours for the upgrade but the machine is frozen showing half a completed bar graph on "About 14 minutes remaining"