PDA

View Full Version : [ubuntu] ices2 won't start in ALSA-mode (Lucid)



produnis
April 29th, 2010, 07:56 PM
Hi folks, I did a fresh install of Lucid today. While under Jaunty and Karmic, I run ices2 in alsa-mode using this xml:

produnis
April 29th, 2010, 08:04 PM
(dont know whats going on here, so here is my post)

Now, running a fresh install of Lucid, ices2 crashes. The Log-File shows:

[2010-04-29 20:26:31] INFO ices-core/main IceS 2.0.1 started...
[2010-04-29 20:26:31] EROR input-alsa/alsa_open_module Error setting 2 periods: Invalid argument
[2010-04-29 20:26:31] EROR input/input_loop Couldn't initialise input module "alsa"
[2010-04-29 20:26:31] INFO ices-core/main Shutdown complete

Does anyone know how to fix that?

produnis
April 30th, 2010, 08:09 AM
Got it.

In the ices2.xml-File, I removed this entry:

param name="periods">2</param

This entry created the "interrupts". I don't really know what it was for,
and it worked with jaunty and karmic,
but in lucid I needed to remove it...

Now it works