PDA

View Full Version : [ubuntu] Lucid Won't Boot After nVidia Driver Install



Nomad64
April 29th, 2010, 12:48 AM
First let me say that I have been using Ubuntu as a server OS for several years now. I haven't used it much as my main desktop OS mainly because of graphic driver performance. As a gamer, I like the best performance possible from my machine.

Anyways, I thought I would give the new Ubuntu 10.04 a try and see how it performs on my machine (specs below). However, I am having an issue that is really starting to frustrate me.

First, machine some specs:
MSI P6N SLI Motherboard
Pentium Core 2 Duo E6850 @ 3.00GHz
2xGeForce 9600 GT cards (SLI)

Ubuntu installed fine from CD, and booted up the first time without issues. I connected it to my wireless network, played around with Firefox for a bit, then decided to install the proprietary nVidia drivers (via System > Administration > Hardware Drivers). I installed the current driver package (195.36.15) and rebooted. Then it all went south...

The machine wouldn't boot after the driver install. Basically, it would start to boot into Ubuntu, then the display would freeze (sometimes black, sometimes with a blinking curser, sometimes with some garbled display). I tried moving my DVI cable to different outputs, but the only output that gave any sort of response was the primary one I normally use. After a few reboots, I was about to give up when I remembered that I had read somewhere that taking out one graphics card can sometimes solve problems with the nVidia drivers. I removed a card and tried again...and the system came up without any issues. It was even running the nVidia driver. I could bring up nVidia X Server Settings and such all OK.

So I dug around for a few hours on the forums and Google and couldn't find much with relation to this release of Ubuntu and my problem. I tried a few other things from various threads without any success. I am having the same issue on the 32 and 64 bit versions.

Anyone else having this problem, or have any suggestions as to how I can fix it?

Here is my xorg.conf file, for reference

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder75) Fri Mar 12 01:42:27 PST 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "1:00:00"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "2:00:00"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "SLI" "On"
SubSection "Display"
Depth 24
EndSubSection
EndSection

schmolch
April 30th, 2010, 12:28 AM
You have this issue because of a bug affecting multi-gpu setups.

https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/548362

Please add a comment to the bugreport and confirm the issue and that you used ubuntu's official nvidia-driver.

krazyd
April 30th, 2010, 07:42 AM
[QUOTE=Nomad64;9189561I haven't used it much as my main desktop OS mainly because of graphic driver performance. As a gamer, I like the best performance possible from my machine.[/QUOTE]

Sorry, but for this you are better off using Windows anyway.

Nomad64
May 3rd, 2010, 06:11 PM
Update:

The bug report for this can be found here: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/573557

Additionally, the curent work around for this is to use the 2.6.31 kernel. I haven't tried this yet, but plan on setting it up and seeing how it goes.

klausner
April 30th, 2011, 09:05 PM
Update:

The bug report for this can be found here: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/573557

Additionally, the curent work around for this is to use the 2.6.31 kernel. I haven't tried this yet, but plan on setting it up and seeing how it goes.

I had the same problem with 2.6.32, so I doubt '31 is much of a workaround :(

riptool
December 18th, 2011, 08:08 PM
I know this is marked solved but I found different solution. Someone mentioned adding vmalloc=192 to the grub cmd line. It seems this occurres a lot with the combo of 8400gs and hauppauge 1600. Everywhere I read said to add vmalloc=192MB. But the correct syntax is vmalloc=192M. Not 192MB. Works for 10.04, 10.10, 11.10.

Take out the hvr 1600 and nvidia proprietary driver boots fine. Put it back in and won't boot unless modify grub with more memory.

Hope this helps. I spent 2 DAYS installing tons of times only to find 192MB was incorrect.

Found fix here. But drop the B from 192MB and will work.
http://www.warp1337.com/content/ubuntu-1104-natty-segmentation-fault-nvidia-geforce-9-series-kernel-failure-solved