View Full Version : [ubuntu] 10.4 upgrade, Xorg, cpu, fans gone nuts

April 28th, 2010, 02:39 PM
Hi all,

I upgraded my Asus Eeepc 900a to 10.4 yesterday. Since then, Xorg has averaged between 30-40% CPU, and my fans have gone nuts running high/low/high/low, ad nausium.

Any ideas what might be going on? Another clue perhaps: on reboot or shutdown, I get a "program not responding" message with "unknown" as the hung program. I have not been able to determine what this program is or if it is related to the hyperactive Xorg.



April 28th, 2010, 03:31 PM
Type "atq" command on terminal and paste there results. I had similiar problem after upgrading to 10.04rc and have solved it, but first we need to know if that's the problem.

April 28th, 2010, 03:54 PM
atq produces nothing...

April 28th, 2010, 05:09 PM
OK, so this is not the case I had, because there were some planned jobs on my system that caused 100% CPU usage. Date of those planned jobs was from November 2009, and they showed just after the upgrade to 10.04rc and I thought it may be the same situation with your high CPU usag, but if atq shows nothing then it is not the same situation.

I have no other ideas what it can be, so I hope someone else will help you.

April 28th, 2010, 05:16 PM
thanks anyway. I appreciate your effort. I downloaded and am running blackbox as my wm which has solved the problem temporarily, so must be a config problem with gnome somewhere...

April 28th, 2010, 05:19 PM
Did you clean install or upgrade? If you upgraded, then you should try booting from a LiveCD to see how it acts.

April 30th, 2010, 06:07 PM
Same problem. Funny thing is that i made a thread 4 weeks ago while in alfa. It did installed some new fglrx drive (automatically) and after short usage of the system the Xorg process started to "eat" more than 60% off of my CPU. Now i downloaded the release ISO burned it on a cd and installed it from the live version. Everytime my mouse go through hyperlink in either firefox OR chrome i get 1 sec lag...I read that as a caution not to download BETA 2 because i might experience this very problem but it was also saying that...it will be fixed in the final release...yet after 10 minutes of installing the software that I ALWAYS INSTALL since 8.10 it began to literally rape my CPU locking me out unable to do anything >.< I must say that this is not fun. There is no need to tell that...compiz is disabled by default (<3 legacy OS driver) and if i enable it my pc will lag like hell. This is the most annoying ATi driver bug EVER >.< Im 2 seconds away to go and buy some nVidia video card god **** it...stupid amd...stupid ATi...i hope you bancrupt...besides that the new ubuntu is real epic deal

May 1st, 2010, 07:57 PM
bump. Any solution to the problem ?

May 1st, 2010, 08:25 PM
I hear that installing backports is helping some with this problem. Something about a fix being made but not included in the final ISO because it was created after the freeze.

May 1st, 2010, 08:51 PM
You may want to enable the backports in your /etc/sources.list. There was a bug fix for that before the release but it was after the freeze.

I believe it has been included in an update somewhere and read somewhere that backports may be the source of the update.
This may be a tad more helpful. If you click the thingy that takes you to his post there are one or two other things to try which have been said to work.

May 4th, 2010, 11:48 PM
Not helping :S I allowed my backports and i still was updated to the max even after package re-check yet after 15 minutes of using my computer it started to "raise the bar" again :S As i read further it is either the driver leaking like hell or the Xorg server itself which ain't cool at all. Is there some way to downgrade my ATi driver version (i suppose open source driver since i've never been asked for proprietary) to the one used in Ubuntu 9.10 so i can check that out and pinpoint the problem. Yes i did not had this problem on any older version of Ubuntu yet i love the look & feel in the new ubuntu and i really want to use it :( but i can't :( :( HELP !!!

May 5th, 2010, 11:54 AM

May 20th, 2010, 12:25 AM
workaround, anyone?

May 23rd, 2010, 03:25 AM
Same issues, i run pandora on either firefox or chrome and my XORG goes crazy, top gives anywhere between 25 to 60 % and on an average its about 7% with absolutely nothing running. Please help.

June 10th, 2010, 01:00 PM
I have the identical problem.

I have an ATI card, a new 10.04 install, and an old-ish 1.84GHz CPU.

System runs OK after boot, but Xorg eventually begins to consume all of the CPU, and everything gets very sluggish.

Even when using Ctrl-Alt-F1 to get to a console login, Xorg continues to eat CPU, and logging in takes tens of seconds.

This is awful.

June 22nd, 2010, 09:19 AM
Exactly the same here, Xorg takes all the CPU. I think it didn't happen before one of the latest 10.4. updates (not sure).

I run it as virtual machine in VMware, but nevertheless it's exactly the same issue as described above. Not really usable. On my other three Ubuntu machines, I don't have this problem.