PDA

View Full Version : [ubuntu_studio] XP wont boot?



MayhemGuitars
April 27th, 2010, 05:08 AM
So i installed XP the other day, after wiping my hard drive. Then i proceeded to install ubuntu studio. This works fine, however grub wont boot up XP after i select it. What do i do?

wilee-nilee
April 27th, 2010, 05:53 AM
So i installed XP the other day, after wiping my hard drive. Then i proceeded to install ubuntu studio. This works fine, however grub wont boot up XP after i select it. What do i do?

You post this boot script.
http://bootinfoscript.sourceforge.net/
and help will arrive sooner or later probably.

MayhemGuitars
April 27th, 2010, 06:38 AM
Note the Vista part is the recovery section of my Hard drive, that was there from before when i had vista, and i was advised by the install guide on here not to touch it, so i didnt. Hope this helps you, help me.




Boot Info Script 0.55 dated February 15th, 2010

============================= Boot Info Summary: ==============================

=> Grub 2 is installed in the MBR of /dev/sda and looks on the same drive in
partition #6 for /boot/grub.

sda1: __________________________________________________ _______________________

File system: ntfs
Boot sector type: Windows XP
Boot sector info: No errors found in the Boot Parameter Block.
Operating System: Windows XP
Boot files/dirs: /boot.ini /ntldr /NTDETECT.COM

sda2: __________________________________________________ _______________________

File system: ntfs
Boot sector type: Windows Vista/7
Boot sector info: No errors found in the Boot Parameter Block.
Operating System:
Boot files/dirs: /bootmgr /boot/bcd

sda3: __________________________________________________ _______________________

File system: Extended Partition
Boot sector type: -
Boot sector info:

sda5: __________________________________________________ _______________________

File system: swap
Boot sector type: -
Boot sector info:

sda6: __________________________________________________ _______________________

File system: ext3
Boot sector type: -
Boot sector info:
Operating System: Ubuntu 9.10
Boot files/dirs: /boot/grub/grub.cfg /etc/fstab /boot/grub/core.img

=========================== Drive/Partition Info: =============================

Drive: sda ___________________ __________________________________________________ ___

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Disk identifier: 0x1549f232

Partition Boot Start End Size Id System

/dev/sda1 * 63 312,512,444 312,512,382 7 HPFS/NTFS
/dev/sda2 605,903,760 625,136,399 19,232,640 7 HPFS/NTFS
/dev/sda3 312,512,445 605,891,474 293,379,030 5 Extended
/dev/sda5 602,003,745 605,891,474 3,887,730 82 Linux swap / Solaris
/dev/sda6 312,512,571 601,987,679 289,475,109 83 Linux


blkid -c /dev/null: __________________________________________________ __________

Device UUID TYPE LABEL

/dev/sda1 A60CB6080CB5D391 ntfs
/dev/sda2 949CA48C9CA46A86 ntfs FACTORY_IMAGE
/dev/sda5 262e82cf-875f-46b4-8723-a873934dd203 swap
/dev/sda6 ae40143a-0919-417f-a71c-6cb4b1e939df ext3

============================ "mount | grep ^/dev output: ===========================

Device Mount_Point Type Options

/dev/sda6 / ext3 (rw,errors=remount-ro)


================================ sda1/boot.ini: ================================

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

=========================== sda6/boot/grub/grub.cfg: ===========================

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s /boot/grub/grubenv ]; then
have_grubenv=true
load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
saved_entry=${prev_saved_entry}
save_env saved_entry
prev_saved_entry=
save_env prev_saved_entry
fi
insmod ext2
set root=(hd0,6)
search --no-floppy --fs-uuid --set ae40143a-0919-417f-a71c-6cb4b1e939df
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=640x480
insmod gfxterm
insmod vbe
if terminal_output gfxterm ; then true ; else
# For backward compatibility with versions of terminal.mod that don't
# understand terminal_output
terminal gfxterm
fi
fi
if [ ${recordfail} = 1 ]; then
set timeout=-1
else
set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/white
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry "Ubuntu, Linux 2.6.31-9-rt" {
recordfail=1
if [ -n ${have_grubenv} ]; then save_env recordfail; fi
set quiet=1
insmod ext2
set root=(hd0,6)
search --no-floppy --fs-uuid --set ae40143a-0919-417f-a71c-6cb4b1e939df
linux /boot/vmlinuz-2.6.31-9-rt root=UUID=ae40143a-0919-417f-a71c-6cb4b1e939df ro quiet splash
initrd /boot/initrd.img-2.6.31-9-rt
}
menuentry "Ubuntu, Linux 2.6.31-9-rt (recovery mode)" {
recordfail=1
if [ -n ${have_grubenv} ]; then save_env recordfail; fi
insmod ext2
set root=(hd0,6)
search --no-floppy --fs-uuid --set ae40143a-0919-417f-a71c-6cb4b1e939df
linux /boot/vmlinuz-2.6.31-9-rt root=UUID=ae40143a-0919-417f-a71c-6cb4b1e939df ro single
initrd /boot/initrd.img-2.6.31-9-rt
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Microsoft Windows XP Professional (on /dev/sda1)" {
insmod ntfs
set root=(hd0,1)
search --no-floppy --fs-uuid --set a60cb6080cb5d391
drivemap -s (hd0) ${root}
chainloader +1
}
menuentry "Windows Vista (loader) (on /dev/sda2)" {
insmod ntfs
set root=(hd0,2)
search --no-floppy --fs-uuid --set 949ca48c9ca46a86
chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

=============================== sda6/etc/fstab: ===============================

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda6 during installation
UUID=ae40143a-0919-417f-a71c-6cb4b1e939df / ext3 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=262e82cf-875f-46b4-8723-a873934dd203 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

=================== sda6: Location of files loaded by Grub: ===================


298.6GB: boot/grub/core.img
298.6GB: boot/grub/grub.cfg
298.7GB: boot/initrd.img-2.6.31-9-rt
298.7GB: boot/vmlinuz-2.6.31-9-rt
298.7GB: initrd.img
298.7GB: vmlinuz

wilee-nilee
April 27th, 2010, 07:07 AM
I could suggest here but, I am not real sure where the problem is. but the good thing is there are others who are very good at this, so posting this script should get you some help.

The only thing I would do to start with is in a terminal in Ubuntu run sudo update-grub and see if this changes things. I think that the boot flag should be on sda2, but I can't really confirm that, that is the problem. Both of these ideas though will not damage your setup. If you want to try and change the boot flag install gparted in Ubuntu, then right click on the sda2 partition in gparted>manage flags and tick boot. This can be reversed back to sda1 if this doesn't work. You want to be very careful with gparted it is what we use in general to delete,move, and resize partitions so it is a powerful tool. If you change the booting partition then a sudo update-grub would be a good idea again.

Sorry if you may know some of this already I am most concerned with keeping your OS's intact so a person who has more definitive answers can help.

MayhemGuitars
April 27th, 2010, 12:28 PM
I could suggest here but, I am not real sure where the problem is. but the good thing is there are others who are very good at this, so posting this script should get you some help.

The only thing I would do to start with is in a terminal in Ubuntu run sudo update-grub and see if this changes things. I think that the boot flag should be on sda2, but I can't really confirm that, that is the problem. Both of these ideas though will not damage your setup. If you want to try and change the boot flag install gparted in Ubuntu, then right click on the sda2 partition in gparted>manage flags and tick boot. This can be reversed back to sda1 if this doesn't work. You want to be very careful with gparted it is what we use in general to delete,move, and resize partitions so it is a powerful tool. If you change the booting partition then a sudo update-grub would be a good idea again.

Sorry if you may know some of this already I am most concerned with keeping your OS's intact so a person who has more definitive answers can help.

thank you for your help so far, I'll try this till something else is said. Your fine, better to be very clear, then risk someone loosing it all. :)

MayhemGuitars
April 27th, 2010, 09:32 PM
Anyone?

MayhemGuitars
April 28th, 2010, 12:11 AM
Did some more work on this, now I'm given this



Boot Info Script 0.55 dated February 15th, 2010

============================= Boot Info Summary: ==============================

=> Grub 2 is installed in the MBR of /dev/sda and looks on the same drive in
partition #6 for /boot/grub.

sda1: __________________________________________________ _______________________

File system: ntfs
Boot sector type: Grub 2
Boot sector info: Grub 2 is installed in the boot sector of sda1 and
looks at sector 583438395 of the same hard drive for
core.img, core.img is at this location on /dev/sda and
looks on partition #6 for /boot/grub. No errors found
in the Boot Parameter Block.
Operating System: Windows XP
Boot files/dirs: /boot.ini /ntldr /NTDETECT.COM

sda2: __________________________________________________ _______________________

File system: Extended Partition
Boot sector type: -
Boot sector info:

sda5: __________________________________________________ _______________________

File system: ext3
Boot sector type: -
Boot sector info:
Operating System: Ubuntu 9.10
Boot files/dirs: /boot/grub/grub.cfg /etc/fstab /boot/grub/core.img

sda3: __________________________________________________ _______________________

File system: swap
Boot sector type: -
Boot sector info:

sda4: __________________________________________________ _______________________

File system: ntfs
Boot sector type: Windows Vista/7
Boot sector info: No errors found in the Boot Parameter Block.
Operating System:
Boot files/dirs: /bootmgr /boot/bcd

=========================== Drive/Partition Info: =============================

Drive: sda ___________________ __________________________________________________ ___

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Disk identifier: 0x1549f232

Partition Boot Start End Size Id System

/dev/sda1 * 63 312,512,444 312,512,382 7 HPFS/NTFS
/dev/sda2 312,512,445 605,891,474 293,379,030 5 Extended
Extended partition linking to another extended partition
/dev/sda5 312,512,571 601,987,679 289,475,109 83 Linux
/dev/sda3 602,003,745 605,891,474 3,887,730 82 Linux swap / Solaris
/dev/sda4 605,903,760 625,136,399 19,232,640 7 HPFS/NTFS

/dev/sda2 overlaps with /dev/sda3

blkid -c /dev/null: __________________________________________________ __________

Device UUID TYPE LABEL

/dev/sda1 90280DC7280DACF2 ntfs
/dev/sda3 262e82cf-875f-46b4-8723-a873934dd203 swap
/dev/sda4 949CA48C9CA46A86 ntfs FACTORY_IMAGE
/dev/sda5 ae40143a-0919-417f-a71c-6cb4b1e939df ext3

============================ "mount | grep ^/dev output: ===========================

Device Mount_Point Type Options

/dev/sda5 / ext3 (rw,errors=remount-ro)


================================ sda1/boot.ini: ================================

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

=========================== sda5/boot/grub/grub.cfg: ===========================

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s /boot/grub/grubenv ]; then
have_grubenv=true
load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
saved_entry=${prev_saved_entry}
save_env saved_entry
prev_saved_entry=
save_env prev_saved_entry
fi
insmod ext2
set root=(hd0,6)
search --no-floppy --fs-uuid --set ae40143a-0919-417f-a71c-6cb4b1e939df
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=640x480
insmod gfxterm
insmod vbe
if terminal_output gfxterm ; then true ; else
# For backward compatibility with versions of terminal.mod that don't
# understand terminal_output
terminal gfxterm
fi
fi
if [ ${recordfail} = 1 ]; then
set timeout=-1
else
set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/white
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry "Ubuntu, Linux 2.6.31-9-rt" {
recordfail=1
if [ -n ${have_grubenv} ]; then save_env recordfail; fi
set quiet=1
insmod ext2
set root=(hd0,6)
search --no-floppy --fs-uuid --set ae40143a-0919-417f-a71c-6cb4b1e939df
linux /boot/vmlinuz-2.6.31-9-rt root=UUID=ae40143a-0919-417f-a71c-6cb4b1e939df ro quiet splash
initrd /boot/initrd.img-2.6.31-9-rt
}
menuentry "Ubuntu, Linux 2.6.31-9-rt (recovery mode)" {
recordfail=1
if [ -n ${have_grubenv} ]; then save_env recordfail; fi
insmod ext2
set root=(hd0,6)
search --no-floppy --fs-uuid --set ae40143a-0919-417f-a71c-6cb4b1e939df
linux /boot/vmlinuz-2.6.31-9-rt root=UUID=ae40143a-0919-417f-a71c-6cb4b1e939df ro single
initrd /boot/initrd.img-2.6.31-9-rt
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Microsoft Windows XP Professional (on /dev/sda1)" {
insmod ntfs
set root=(hd0,1)
search --no-floppy --fs-uuid --set a60cb6080cb5d391
drivemap -s (hd0) ${root}
chainloader +1
}
menuentry "Windows Vista (loader) (on /dev/sda2)" {
insmod ntfs
set root=(hd0,2)
search --no-floppy --fs-uuid --set 949ca48c9ca46a86
chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

=============================== sda5/etc/fstab: ===============================

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda6 during installation
UUID=ae40143a-0919-417f-a71c-6cb4b1e939df / ext3 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=262e82cf-875f-46b4-8723-a873934dd203 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

=================== sda5: Location of files loaded by Grub: ===================


298.6GB: boot/grub/core.img
298.6GB: boot/grub/grub.cfg
298.7GB: boot/initrd.img-2.6.31-9-rt
298.7GB: boot/vmlinuz-2.6.31-9-rt
298.7GB: initrd.img
298.7GB: vmlinuz

oldfred
April 28th, 2010, 12:57 AM
Now you installed grub2 to the partition which had essential windows boot files. You need to set the boot flag to sda1 and then use the XP disk to repair the XP install. If you run fixMBR you will have to reinstall grub2 to the MBR (sda not partition sda1). You may have to run fixMBR just to confirm that windows boots on its own.

Did you have Vista installed also? The windows in sda4 is not complete but it look more like a boot partition or recovery partition and is missing the main files.

To repair windows with mounting issues from your Windows XP CD - Do not run fixMBR unless you want windows boot loader in the MBR.
fixboot C:
chkdsk C: /R
http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/chkdsk.mspx?mfr=true
Thread with this and other repair suggestions
http://ubuntuforums.org/showthread.php?t=1393848
Check disk from CD - WinXP recovery console - menu shown with example
http://kb.wisc.edu/helpdesk/page.php?id=5097

MayhemGuitars
April 28th, 2010, 01:16 AM
The vista partition is just a recovery section, that's all.

EDIT:
"Now you installed grub2 to the partition which had essential windows boot files. You need to set the boot flag to sda1"
I cant manage my flags for some reason in gparted, what do i do now?

wilee-nilee
April 28th, 2010, 01:44 AM
The vista partition is just a recovery section, that's all.

EDIT:
"Now you installed grub2 to the partition which had essential windows boot files. You need to set the boot flag to sda1"
I cant manage my flags for some reason in gparted, what do i do now?

Use a live Cd to do this, and if you are already try clicking on swap and turning it off to change the boot then turn it back on..

MayhemGuitars
April 28th, 2010, 03:18 AM
To repair windows with mounting issues from your Windows XP CD - Do not run fixMBR unless you want windows boot loader in the MBR.
fixboot C:
chkdsk C: /R



I did this, i booted the XP CD, went into recovery, and ran those two commands. Now, windows XP boots, everything works fine on it (I'm on it now) However, ubuntu boots, but does not fully load. It stops after loading the grey background, so i cant use it. So close to getting everything done, thanks for the help so far!

So now, how do i get past my little problem with ubuntu loading fully?

oldfred
April 28th, 2010, 04:32 AM
Did it boot before? Can you boot from the recovery mode?

From the grub menu press e for edit and remove the quiet and splash. Then boot, you then should see every line that it is processing and have to quickly look for any error messages. Often a graphics problem and additional settings may be required.

MayhemGuitars
April 28th, 2010, 04:43 AM
Did it boot before? Can you boot from the recovery mode?

From the grub menu press e for edit and remove the quiet and splash. Then boot, you then should see every line that it is processing and have to quickly look for any error messages. Often a graphics problem and additional settings may be required.

Yea, it booted before i went into XP in recovery mood, that's how i was on the forum. I can indeed boot from the recovery mode, so i shall try as you said and post what i find.

oldfred
April 28th, 2010, 05:08 AM
IF you can get in with recovery mode, then I would try to run all the updates from the command line and try startx to see if you can then get in. (Lucid gives a menu to do the repairs from recovery mode). I do not know what video you have but you can reinstall that from command line also.

apt-get update
apt-get upgrade
#would upgrade you to the latest kernel in the repositories
apt-get dist-upgrade
startx

I do not know if reinstalling grub would work, If the above does not work then I might try:
apt-get install grub-pc grub-common
grub-install /dev/sda
grub-install --recheck /dev/sda
# possibly this also
dpkg-reconfigure grub-pc

MayhemGuitars
April 28th, 2010, 05:35 AM
IF you can get in with recovery mode, then I would try to run all the updates from the command line and try startx to see if you can then get in. (Lucid gives a menu to do the repairs from recovery mode). I do not know what video you have but you can reinstall that from command line also.

apt-get update
apt-get upgrade
#would upgrade you to the latest kernel in the repositories
apt-get dist-upgrade
startx


I did this, and then after a black screen and a 30 sec or so pause, it loaded up fine, with me as root.
Now, if i restart my comp and try to boot it up, i still have the same issue. However, if i enter recovery mode like before, and simply put in

startx
then i again get that pause and then it loads. Honestly, this is pretty good with me, i can access windows and this fine, just requires a bit of extra work. However, do you know of any way to fix this? I really dont think it's a graphics issue, i would have had it before.

Lastly, thank you for all your help, you've made my long awaited dream of running both a reality. :)

oldfred
April 28th, 2010, 05:47 AM
there is some minor hiccup somewhere. the difference in boot is quiet, splash and directly going in multiuser with the startx automatically run. Recovery starts you to command line as single user.

I might look in log files - system, admistration, log file viewer. Lots of info but scroll thru looking for errors warnings or something repeating several times then working??