PDA

View Full Version : [ubuntu] 10.04 LTS RC: Blank Screen at startup



IcyPhoenix
April 27th, 2010, 12:39 AM
Hey, all. I've been using Ubuntu off and on since 6.10, but I am definitely a noob when it comes to troubleshooting this kind of stuff. All of my previous installs went flawlessly, so I guess I've been lucky so far. I finally decided that I would bite the bullet, and remove Windows altogether. No more dual-boot with XP or 7 for me.

I've been attempting to install the 10.04 RC all weekend, and it's been pretty frustrating. I decided I would start with my aging laptop, a HP Pavilion ze8500 that I custom-ordered way back in 2003. A few specs I know off the top of my head:

P4 (2.30 GHz)
512MB RAM
40GB SATA HDD

I burned the ISO to CD-R and started the install. When I boot from the CD, I get a purple screen which is blank other than two symbols at the very bottom. IIRC, one looked like a ruler or something, and the other looked sort of like a star in a circle? I think they were separated by an equal sign.

I have no idea what that meant, but I knew enough to hit F6 and that got the install menu to appear onscreen. The only way I could get through the installer without losing video was to use 'nomodeset'

I installed over top of Windows 7 RC with the default partition table settings and after the install finished, I got the dialog box telling me that a restart is necessary. I hit Continue, the CD tray ejected, and my laptop restarted.

So, assuming that the installation was a success, I see the BIOS screen, and then that goes blank, and where I would expect to see a boot screen or a Grub dialog, I see nothing at all.

After the first install attempt, I would hear a drum sound after the screen went blank.

I tried hitting 'Esc', along with 'Ctrl+Alt+F1', 'Ctrl + Alt + F2' or whatever else I could think of, and nothing seems to work.

I updated my BIOS, remembering that I forgot to do that, and then I reinstalled Ubuntu. Again, no display when Ubuntu boots. And now, I hear no drum sound at all.

I am certain I was using an ATI video driver with Windows, but other than that, I don't know any specs on the display off the top of my head.

Am I doing something wrong, or does anyone have any suggestions? I'd really love to get this working so I can finally ditch Windows for good on my other two computers.

arterio
April 27th, 2010, 06:44 AM
I'm having the same problem.

My desktop, I just installed 10.04 RC x64 on it. I was using a USB stick to install from. I downloaded the 10.04 RC and put it on the USB stick with UNetBootin, rebooted and told the system to boot from the USB stick. It started to boot, and ended up in a blank screen.

I thought maybe it was an issue with the image so I decided to download 9.10 x64 and then upgrade to 10.04 RC x64. I installed 9.10 x64, and everything went perfect. Booted in for the first time and beyond not having the resolution set properly it seemed to be working fine. I started the upgrade process and once completed I rebooted the system. I get a black screen and just as the OP mentioned I can hear the welcome jingle, but the screen stays black and goes into power saving mode. Like there is no signal coming from it.

System specs:

Intel Q9450 @ 2.66Ghz
Asus Rampage Extreme
4GB G-Skill DDR3 2000
ATI Radeon 5870
Creative X-Fi

Any help would be appreciated. I'm interested in switching to Ubuntu as my primary OS, but if this can't be resolved then I will have to stay with Windows 7.

Terry32
April 27th, 2010, 11:13 PM
Same issue here no video after the ubuntu logo and dots, system below:

Ubuntu 10.04 RC 32-Bit
Intel i7 920
6GB Ram
Gigabyte GA-X58A-UD7 Motherboard
ATI HD 5970 2GB

It made it to the desktop because I was able to click the menu and see the disk access because it was in LIVE mode and I shut it down blind using keystrokes.

It sucked when I booted back into windows, both my ethernet ports were dead, no power it seemed, reboots didn't help, had to shut down and and unplug my power supply for a minute and boot back up.

arterio
April 27th, 2010, 11:33 PM
From searching around it seems it is a problem with ATI cards.

However, that being said, I am writing this on a laptop with an ATI Xpress200M graphics chip in it and the 10.04 32-bit RC install went flawlessly.

Maybe something for the dev's to look into before the release in a few days. Newer ATI cards seem to be having problems after fresh install and after upgrades to 10.04.

Terry32
April 28th, 2010, 01:32 AM
I finally figured it out, I switched the connector on the video card that my monitor was attached to, since getting the card I have had my monitor attached to the DVI connector farthest from the motherboard or better yet the one next to the screw on the bracket. I moved it to the other DVI connector booted up like that and I get video and no blank screen anymore.

I always wondered which one was the primary port because my card was not marked, I have a Sapphire HD 5970.

Good Luck!!!!!!

arterio
April 28th, 2010, 01:37 AM
I tried switching connectors. Plugged into first DVI port and rebooted, no luck. Second DVI port, rebooted, no luck. HDMI port (using HDMI to DVI cable), rebooted no luck. DisplayPort (using DP to HDMI adapter), rebooted and no luck.

I have re-installed Windows 7 and will stick with that till a newer version comes out.

Rasa1111
April 28th, 2010, 01:40 AM
I get a black screen and just as the OP mentioned I can hear the welcome jingle, but the screen stays black and goes into power saving mode. Like there is no signal coming from it. same thing here, and thats not even installing it,
just trying to run from liveCD.

i dont get it....

good thing im happy with karmic! lol

IcyPhoenix
April 28th, 2010, 02:51 AM
Well, I did a dual boot setup on my primary desktop PC last night and it works flawlessly. Perhaps that is because my desktop has an nVidia rather than an ATI...

I spent all last night messing around with Lucid on my desktop (sleep is overrated.) I love it and I will definitely be installing over Windows 7 with the final release in a few days. :)

I'll stick with Karmic on my laptop until the ATI issue is resolved. :(

jaycee23
April 28th, 2010, 06:32 AM
Exactly same issue here - installed no problem on my Nvidia containing laptop. Using a HDMI connection for the visuals.

My specs are in my signature. Must be an ATI problem. Hopefully they will sort it for the full release later this week!!!

nucleuskore
April 29th, 2010, 07:44 PM
Same issue here

HP Pavilion SLimline s7727c

with
VGA compatible controller: nVidia Corporation C51 [GeForce 6150 LE] (rev a2)


Just a blank screen. I tried various video modes, no luck :(

Update:
I booted from the cd, pressed F6 and then selected the Nomodeset option. The install proceeded without any problems. However I am back with a blank screen with a monitor message that the video mode cannot be displayed. This is true even if I select the recovery option at boot. Now I am stuck.

Any Ideas??

Rasa1111
April 29th, 2010, 07:53 PM
well,

I have come further than I had in my previous post in this thread...
and i thought it was going to work this time.... but no go... lol

All goes fine, and I get to the point where you can " try ubuntu" or "install ubuntu".

So I choose "try ubuntu" ... and it acts like it is going to work....
the loading screen comes up.....

then, my screen goes black,
but this time.... on the top half of my monitor...
it starts blinking, with white vertical stripes going across the black screen (only top half though)..
and It just keeps doing this,

anyone else experiencing that? if so...
How does one get around that? lol

nucleuskore
April 29th, 2010, 08:39 PM
Update:
I booted from the cd, pressed F6 and then selected the Nomodeset option. The install proceeded without any problems. However I am back with a blank screen with a monitor message that the video mode cannot be displayed. This is true even if I select the recovery option at boot. Now I am stuck.

Any Ideas??

sharjeel
April 29th, 2010, 09:09 PM
I have been able to boot into my computer with accelerated graphics using an older kernel. To this point, it seems that the kernel could have some issue.
I also noticed that xorg.conf had been renamed to xorg.conf~. Does someone know if that is to be expected? Does Lucid use some other way for configuring X?

nucleuskore
April 29th, 2010, 09:22 PM
Eureka !!

I have a HP Pavilion SLimline s7727c

with lspci giving me
VGA compatible controller: nVidia Corporation C51 [GeForce 6150 LE] (rev a2)

I was getting a blank screen (out of sync) on booting from the live cd.

I worked around the problem as follows:


At install screen press F6 and select nomodeset and install Ubuntu as usual.
On first boot after install, press e on getting the GRUB bootloader.
Using arrow keys navigate to and delete quiet and splash and type the word nomodeset in their place
Press Ctrl and X to boot
You should now be able to login to your Ubuntu as usual

For those of you who do not know what to do next, in the taskbar click on System->Administration->Hardware drivers, and select and activate the nvidia current driver if you have an nvidia card like I do. The driver will be downloaded and activated automatically, and you will be prompted for a reboot.

Fire_Chief
April 30th, 2010, 03:54 AM
Perfectly brilliant!

Thank you nucleuskore! That worked for getting me into the desktop. Currently installing the restricted driver (have an Nvidia 9600GT). Here's hoping for proper working boot after this update.

Thanks!

LostOverThere
April 30th, 2010, 11:22 AM
Thank-you nucleuskore! It worked like a charm! I really appreciate it! (1440x900 display here with an old Nvidia Geforce 4)

jaycee23
April 30th, 2010, 12:51 PM
Update - now have final version of 10.04LTS. This is for people with issues with ATI GPU and blank screens (no signal) on boot up

Same issue blank screen after initial boot screen HOWEVER

- switched to DVI connection instead of HDMI and it boots fine
- installed restricted driver for ATI
- reboot
- switch back to HDMI connection only

All is well, no more blank screen on boot up and restricted driver working well without any issues.

Woohoo

:P

jasidog
April 30th, 2010, 04:10 PM
Just to confirm what jaycee said about newer ATI cards.

Using an ATI 5870 and two monitors had the same problem.

After trying with just one monitor in a specific dvi port the live cd booted correctly.

So thanks for the advice folks, you're life savers! :)

Course at the moment I'm only assuming once I install this holds true and that changing to the proprietary ATI drivers will get me back to two monitors.

When I get chance to install later I'll edit here to confirm or not.

-------

Confirmed

saliflo
April 30th, 2010, 04:54 PM
nukleuscore. You are great.

nucleuskore
April 30th, 2010, 06:14 PM
No I am not great. I am happy to be of some help to you and all who benefited from this little insight. It is however quite annoying to see things like this

http://www.ubuntugeek.com/how-to-fix-ubuntu-10-04-lts-lucid-blank-screen-at-startup.html

copy/paste verbatim from this thread with no bank link to the reference.

Reference acknowledged, thank you

ImpressMe
April 30th, 2010, 06:21 PM
I burned Kubuntu and Ubuntu 10.04 on CD's, booting them both as LiveCD's both ends with a blank screen.

They expect end users to deal with this, editing GRUB files?

Ubuntu worked on this machine for years.

kirenpillay
April 30th, 2010, 08:23 PM
Hi

It looks like the driver is using the wrong connector as the primary. I have an ATI Radeon 5850 with two screens connected.

The X seems to be displaying on the secondary screen instead of the first one. The first screen is blank.

Rasa1111
April 30th, 2010, 09:54 PM
I burned Kubuntu and Ubuntu 10.04 on CD's, booting them both as LiveCD's both ends with a blank screen.

They expect end users to deal with this, editing GRUB files?

Ubuntu worked on this machine for years.

I burned 4 before I finally figured it out (with lots of help)
and it was even easier than everyone thought...

have you done this..
When the cd starts, and gets to the Purple screen with the [keyboard]=(human) icons at the bottom...

when you see that screen, hit spacebar...

and just continue on normally from there..

if you havent already done that, give it a try..
it made a wordld of difference...

from 4 cd's going blank and giving me nothing...
to a fully installed perfect working lucid...

and all i had to do was hit spacebar to get to the 'install' screen.

weird, but it worked.

SabreWolfy
April 30th, 2010, 10:01 PM
No I am not great. I am happy to be of some help to you and all who benefited from this little insight. It is however quite annoying to see things like this

http://www.ubuntugeek.com/how-to-fix-ubuntu-10-04-lts-lucid-blank-screen-at-startup.html

copy/paste verbatim from this thread with no bank link to the reference.

I found this thread by following a link at the end of the UbuntuGeek.com post.

nucleuskore
April 30th, 2010, 11:35 PM
I found this thread by following a link at the end of the UbuntuGeek.com post.

Thanks, post edited

The-NightPhoenix
May 1st, 2010, 12:20 AM
i have the same problem but i don't have any ATI Cards !!!

its an old built in Intel Card . it was working fine on karmic :(


i tried to install it with nomodeset it installed . but the first boot grub doesnt show !!! it automaticly gows to the logo and then the blank screen

ScottRose
May 1st, 2010, 01:09 AM
Just wanted to give nucleuskore another "thanks". That was really painful, and yet so simple to resolve.

Scott

ieee488
May 1st, 2010, 01:30 AM
i have the same problem but i don't have any ATI Cards !!!

its an old built in Intel Card . it was working fine on karmic :(


i tried to install it with nomodeset it installed . but the first boot grub doesnt show !!! it automaticly gows to the logo and then the blank screen

Same thing here.

Trying the LiveCD on a Dell Latitude D400 which runs 9.10 just fine. This laptop has Intel 855GM chipset.

I am really really surprised at this blank screen problem.

I tried the suggestion about hitting the spacebar. Didn't make any difference.

Tried nucleuskore's suggestion. Didn't make any difference.

Ends up at blank screen at start up.



Not sure where to go from here.

grimsbyguy
May 1st, 2010, 01:45 AM
Updated my 9.10 64 bit and got the black screen (but ubuntu is running "underneath" that black veil as witnessed by a blind log in that worked and made appropriate sounds). Could not get it (video) working properly. Installed fresh - works perfectly. Go figure.

Icarus315
May 1st, 2010, 02:42 AM
Eureka !!

I have a HP Pavilion SLimline s7727c

with lspci giving me
VGA compatible controller: nVidia Corporation C51 [GeForce 6150 LE] (rev a2)

I was getting a blank screen (out of sync) on booting from the live cd.

I worked around the problem as follows:


At install screen press F6 and select nomodeset and install Ubuntu as usual.
On first boot after install, press e on getting the GRUB bootloader.
Using arrow keys navigate to and delete quiet and splash and type the word nomodeset in their place
Press Ctrl and X to boot
You should now be able to login to your Ubuntu as usual

For those of you who do not know what to do next, in the taskbar click on System->Administration->Hardware drivers, and select and activate the nvidia current driver if you have an nvidia card like I do. The driver will be downloaded and activated automatically, and you will be prompted for a reboot.

Thank you so much! These instructions got my parents computer going just perfect! Again, you made all the difference for me today! Thanks.

Bill.

Paul41
May 1st, 2010, 03:38 AM
Same thing here.

Trying the LiveCD on a Dell Latitude D400 which runs 9.10 just fine. This laptop has Intel 855GM chipset.

I am really really surprised at this blank screen problem.

I tried the suggestion about hitting the spacebar. Didn't make any difference.

Tried nucleuskore's suggestion. Didn't make any difference.

Ends up at blank screen at start up.



Not sure where to go from here.

I'm stuck with the same problem

Darque1137
May 1st, 2010, 04:07 AM
I'm stuck with the same problem

Same here - old Dell 700m with Intel chipset. When I upgraded from 9.10, I was at least able to go from Grub to safemode. (I have no idea where you guys are using your grub tricks... all I can do is hit Escape and boot from failsafe.) I tried a fresh install from disc, and I get to the "ubuntu" screen with the five white/red dots showing progress, and then a black screen with nothing. Tried the "nomodeset" trick, nothing. Install utterly fails. So frustrating. I first installed Feisty Fawn on this computer, and I had to dig around everywhere to find a screen resolution hack that would let me see anything. Now, years later, there isn't even an operational workaround. Very, very frustrating. Do I really have to go through all this just to have a computer that only runs Firefox and OpenOffice?

twrock
May 1st, 2010, 05:09 AM
Same here - old Dell 700m with Intel chipset.

Yep, Dell 700m, blank screen. No deal.

It's a real bummer. I was hoping to make the move from 9.04 (I skipped 9.10) to an LTS version. Hopefully someone will come up with a realistic solution.

Hmm, maybe this should have been a 10.06 version, similar to the release of Dapper.

twrock
May 1st, 2010, 06:37 AM
(NOTE: please see Post #38 below for something that worked much more simply on my Dell 700m.)

I'm back. Typing this post from within 10.04 on my Dell 700m. This may be premature (i.e. I won't be able to get things working after an install, etc.), but at least I'm in to something that works with the Live CD (actually a Live USB stick).

I got this from another source that I don't have the link to at this moment, so credit goes elsewhere. Here's what worked for me.

1. When you see the purple box with the little keyboard and person, hit a key to enter options.
2. Choose your language.
3. Verify you have chosen "Try Ubuntu without any changes."
4. Press F6.
5. Press Esc to get out of the menu that pops up.
6. Go to the end of the commandline (with arrow keys if necessary) and type: "i915.modeset=1" (If this doesn't work, try "i915.modeset=0" instead.)
7. Hit Enter and pray hard.

That got me in; I hope it works for you.

[More edits] Here's a link with a bunch of info: https://wiki.ubuntu.com/X/Bugs/Lucidi8xxFreezes
I tried Workaround A. It works, but it has other problems on my Dell 700m. Now at each boot, I get an error message. I then choose to "Restart X" and things are fine after that. But I really don't want an extra step on each boot, so I'll keep working on it.

[And yet more edits] I think I got it! Instead of Restarting X on the boot error, I chose to Troubleshoot the error. Then I chose to Edit the configuration file. I changed "vesa" to "intel" and clicked ok. I rebooted. at the GRUB menu, I hit "e" and worked down to the end of the line that has "quiet splash" and added "i915.modeset=1" (no quotes). I hit Ctrl-X and everything went without a hitch! So now I just need to edit my GRUB configuration file to make that permanent, and I should be in business. So a combination of Workaround A, editing the configuration file, and editing the GRUB configuration should finally work for me.

As always, YMMV.

westbarbary
May 1st, 2010, 08:19 AM
I'm back. Typing this post from within 10.04 on my Dell 700m. This may be premature (i.e. I won't be able to get things working after an install, etc.), but at least I'm in to something that works with the Live CD (actually a Live USB stick). However, I only have 1024x768 resolution right now.

I got this from another source that I don't have the link to at this moment, so credit goes elsewhere. Here's what worked for me.

1. When you see the purple box with the little keyboard and person, hit a key to enter options.
2. Choose your language.
3. Verify you have chosen "Try Ubuntu without any changes."
4. Press F6.
5. Press Esc to get out of the menu that pops up.
6. Go to the end of the commandline (with arrow keys if necessary) and type: "i915.modeset=0 xforcevesa" (no quotes; that is a zero, not a capital O; I also was able to boot without "xforcevesa" at the end).
7. Hit Enter and pray hard.

That got me in; I hope it works for you.

[Edit] After installation (in which I kept my /home partition), I was able to reboot into my new system. However, the monitor is not detected and I am still operating in 1024x768 mode (instead of the possible 1280x800 mode it is supposed to support). But it "works".

I am having a similar problem. After upgrading on my Dell Inspiron 510m I get the Ubuntu start screen with the moving dots for a short period before the entire screen goes blank and the computer unresponsive. I have tried most of the advice on this forum but none has met with any success. My graphics on the Dell are onboard and I have had no trouble at all with previous installations. Does anyone have any ideas?

Unicast
May 1st, 2010, 08:34 AM
I'm back. Typing this post from within 10.04 on my Dell 700m. This may be premature (i.e. I won't be able to get things working after an install, etc.), but at least I'm in to something that works with the Live CD (actually a Live USB stick). However, I only have 1024x768 resolution right now.

I got this from another source that I don't have the link to at this moment, so credit goes elsewhere. Here's what worked for me.

1. When you see the purple box with the little keyboard and person, hit a key to enter options.
2. Choose your language.
3. Verify you have chosen "Try Ubuntu without any changes."
4. Press F6.
5. Press Esc to get out of the menu that pops up.
6. Go to the end of the commandline (with arrow keys if necessary) and type: "i915.modeset=0 xforcevesa" (no quotes; that is a zero, not a capital O; I also was able to boot without "xforcevesa" at the end).
7. Hit Enter and pray hard.

That got me in; I hope it works for you.

[Edit] After installation (in which I kept my /home partition), I was able to reboot into my new system. However, the monitor is not detected and I am still operating in 1024x768 mode (instead of the possible 1280x800 mode it is supposed to support). But it "works".

Or try the kernel option "i915.modeset=1" without the "xforcevesa" option.

Works like a charm for me on my D400.

If it works you can make the changes permanent: http://ubuntuforums.org/showpost.php?p=9171045&postcount=11

Rackstar
May 1st, 2010, 10:24 AM
Did anyone file a bugreport?

I did: https://bugs.launchpad.net/ubuntu/+bug/572868

Please click "this affects me too" to get some attention.

twrock
May 1st, 2010, 10:45 AM
Or try the kernel option "i915.modeset=1" without the "xforcevesa" option.

Works like a charm for me on my D400.

If it works you can make the changes permanent: http://ubuntuforums.org/showpost.php?p=9171045&postcount=11

Yes, it does work. I've been working on this all day. I just got done reinstalling to see what the truly necessary steps would be for a fresh install on my Dell 700m.

If I add "i915.modeset=1" to the the boot from a USB stick (I suppose CD will be the same), I then end up at the error screen "Ubuntu is running in low graphics mode". I clicked OK, then "Troubleshoot the error" then "Edit configuration", then edited "vesa" to "intel". Then I "closed", "cancelled" and the hit "Restart X". That got me into live mode with full screen support. Once there, I installed as usual.

After reboot, I hit "e" at the GRUB screen, and added "i915.modeset=1" at the end of the line with "quiet splash". Then hit Ctrl-X to finish booting. It all went off without a hitch.

So now I will edit my GRUB configuration to make it permanent, and everything will be done.

I'll leave what I wrote above, because maybe something there will be useful for some other hardware. But for the Dell 700m (Intel 855GM chip), it is that simple.

Leischa
May 1st, 2010, 10:53 AM
Eureka !!

I have a HP Pavilion SLimline s7727c

with lspci giving me
VGA compatible controller: nVidia Corporation C51 [GeForce 6150 LE] (rev a2)

I was getting a blank screen (out of sync) on booting from the live cd.

I worked around the problem as follows:


At install screen press F6 and select nomodeset and install Ubuntu as usual.
On first boot after install, press e on getting the GRUB bootloader.
Using arrow keys navigate to and delete quiet and splash and type the word nomodeset in their place
Press Ctrl and X to boot
You should now be able to login to your Ubuntu as usual

For those of you who do not know what to do next, in the taskbar click on System->Administration->Hardware drivers, and select and activate the nvidia current driver if you have an nvidia card like I do. The driver will be downloaded and activated automatically, and you will be prompted for a reboot.

I just did that and it still doesn't work. I think this is a really poor show by Ubuntu.

jdoor0
May 1st, 2010, 01:49 PM
Hello,

I have a Dell Inspiron 510m with the same "black-screen" problem as described here. I got the solution from this page: https://wiki.ubuntu.com/X/Bugs/Lucidi8xxFreezes

When booting, I pressed ESC as soon as GRUB displayed its message, then I selected the first line mentioning "recovery" (normally that is the second line, the first line is a "standard" boot) and pressed ENTER. This boots Linux in recovery mode (so you'll see lots of debugging info scrolling by, and maybe one or more of your harddisks will get checked through fsck, which may take a few minutes). Then, a menu will appear, of which I selected the first entry (continue booting, or something like that). Then, on the login prompt, I entered my login and password. From then on, I followed the instructions of workaround A (see link above) and then entered "reboot". The system restarted, and succesfully got to the graphical login. Hope this helps for some other "victims"...

Rasa1111
May 1st, 2010, 01:55 PM
Yes, it does work. I've been working on this all day. I just got done reinstalling to see what the truly necessary steps would be for a fresh install on my Dell 700m.

If I add "i915.modeset=1" to the the boot from a USB stick (I suppose CD will be the same), I then end up at the error screen "Ubuntu is running in low graphics mode". I clicked OK, then "Troubleshoot the error" then "Edit configuration", then edited "vesa" to "intel". Then I "closed", "cancelled" and the hit "Restart X". That got me into live mode with full screen support. Once there, I installed as usual.

After reboot, I hit "e" at the GRUB screen, and added "i915.modeset=1" at the end of the line with "quiet splash". Then hit Ctrl-X to finish booting. It all went off without a hitch.

So now I will edit my GRUB configuration to make it permanent, and everything will be done.

I'll leave what I wrote above, because maybe something there will be useful for some other hardware. But for the Dell 700m, it is that simple.

well done!! :KS

ieee488
May 1st, 2010, 03:20 PM
Yes, it does work. I've been working on this all day. I just got done reinstalling to see what the truly necessary steps would be for a fresh install on my Dell 700m.

If I add "i915.modeset=1" to the the boot from a USB stick (I suppose CD will be the same), I then end up at the error screen "Ubuntu is running in low graphics mode". I clicked OK, then "Troubleshoot the error" then "Edit configuration", then edited "vesa" to "intel". Then I "closed", "cancelled" and the hit "Restart X". That got me into live mode with full screen support. Once there, I installed as usual.

After reboot, I hit "e" at the GRUB screen, and added "i915.modeset=1" at the end of the line with "quiet splash". Then hit Ctrl-X to finish booting. It all went off without a hitch.

So now I will edit my GRUB configuration to make it permanent, and everything will be done.

I'll leave what I wrote above, because maybe something there will be useful for some other hardware. But for the Dell 700m, it is that simple.

Thank you!

I didn't get the error screen about running in low graphics mode that you encountered, but everything else is as you described.

My Dell Latitude D400 is running 10.04 Lucid Lynx now. :)
And I am also able to boot into Windows XP from grub. Whew! Was worried that that broke.

romulus
May 1st, 2010, 04:57 PM
Thnx nucleuskore this is working for me too (Nvidia 7040 integrated graphics)

tarjxvf
May 1st, 2010, 05:29 PM
Exactly same issue here - installed no problem on my Nvidia containing laptop. Using a HDMI connection for the visuals.

My specs are in my signature. Must be an ATI problem. Hopefully they will sort it for the full release later this week!!!

Mine is the opposite. No problem in my laptop with ATI HD3200, while the screen went blank for my desktop with NVIDIA 9600GT.

arterio
May 1st, 2010, 06:27 PM
Well I've resorted to keeping Windows 7 on my desktop and installed Ubuntu on my laptop. 9.10 works great on my laptop, however 10.04LTS does not. I have multiple issues, mostly to do with my wireless.

DougRM
May 1st, 2010, 10:05 PM
Thanks everyone for the tips. Though if someone could help me clarify a few things I am not as technically minded.

GRUB?

I have managed to work through these steps

1. When you see the purple box with the little keyboard and person, hit a key to enter options.
2. Choose your language.
3. Verify you have chosen "Try Ubuntu without any changes."
4. Press F6.
5. Press Esc to get out of the menu that pops up.
6. Go to the end of the commandline (with arrow keys if necessary) and type: "i915.modeset=0 xforcevesa" (no quotes; that is a zero, not a capital O; I also was able to boot without "xforcevesa" at the end).
7. Hit Enter and pray hard.

but when I get to the suggestions about

On first boot after install, press e on getting the GRUB bootloader.
Using arrow keys navigate to and delete quiet and splash and type the word nomodeset in their place
Press Ctrl and X to boot
You should now be able to login to your Ubuntu as usual

Can someone explain those steps in a little more detail for someone who is ignorant on computers. thanks

I have a Dell 700m Insperon

ieee488
May 1st, 2010, 11:31 PM
but when I get to the suggestions about

On first boot after install, press e on getting the GRUB bootloader.
Using arrow keys navigate to and delete quiet and splash and type the word nomodeset in their place
Press Ctrl and X to boot
You should now be able to login to your Ubuntu as usual

Can someone explain those steps in a little more detail for someone who is ignorant on computers. thanks

I have a Dell 700m Insperon

The instructions are pretty self-explanatory. I don't know how they can be any clearer short of doing a video, and I don't plan on doing that.
There is a typo in #6. It should be i915.modeset=1

I am not sure why you are wanting to type nomodeset. That won't work for your Dell. You are confusing two different solutions.

6String.
May 1st, 2010, 11:55 PM
Dell 710m, same issue...

Fixed it thanks. :)

Rasa1111
May 2nd, 2010, 12:08 AM
The instructions are pretty self-explanatory. I don't know how they can be any clearer short of doing a video, and I don't plan on doing that.
There is a typo in #6. It should be i915.modeset=1

I am not sure why you are wanting to type nomodeset. That won't work for your Dell. You are confusing two different solutions.

actually...

to a n00b,
no , they really aren't that self explanatory.

Ive got my lucid working now finally (for the most part)..

and I do understand most of the instructions I am given to fix things...
and i dont quite understand that myself.

I think there would be a way to explain it easier for a n00b...
and i dont think telling the ' Its pretty self explanatory" instead of actually making (or trying) to make it easier for them.. is much help.

thanks anyway though.

ieee488
May 2nd, 2010, 12:19 AM
actually...

to a n00b,
no , they really aren't that self explanatory.

Ive got my lucid working now finally (for the most part)..

and I do understand most of the instructions I am given to fix things...
and i dont quite understand that myself.

I think there would be a way to explain it easier for a n00b...
and i dont think telling the ' Its pretty self explanatory" instead of actually making (or trying) to make it easier for them.. is much help.

thanks anyway though.

I can't think of how to make it any easier with words. A video would be helpful or a step by step instruction with pictures would be helpful. Maybe you or someone would want to make one and put it up on Youtube.

I thought twrock did an excellent job, and because of that, I have a working Lucid Lynx on my D400.

twrock
May 2nd, 2010, 01:17 AM
Thanks everyone for the tips. Though if someone could help me clarify a few things I am not as technically minded.
<snip>

I have a Dell 700m Insperon

Doug, here's a post I wrote from a thread dedicated to the 700m. See if it helps.
http://ubuntuforums.org/showpost.php?p=9207957&postcount=12

jivana
May 2nd, 2010, 01:58 AM
(

[More edits] Here's a link with a bunch of info: https://wiki.ubuntu.com/X/Bugs/Lucidi8xxFreezes
I tried Workaround A. It works, but it has other problems on my Dell 700m. Now at each boot, I get an error message. I then choose to "Restart X" and things are fine after that. But I really don't want an extra step on each boot, so I'll keep working on it.

[And yet more edits] I think I got it! Instead of Restarting X on the boot error, I chose to Troubleshoot the error. Then I chose to Edit the configuration file. I changed "vesa" to "intel" and clicked ok. I rebooted. at the GRUB menu, I hit "e" and worked down to the end of the line that has "quiet splash" and added "i915.modeset=1" (no quotes). I hit Ctrl-X and everything went without a hitch! So now I just need to edit my GRUB configuration file to make that permanent, and I should be in business. So a combination of Workaround A, editing the configuration file, and editing the GRUB configuration should finally work for me.

As always, YMMV.


Thanks so much, workaround A did it for me, this is a great link for everyone running the Intel 855 graphics chip, which seems to have been blacklisted in Lucid.
I already had Lucid installed, but could not boot. Booting the alternate CD, going to Rescue system, working your way through the screens (defaults did it for me), until you can execute a shell on your drive. Choose that option, type what it says above under workaround A - ignore errors (I got 'could not resolve ...' ), when you've executed the commands use Exit to get out of the shell, take out the CD and use Reboot the system or similar, all was good on my system.
Edit: The system reboots, but still problems playing video from the browser, e.g. .wmv files, also after following the steps in https://help.ubuntu.com/community/Medibuntu
Still investigating.
Life is still better than without being able to boot - good luck!

zzyzx1
May 2nd, 2010, 03:01 AM
i HOPE nobody marks this as SOLVED. I still havent seen a fix for the ATI folks (whithout having to do a fresh install) The Live CD boots just fine with graphics. Let me clarify whats going on with *Upgrade* -

Dell Zino with ATI Mobility Radeon HD 4000 Series GDU. Running the ATI drivers for Linux. Works GREAT in 9.04-9.10. I was running 9.10 and did the *upgrade* to 10.04. NONE of the recommendation have made any sort of dent in this.

This is really a serious issue for ATI users, especially for ones that have tweeted and facebooked abot the big * upgrade* for months.

Why wasnt there more caution flags thrown up on this?? NOWHERE NEAR READY for primetime.

Appreciate any help.

Thank you!

gohanssjn
May 2nd, 2010, 03:30 AM
i HOPE nobody marks this as SOLVED. I still havent seen a fix for the ATI folks (whithout having to do a fresh install) The Live CD boots just fine with graphics. Let me clarify whats going on with *Upgrade* -

Dell Zino with ATI Mobility Radeon HD 4000 Series GDU. Running the ATI drivers for Linux. Works GREAT in 9.04-9.10. I was running 9.10 and did the *upgrade* to 10.04. NONE of the recommendation have made any sort of dent in this.

This is really a serious issue for ATI users, especially for ones that have tweeted and facebooked abot the big * upgrade* for months.

Why wasnt there more caution flags thrown up on this?? NOWHERE NEAR READY for primetime.

Appreciate any help.

Thank you!

Hmmm. My tablet (Dell Latitude XT) works with the nomodeset fix. ATI x1250 inside. However, I don't know how to install any ATI drivers to see if it works without that switch.

twrock
May 2nd, 2010, 08:10 AM
There is a typo in #6. It should be i915.modeset=1


Yeah, this is a real conundrum for me. I did go back and change that, even though I didn't really want to. Because once that step is different, it affects the rest of the process. So doing it one way might work for some machines, but doing it yet another way might be the only way to get things to work for someone else.

I'm on another thread dedicated to the Dell 700m only, and someone there is getting different results on the same machine! So who knows what's going to work.

Basically, it seems that i915.modeset=0 will get some people in, but only up to 1024x768 resolution and only a square screen. i195.modeset=1 will get the widescreen working for some. I'm not sure for whom "xforcevesa" is necessary, but it might be helpful for some. Knowing that some machines might need to have xorg.conf edited to change "vesa" to "intel" is probably going to be important for yet someone else.

So the wiki is correct (https://wiki.ubuntu.com/X/Bugs/Lucidi8xxFreezes). There is not yet a universal solution, and the best we can do at the moment is treat each problem as a new one. I thought I had found a reproducible solution for the Dell 700m, but maybe I'm wrong about even that.

So as always, YMMV. :)

SabreWolfy
May 2nd, 2010, 08:39 AM
Why do such fundamental problems still exist in the latest release? :( It's so frustrating. How can I possibly motivate to friends and family to try/use Ubuntu with problems like this? Can you imagine "moms and pops" trying to adjust boot parameters just to get Ubuntu working? :( Or the impression a blank screen creates on the first boot of this great new, free operating system?

Unicast
May 2nd, 2010, 09:16 AM
Hmmmm....

Even with the "i915.modeset=1" kernel option I have been getting occasional black screens with X trying to restart (unsuccessfully) in low res mode.

I've taken the extreme step of installing a newer kernel (2.6.34-020634rc6) and removed the above kernel option from grub.

Still testing, but seems more stable than the stock kernel that ships with Lucid.

IcyPhoenix
May 2nd, 2010, 07:02 PM
I am glad to see many folks here have resolved this problem. However, I have still not come much closer to a reasonable solution.

I did a fresh install with the official release version, hoping the ATI issue was confined to the RC, but I'm still having the same issue.

Today I decided to try something, so I got my old spare CRT monitor out of the closet and set it up. I plugged it into my laptop's VGA port, and.....

I GOT VIDEO!! :)

ON BOTH SCREENS!! :confused:

So, why is it that my laptop cannot boot into Ubuntu 10.04 with any video, but if I plug in my Dell E773c (16" CRT monitor), it displays video perfectly fine ON BOTH SCREENS?!?!?!

I even went into the Monitor settings and messed around with the dual-monitor options, and everything works fine. If I unplug the CRT, my laptop's display still works by itself, until the next reboot.

So, basically, I've got it working, as long as I boot my laptop while the CRT is plugged into the VGA port. :(

Does anybody know how I can determine EXACTLY what model of video card is in my laptop, short of opening up the case? I'll do that if I have to, but if there's an easier way, I'd love to know.

Also, I've heard that I may get some good results from disabling KMS by using the "radeon.modeset=0" option. How do I try this and how do I edit the boot options to make this a permanent solution?

And on another note, I tried running System>Administration>Hardware Drivers to see if I could install a proprietary ATI driver. After about 2-3 minutes of searching for packages, it came back with "No proprietary drivers are in use on this system."

I'm so close to finding a solution, if anyone can help, that would be awesome. Thanks!

Covarrubias
May 2nd, 2010, 08:08 PM
I have an ATI 5770 and my monitor have a native resolution of 1920x1080 and can´t boot liveCD because after the orange dots at boot i get a black screen and can´t do anything from here.

¿someone with the same configuration can boot Lucid Lynx LiveCD?

For what i have read i think folks with Nvidia and Intel graphics can do (with tricks) but not ATI´s folks.

IcyPhoenix
May 2nd, 2010, 08:08 PM
Well, to my amazement, I still had the documentation from when I purchased my laptop. I usually keep things like that, but I thought it got misplaced when I moved about 5 years ago.

My video card details:

ATI Mobility Radeon 7000 Series (IGP 345M)
*Not to be confused with a slightly different model, the Radeon 7000 IGP*

Note: My laptop is of the "desktop replacement" variety. It is very heavy, and uses a desktop mobo with a P4 Desktop CPU in "portability mode" (essentially underclocked to reduce energy usage), rather than an actual Mobile CPU. It gets rather hot under full power, especially in its old age...

So, I have answered one of my three questions. Two still remain. I am not afraid of using command line options, but after 20 years of troubleshooting only Windows / DOS, I'm not sure where to begin with Ubuntu / Linux. I've been using it here and there since Hardy, but I've never encountered any problems until now.

How would I go about disabling KMS by using the "radeon.modeset=0" option?

Is there a proprietary ATI driver that I could install?

Thanks to everyone for your help so far! :)

drizzt001
May 2nd, 2010, 11:07 PM
You guys are lifesavers. I have finally been able to boot my laptop with the "i915.modeset=1" fix outlined above. Thank you soooo much!

ieee488
May 2nd, 2010, 11:30 PM
Hmmmm....

Even with the "i915.modeset=1" kernel option I have been getting occasional black screens with X trying to restart (unsuccessfully) in low res mode.

I've taken the extreme step of installing a newer kernel (2.6.34-020634rc6) and removed the above kernel option from grub.

Still testing, but seems more stable than the stock kernel that ships with Lucid.

Fortunately my D400 has shown no signs of the black screens with the multiple boots yesterday. My BIOS is A08.

cshannon1077
May 3rd, 2010, 04:21 AM
2 Newly burned CD's to install 10.04 would not even boot the PC.
Booted my new Toshiba laptop back to 9.1 and did the upgrade from there. Now 10.04 boots up to a black screen after the music. Even if I leave it on for an hour, it never changes. Ctrl+Alt+F1, etc... does nothing. Seems like this was released too soon again!!

swappa
May 3rd, 2010, 09:01 AM
Same problem here.
Ubuntu 10.4 x64 - two Dell monitors connected through DVI and VGA.
None of the workarounds is helping - using the latest Nvidia drivers.

This is a show stopper for me. Please advise.

irober02
May 3rd, 2010, 10:43 AM
It's a bummer that ATI graphic card support has slipped again. It was really good for 9.10. However, a quick work around for me was to copy my old xorg.conf file over the top of the one that the dist upgrade created and I'm back in business! :-)

Perhaps I'll need to check if that old xorg.conf is optimally configured for the new distro but if it works I probably won't bother. I've been enjoying a life without worrying about xorg.conf! ;-)

Svictor
May 3rd, 2010, 11:36 AM
Yes, it does work. I've been working on this all day. I just got done reinstalling to see what the truly necessary steps would be for a fresh install on my Dell 700m.

If I add "i915.modeset=1" to the the boot from a USB stick (I suppose CD will be the same), I then end up at the error screen "Ubuntu is running in low graphics mode". I clicked OK, then "Troubleshoot the error" then "Edit configuration", then edited "vesa" to "intel". Then I "closed", "cancelled" and the hit "Restart X". That got me into live mode with full screen support. Once there, I installed as usual.

After reboot, I hit "e" at the GRUB screen, and added "i915.modeset=1" at the end of the line with "quiet splash". Then hit Ctrl-X to finish booting. It all went off without a hitch.

Great ! Thank you very much ! It worked for me as well on a Dell D400.

The trouble with these bugs is that they cast a serious shadow for the newcomers on ubuntu. I was installing Lucid on my friend's computer who is not quite as "geek" as I am. I was precisely saying "and you'll see, Linux has become very smooth to use now" when the screen got blank... The half an hour or so spent in finding a solution (until I came to this post) did not reassure her at all. But well, I suppose this is a discussion for another thread.
Thanks again for sharing this knowledge !

hellomoto
May 3rd, 2010, 07:59 PM
http://ubuntuforums.org/showthread.php?t=1468152&page=3 Hope this helps!

Check that your BIOS hasn't got a floppy disk enabled if you are experiencing a poor boot time after log in

mhbell
May 3rd, 2010, 08:29 PM
None of the beta's worked and neither did the release on a compaq presario desktop computer with AMD 64 cpu 2 gigabyte ram and 360 GB HD grafics is a Nvidia 6150 LE built in Monitor is a Visio HDtv 26 inch. I keep getting a blank screen or a no signal once in awhile I can get the first screen and when I tell it to run with out making changes to my system it starts and then the screen shuts down with no signal and then starts up again then it goes to sleep and I get a blank screen. I know that it has finished booting up because I get the boot sound when it is supposed to show the desktop but all I get is a blank screen. It is a graphics problem Monitor or graphics card. I don't know which. 9:10 is working flawlessly for me, but I want a LTR Don't know what to do have tried all of the help codes noapic, ect.
MH:
confused:

irober02
May 3rd, 2010, 11:09 PM
On closer inspection the only difference between my good xorg.conf file and the bad one that the distribution upgrade made was the line that read "Virtual 2048 779".

My xorg.conf file now reads:

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Virtual 1400 1861
EndSubSection
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "ati"
EndSection

Section "ServerFlags"
Option "DontZap" "False"
EndSection

nucleuskore
May 4th, 2010, 02:45 AM
@mhbell do you see the grub bootloader onscreen at boot. If yes follow post number 14 in this thread

Manganic
May 4th, 2010, 05:52 AM
Well, to my amazement, I still had the documentation from when I purchased my laptop. I usually keep things like that, but I thought it got misplaced when I moved about 5 years ago.

My video card details:

ATI Mobility Radeon 7000 Series (IGP 345M)
*Not to be confused with a slightly different model, the Radeon 7000 IGP*

Note: My laptop is of the "desktop replacement" variety. It is very heavy, and uses a desktop mobo with a P4 Desktop CPU in "portability mode" (essentially underclocked to reduce energy usage), rather than an actual Mobile CPU. It gets rather hot under full power, especially in its old age...

So, I have answered one of my three questions. Two still remain. I am not afraid of using command line options, but after 20 years of troubleshooting only Windows / DOS, I'm not sure where to begin with Ubuntu / Linux. I've been using it here and there since Hardy, but I've never encountered any problems until now.

How would I go about disabling KMS by using the "radeon.modeset=0" option?

Is there a proprietary ATI driver that I could install?

Thanks to everyone for your help so far! :)

I'm also experiencing this issue on my laptop (LG R405 with ATI Radeon Xpress 1250). I have managed somewhat of a workaround:


Hold down left-shift on boot to enter GRUB
hit "e" to edit the kernel
remove "quiet splash" and replace with "nomodeset single"
control-x to boot

(http://bugs.launchpad.net/ubuntu/+source/grub2/+bugs/511130)

A system recovery screen appears, I selected "start ubuntu normally" (or whatever option is similar) which put me through to a shell login prompt. After logging in to the basic shell I typed:


sbritton@Zarniwoop:~$ sudo /etc/init.d/gdm start

Which, much to my surprise, launched the Lucid Lynx gui.

I'm using the standard drivers for my video card (I attempted, but failed to install ATI's catalyst control center.)

Where I'm at now is trying to figure out what changes I need to make to what files to get this gui to launch from boot. Hopefully this helps and moves us forward a bit. If anyone can make any suggestions towards what I did to get the to work this way, and what changes I can make to get this system working, I'd appreciate it!

Darque1137
May 4th, 2010, 10:06 AM
Update: I did manage to get Lucid working on my venerable Dell 700m with the Intel chipset, using the i915 modeset workaround. Apparently I was having trouble getting this to work in grub because of a separate problem with grub, which was fixed and then startup commenced.

Now Flash doesn't work in Firefox. Sigh. Maybe it's time to replace old Maribelle.

Manganic
May 4th, 2010, 02:57 PM
For me, I seem to have found the workaround.

First, credit where credit is due:

http://ubuntuforums.org/showthread.php?p=9221567

So, to make this change (remember to ALWAYS preserve a backup of your files)



sbritton@Zarniwoop:~$ cd /etc/default
sbritton@Zarniwoop:/etc/default$ sudo gedit grub


The editor will come up

Locate this line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Change it to:
GRUB_CMDLINE_LINUX_DEFAULT="radeon.modeset=0 quiet splash"

Save, reboot, and voila!

When Lucid is installed, it defaults to KMS - Kernel Mode Setting, which means the Kernel determines the graphics mode to launch in. It seems that ATI cards don't like this and cause the Blank Screen of Death(tm).

Further reading:
https://wiki.ubuntu.com/X/KernelModeSetting

Further note: I make no promises as to whether this change will work on "your" system. All I know is that it worked for me.

ppepperr
May 4th, 2010, 04:25 PM
For me, I seem to have found the workaround.

First, credit where credit is due:

http://ubuntuforums.org/showthread.php?p=9221567

So, to make this change (remember to ALWAYS preserve a backup of your files)



sbritton@Zarniwoop:~$ cd /etc/default
sbritton@Zarniwoop:/etc/default$ sudo gedit grub


The editor will come up

Locate this line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Change it to:
GRUB_CMDLINE_LINUX_DEFAULT="radeon.modeset=0 quiet splash"

Save, reboot, and voila!

When Lucid is installed, it defaults to KMS - Kernel Mode Setting, which means the Kernel determines the graphics mode to launch in. It seems that ATI cards don't like this and cause the Blank Screen of Death(tm).

Further reading:
https://wiki.ubuntu.com/X/KernelModeSetting

Further note: I make no promises as to whether this change will work on "your" system. All I know is that it worked for me.
Hi new kid on the block. Been using Ubuntu without issue for 3 years on my Samsung R60 Plus laptop. Upgrade to 9.10 went without a hitch so I was extremely disappointed with upgrade to 10.04. Spent too long researching the issue and reverted to 9.10 before seeing this thread/post. Many thanks to Manganic your solution appears to be working. Lets hope the ATI issue is solved soon. Newbies shouldn't have to play around with GRUB.

KingJeremy
May 4th, 2010, 05:12 PM
I'll be trying nucleuskore's Eureka Fix when I get home this evening, but in just scanning this thread, I haven't seen my specific problem mentioned - my screen only stays blank if the laptop isn't plugged into the power cord on bootup. Plugged in, it boots up just fine.

I have an HP tx2110 tablet and I upgraded to 10.04 from 9.10. If anyone else happens to have a similar problem, I'd be interested in hearing as much.

twrock
May 5th, 2010, 01:32 AM
Update: I did manage to get Lucid working on my venerable Dell 700m with the Intel chipset, using the i915 modeset workaround. Apparently I was having trouble getting this to work in grub because of a separate problem with grub, which was fixed and then startup commenced.

Now Flash doesn't work in Firefox. Sigh. Maybe it's time to replace old Maribelle.

Downgrading to Karmic worked fine for me. ;)

I just don't have the time to mess with it anymore. I'm sure they'll get this all worked out before 9.10 is EOL'ed.

KingJeremy
May 5th, 2010, 01:57 AM
I'll be trying nucleuskore's Eureka Fix when I get home this evening, but in just scanning this thread, I haven't seen my specific problem mentioned - my screen only stays blank if the laptop isn't plugged into the power cord on bootup. Plugged in, it boots up just fine.

I have an HP tx2110 tablet and I upgraded to 10.04 from 9.10. If anyone else happens to have a similar problem, I'd be interested in hearing as much.

Well, that didn't work. If my laptop isn't plugged in when I boot up, my screen stays black. Which is funny, because I can still log in, I just can't see anything.

Anybody having this problem?

sharkey77
May 5th, 2010, 06:25 AM
I did an upgrade on a Gateway MX6131 from 9.10 to 10.04 through the update manager.

To edit Grub I have to hold shift and keep pressing escape during boot. If I just hold shift Grub quickly flashes on the screen then goes to the Ubuntu Splash screen then to the blank screen.

I erased quiet splash and replaced with nomodeset but the problem persists.

I can get into Ubuntu by choosing Recovery Mode> failsafex> run ubuntu in low graphics mode for one session but can not use the other options to change any settings or view the log files (an empty window opens up).

How do I find the correct nomodeset setting to use with my graphics card so I don't have to choose failsafex everytime?

Thanks for your help.


Video Intel® Extreme 2 Graphics
Screen 15.4-inch Widescreen Ultrabright TFT WXGA

KingJeremy
May 5th, 2010, 07:18 AM
So, I disabled the Nvidia (current version) driver and rebooted w/o the power cord plugged in and it booted up fine. With the driver activated, I get the Blank Screen of Death(tm) if I start the computer without being plugged in. Weird stuff. I'll keep an eye here if anyone reports a similar problem, or a solution.

sharkey77
May 5th, 2010, 07:20 AM
I followed the steps in http://ubuntuforums.org/showpost.php?p=9171045&postcount=11 but it didn't help. I went to https://wiki.ubuntu.com/X/KernelModeSetting but don't know how to check my driver.

This is my grub file:


# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

I ran sudo update-grub after saving the above changes.

sharkey77
May 5th, 2010, 07:32 AM
If I read this correct I too have the 855GM chipset

lshw

*-display:0 UNCLAIMED
description: VGA compatible controller
product: 82852/855GM Integrated Graphics Device
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list
configuration: latency=0
resources: memory:e8000000-efffffff(prefetchable) memory:e0000000-e007ffff ioport:1800(size=8)
*-display:1 UNCLAIMED
description: Display controller
product: 82852/855GM Integrated Graphics Device
vendor: Intel Corporation
physical id: 2.1
bus info: pci@0000:00:02.1
version: 02
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list
configuration: latency=0
resources: memory:f0000000-f7ffffff(prefetchable) memory:e0080000-e00fffff


lsmod

intel_agp 24177 2 i915
video 17375 1 i915
output 1871 1 video

lspci

00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

twrock
May 5th, 2010, 11:19 AM
I followed the steps in http://ubuntuforums.org/showpost.php?p=9171045&postcount=11 but it didn't help. I went to https://wiki.ubuntu.com/X/KernelModeSetting but don't know how to check my driver.

This is my grub file:


# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

I ran sudo update-grub after saving the above changes.
Looks like you have the same line in there twice.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1"

Delete the one in red and add i915.modeset=1 to the already existing line that ends in "quiet splash".

That's my guess.

sharkey77
May 6th, 2010, 04:00 AM
You had me happy, I thought a simple error in my tiredness was to blame but I changed it and still no luck.



# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

sharkey77
May 6th, 2010, 05:07 AM
When I hold shift and the choose e on Grub I see that the changes I made are not saved, if I manually input i915.modeset=1 it boots fine.

Nevermind..... Just found the problem, I was running sudo update-grub in the same terminal without FIRST closing gedit so the command never actually ran even though the grub file was saved. I was tired.

fitoo.
May 8th, 2010, 04:21 PM
does it work for intel 945 PL? i have the same problem, the black screen when boot linux....

Jrichalot
May 17th, 2010, 12:41 PM
(NOTE: please see Post #38 below for something that worked much more simply on my Dell 700m.)

... So now I just need to edit my GRUB configuration file to make that permanent, and I should be in business. So a combination of Workaround A, editing the configuration file, and editing the GRUB configuration should finally work for me.

As always, YMMV.

Thank you very much for this fix. I am running 10.04 quite happily on a D400 now (a few more fixes needed for wireless and video but I´ll get there ;o)

Could you tell me/us which config file you entered the i915.modeset=1 option in to make it permanent.

I have tried a few of the files under /etc/grub.d/ (40_custom is a strong candidate) but they are all in a scripting language I am not familiar with and simply typing the line in does not pass the parameter to the main grub.cfg file (that now says DO NOT EDIT in big bold letters at the top!)

Thanks for any help you can give.

J.

Manganic
May 17th, 2010, 02:25 PM
Thank you very much for this fix. I am running 10.04 quite happily on a D400 now (a few more fixes needed for wireless and video but I´ll get there ;o)

Could you tell me/us which config file you entered the i915.modeset=1 option in to make it permanent.

I have tried a few of the files under /etc/grub.d/ (40_custom is a strong candidate) but they are all in a scripting language I am not familiar with and simply typing the line in does not pass the parameter to the main grub.cfg file (that now says DO NOT EDIT in big bold letters at the top!)

Thanks for any help you can give.

J.

It really depends on whether you have Grub2 or Grub Legacy installed. If you install 10.04 LTS off the liveCD, you, by default, get Grub2, however on the computers where I upgraded from 9.10 (or earlier in some cases) it left me with Grub Legacy.

I suggest you upgrade to Grub2, as I found it somewhat easier to configure.

https://help.ubuntu.com/community/Grub2

Once you've updated to Grub2, you edit /etc/default/grub, and look for the line that says GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and change it.

Good luck!

brucewagner
May 18th, 2010, 03:33 AM
I'm also experiencing this issue on my laptop (LG R405 with ATI Radeon Xpress 1250). I have managed somewhat of a workaround:


Hold down left-shift on boot to enter GRUB
hit "e" to edit the kernel
remove "quiet splash" and replace with "nomodeset single"
control-x to boot

(http://bugs.launchpad.net/ubuntu/+source/grub2/+bugs/511130)

A system recovery screen appears, I selected "start ubuntu normally" (or whatever option is similar) which put me through to a shell login prompt. After logging in to the basic shell I typed:


sbritton@Zarniwoop:~$ sudo /etc/init.d/gdm start

Which, much to my surprise, launched the Lucid Lynx gui.

I'm using the standard drivers for my video card (I attempted, but failed to install ATI's catalyst control center.)

Where I'm at now is trying to figure out what changes I need to make to what files to get this gui to launch from boot. Hopefully this helps and moves us forward a bit. If anyone can make any suggestions towards what I did to get the to work this way, and what changes I can make to get this system working, I'd appreciate it!

Wow.

From the LiveDVD, I was able to do the, "Press the spacebar at the 'keyboard=man' icon screen to get the install menu"... And then the, "At install screen press F6 and select nomodeset and install Ubuntu as usual."

(Well, in my case, I am installing a LiveDVD version of Ubuntu 10.04 created using remastersys so I "Press Tab to edit options" and then I replace the words "quiet splash" with the word "nomodeset" and press Enter... and it boots to the LiveDVD desktop just fine... and I can install the OS just fine...)

But then, after installing Ubuntu... the next instruction was, "On first boot after install, press e on getting the GRUB bootloader."

SORRY GUYS! THIS IS WRONG!

For a newbie, you must say, "Hold down the left Shift key during boot to get the Grub bootloader menu."

It took tons of reading and re-reading before I finally found Manganic's post.... where he CORRECTLY included the, "Hold down left-shift on boot to enter GRUB menu" step! GEEZ

Thanks so much, Manganic.

So.... I was able to follow your instructions... and now I am able to actually get alot further. I am now able to get into the INSTALLED Ubuntu. Once in, I first did the System -> Administration -> Hardware Drivers ...and installed the Current (recommended) driver... I'm using the NVIDIA (version current). Next, I went to System -> Administration -> Update Manager and installed all new updates (in the hopes that they've fixed some things in the meantime). And....

IT WORKED!!!!

I am in. And it works. Thank God.

But what the heck happened!? Did Canonical fail bigtime due to a forced 6-month release schedule rushing the product out the door?

Perhaps the thinking was/is that fixes can always be done afterward... and continuously... HOWEVER, if the darn OS won't BOOT... from the LiveCD... You've got SERIOUS problems on your hands.

How can anyone recommend to their friends an OS which won't even boot (black screen of death) from the LiveCD...???

I think Canonical is going to have no choice but to do an interim update of their LiveCD ISO image asap... BEFORE the next release in October. We cannot have a LiveCD that won't boot... for 6 months... No way. Not acceptable. What happened to the quality control testing? This is an enormous fail. If they don't test ANYTHING else... They need to test that the darn LiveCD boots correctly on every known PC / video combination they can possibly come up with.

Everything else can be fixed with updates... But BOOTING is a total deal-breaker. Nothing works if you can't boot it, and install it, and then boot the installation.

I'm running a business where I am recommending Ubuntu to everyone. This is embarrassing, to say the least. I'm just going to have to tell people that they're going to have to have US install it for them. This process is nothing that any ordinary user should EVER be forced to even hear about... much less, attempt on their own.

I hope Canonical's quality control team has learned a valuable lesson from all of this.

And we, the users, might want to learn from this too. I've always said, the safest place to be is.... six months BEHIND... :)

sharkey77
May 18th, 2010, 04:02 AM
I found an easier way that also got rid of another boot error.

This is Intel specific.

https://wiki.ubuntu.com/X/Bugs/Lucidi8xxFreezes


echo options i915 modeset=1 | sudo tee /etc/modprobe.d/i915-kms.conf
sudo update-initramfs -u

Manganic
May 18th, 2010, 04:25 AM
Let's be fair here, Bruce. I know and understand your frustration. I spent many hours last night on Ubuntu (Karmic) getting my dual radeon 4850 video cards set up with the RadeonHD driver in Xorg.conf. This is all so I can preserve my xorg.conf file and upgrade to Lucid on the same system (fifth attempt) and get my three screens acting as one large expanded desktop without going to the (buggy) fglrx drivers.

Last time I did this, I lost all use of my keyboard and mouse.

But here's the thing. Ubuntu is free and community supported. I suppose I could pay Canonical and get support, but I find that when I dig deep enough, I tend to find solutions, and, in the process, learn a heck of a lot more than if I paid someone for support.

Remember: you don't get what you don't pay for.

twrock
May 18th, 2010, 08:02 AM
SORRY GUYS! THIS IS WRONG!

For a newbie, you must say, "Hold down the left Shift key during boot to get the Grub bootloader menu."


Yes, you are correct.....
...and, no, you are incorrect.

It depends on your setup. What was seemingly "wrong" for you, is in fact very "right" for someone else.

So we all just have to be willing to admit that something that seems "guaranteed" to work, because it worked for us, might not work for someone else with a slightly different setup. That is because very few of us are seeing the whole picture. (The classic seven blind guys describing an elephant parable comes to mind.)

Incidentally, here's a link to a thread where a "solution" is proposed to the "not having a bootable CD for six months" problem. You might find it interesting,... or not: http://ubuntuforums.org/showthread.php?t=1472223

brucewagner
May 18th, 2010, 05:22 PM
So we all just have to be willing to admit that something that seems "guaranteed" to work, because it worked for us, might not work for someone else with a slightly different setup. That is because very few of us are seeing the whole picture. (The classic seven blind guys describing an elephant parable comes to mind.)

That is so true. ...and humorous at the same time. :)

OlerBE
May 23rd, 2010, 12:57 PM
I have an ATI 5770 and my monitor have a native resolution of 1920x1080 and can´t boot liveCD because after the orange dots at boot i get a black screen and can´t do anything from here.

¿someone with the same configuration can boot Lucid Lynx LiveCD?

For what i have read i think folks with Nvidia and Intel graphics can do (with tricks) but not ATI´s folks.

My Live cd ran fine from usb via unetbootin when I tried another dvi port on my 5870 eyf6. I hope this helps.

gognos
May 24th, 2010, 02:13 AM
On clean install of 10.04 x86_64 no problems

Installing nvidia drivers no problems

Every second or 3rd start up i get black screen log on rebooting usually fixes this

Some of you are using intel others amd some ati others nvidia yet all having problems is it really a graphics thing ?

Apparently not after another clean install and no nvidia drivers i get the same problem

Clean install added grub2

Changing grub like suggested still made no difference

Its a minor inconvenience yet consistent with everyone i know who has tried 10.04 from either an upgrade or clean install.

Very disappointing bug for an LTS release

eGelor
May 24th, 2010, 11:14 AM
Hi everybody. Pls help me.
i got the nvidia 9200gs
i make sudo nano /etc/default/grub
change as this thread says to nomodeset
sudo update-grub
i make the blacklist.
change to nvidia-current.
i am still taking a black screen.

yippy
May 26th, 2010, 05:42 AM
On my ATI 5770 it turned out to be which DVI port I was plugged into. However, I had to switch ports and then REBOOT to get a picture, I didn't have a picture until after reboot.

alankatana
May 27th, 2010, 07:13 AM
how to get past this blank screen....using nvidia 9600 card

nucleuskore
May 27th, 2010, 12:06 PM
see post number 14 in this thread

SMANN
May 28th, 2010, 08:42 PM
Just a note from my personal experience with 10.04 clean install and a Nvidia 6150 integrated graphics chip...

The "nomodeset" startup option simply did not work for me. Only the "xforcevesa" option permitted continuing on to use the graphical installer, albeit at reduced resolution. After completing the initial install I was eventually able to get the latest Nvidia Current drivers(195) and can now mostly boot into a full resolution gui.

However, even now, booting into a full resolution gui is hit or miss. Maybe every third time I boot the gui fails to launch and I am left at a cmd line login prompt. I had an instance of rebooting 4 times in a row with X failing to start yet the 5th time it did. I'm not at all clear why it will fail a certain percentage of the time with no changes happening in between. Some sort of weird hardware/software timing issue perhaps?

nucleuskore
May 28th, 2010, 08:50 PM
I think it is something to do with X. I have issues with both the nvidia card and the intel graphics in my eeepc 1000H. However my blank screen boot rate is about 5-10 %; I have to Ctrl Alt Del to reboot the pc and usually get a display after that.

eGelor
May 28th, 2010, 09:28 PM
Sort of thing like that, but as i tell in a previous post, i
test everything this and other threads. nothing with the blacklist nothing with grub (nomodeset && xforcevesa)nothing after upgrade or format.

post #14 is for newbies, you don't have to make a new install to fix the problem.
Someone with many cups got to tell as the answer.

http://www.youtube.com/watch?v=j6IfWJ_nlLc

i check this post of youtube and the tread at the comments...
i find
deb http://ppa.launchpad.net/nvidia-vdpau/ppa/ubuntu YOUR_UBUNTU_VERSION_HERE main
deb-src http://ppa.launchpad.net/nvidia-vdpau/ppa/ubuntu YOUR_UBUNTU_VERSION_HERE main
this repo for lucid.
i uninstall xserver-xorg-novaeu-all
NADA.
PLS HELP

-kleve
June 7th, 2010, 07:50 AM
Yesterday I spendt 3 hours together with FEDORA 13 and UBUNTU 10.04.
Trying to boot from a USB stick made with unetbootin.

I had same error on both sticks: Black screen after initial boot :(
Screen telling: NO signal input.
So please stop blaming UBUNTU 10.04. FEDORA has the same issue.

After consulting several forums like this , and a good night of sleep I finally managed to boot on both sticks!!.:guitar: TA DAAAAA.

All I did was :
Turn off power on the wall. Both computer and screen.
Changed DVI input ( There are two connections on my Gforce 8900 nvidia)

More to come when I INSTALL the systems.
-kleve

-kleve
June 8th, 2010, 11:28 AM
YES
Installed Ubuntu 10.04 without any problems at all.

I just switched DVI Connection on my Videocard .

-):P

Henns Wörst
June 12th, 2010, 06:20 PM
I've got the issue, that on every 2 or 3 boots I get a blank screen (ATI 1950 Pro)
This sure gets on my nerves, I mean, of what use is extra fast boot time if one has to boot twice all the time? I hope this gets fixed soon. Does anybody know about the first major update and if this is going to be addressed:confused:

ionFreeman
June 15th, 2010, 03:09 AM
I have a 700m and Workaround A worked for me.
https://wiki.ubuntu.com/X/Bugs/Lucidi8xxFreezes

Henns Wörst
June 15th, 2010, 01:57 PM
Just tried it, first reboot and blank screen. Maybe it's because you are using the prop. driver, the 1950Pro is not supported by ATI anymore.

myles.tonnies
June 17th, 2010, 04:26 AM
Just a tid bit for new users. To access the GRUB menu after an install, hold down the SHIFT Key. Then follow the instructions in post 14.

Cheers

rciemins
June 17th, 2010, 07:35 AM
Same problem. I have tried
1) Live CD boot - black screen
1) CD setup - black screen
2) Upgrade via updade-manager from 8.04 LTS to 10.04 directly... Install finished just fine, but after the reboot - black screen...

Can't get event to login screen. I have had similar problems with KDE 4... But after logging in... And then I could log on as different user and fix the problem...

Laptop - LG LS50e
Celeron Mobile 1.5Ghz
512MB RAM
Integrated Intel video adapter (I blame this one)

myles.tonnies
June 17th, 2010, 06:31 PM
Same problem. I have tried
1) Live CD boot - black screen
1) CD setup - black screen
2) Upgrade via updade-manager from 8.04 LTS to 10.04 directly... Install finished just fine, but after the reboot - black screen...

Can't get event to login screen. I have had similar problems with KDE 4... But after logging in... And then I could log on as different user and fix the problem...

Laptop - LG LS50e
Celeron Mobile 1.5Ghz
512MB RAM
Integrated Intel video adapter (I blame this one)
Did you hold down the SHIFT Key to access the GRUB menu and then follow the instructions in post 14?

tgrigsby
June 22nd, 2010, 06:03 AM
I gave up trying to install 10.4 on my Inspiron 8100. As I write this, I'm installing 9.10. When installing 10, I would get the same screen you say (I think the star is a little person in a circle, but I didn't recognize the other symbol). I would press the arrow keys to get a language menu, escape to go back, select "Install Ubuntu", and then watch the screen go blank. And not just blank; it would go white and then fade out toward the edges. Not a cool fade, more like a graphics-chip-freaked-out fade. And that was the last thing I saw. I could tell from messing with keys and watching the disk light that things were still happening in the background, but nothing more.

Okay, so now I'm finishing up the 9.10 install, and it looks fine. I know that if I go into the upgrade manager it will upgrade me to 10, and that worked fine before (this is a reinstall with a new SSD HD).

If Ubuntu is slacking on older hardware support, that would be a Bad Thing. I rely on the various flavors of Linux to power hardware that Microsoft has forgotten, and to do it better than Windows ever could. I figure I'm not alone in this.

Okay, the install finished, I'm rebooted, and Ubuntu is waiting for me to come and play. Good luck with your machine!

Paul41
June 22nd, 2010, 10:43 AM
I gave up trying to install 10.4 on my Inspiron 8100. As I write this, I'm installing 9.10. When installing 10, I would get the same screen you say (I think the star is a little person in a circle, but I didn't recognize the other symbol). I would press the arrow keys to get a language menu, escape to go back, select "Install Ubuntu", and then watch the screen go blank. And not just blank; it would go white and then fade out toward the edges. Not a cool fade, more like a graphics-chip-freaked-out fade. And that was the last thing I saw. I could tell from messing with keys and watching the disk light that things were still happening in the background, but nothing more.

Okay, so now I'm finishing up the 9.10 install, and it looks fine. I know that if I go into the upgrade manager it will upgrade me to 10, and that worked fine before (this is a reinstall with a new SSD HD).

If Ubuntu is slacking on older hardware support, that would be a Bad Thing. I rely on the various flavors of Linux to power hardware that Microsoft has forgotten, and to do it better than Windows ever could. I figure I'm not alone in this.

Okay, the install finished, I'm rebooted, and Ubuntu is waiting for me to come and play. Good luck with your machine!

I gave up trying also but it isn't just a Ubuntu problem. I tried fedora 13 and it has the same problem. Maybe it's something with the new kernel? I ended up installing Debian.

joopbraak
June 24th, 2010, 01:39 PM
To edit Grub I have to hold shift and keep pressing escape during boot. If I just hold shift Grub quickly flashes on the screen then goes to the Ubuntu Splash screen then to the blank screen.

Don't press shift from the beginning. Wait until POST has ended and then press shift until you get the Grub menu.

sabret00the
June 25th, 2010, 10:12 PM
I'm having this problem. I've never installed Ubuntu before and have found myself lost reading this thread.

I have no idea what the Grub menu is or when to hold down shift in order to enter it.

I do know that when I attempt to click F6 on the initial menu, nothing happens. I tab to advanced options and there's nothing there.

What am I doing wrong?

I have a Dell D400 Latitude.

Manganic
June 25th, 2010, 10:48 PM
I'm having this problem. I've never installed Ubuntu before and have found myself lost reading this thread.

I have no idea what the Grub menu is or when to hold down shift in order to enter it.

I do know that when I attempt to click F6 on the initial menu, nothing happens. I tab to advanced options and there's nothing there.

What am I doing wrong?

I have a Dell D400 Latitude.

GRUB is the menu that some systems give to the user to choose which operating system to run. When you boot your machine, it will go through a sequence called POST. some machines show all the details, others give you a splash screen with a logo of some kind. there will be a period where you have a message sayimg "Press DEL" (or F1 or F6) to enter setup. once that message disappears, press and hold down the left shift key.

mrchumpley
June 26th, 2010, 02:07 PM
I have a dual core AMD64 processor with NVIDIA card.

I installed 10.04 from CD (having checked MDSUM etc etc) and it was lovely.

After a few weeks I started getting 'funny things' happening on boot up - essentially the monitor would be 'on' but screen blank.

Then I had a situation whereby it would boot up, I'd hear the drum roll, but the monitor would be 'asleep' or in no-input mode, so again, blank.

NOW even when I try to boot the screen does nothing. I can't even see the GRUB screens etc. on boot up. I no longer hear the drum roll. It's almost as if when I try to start the machine it goes immediately into some sort of hibernate or suspend mode.

This seems like a total disaster to me - i can't even re-install 8.04 which worked fine.

ANY IDEAS??????

(like others, this problem has really dented my enthusiasm for Ubuntu - up to now I have raved about it to everyone. It does seem a pity.)

Manganic
June 26th, 2010, 03:39 PM
I have a dual core AMD64 processor with NVIDIA card.

I installed 10.04 from CD (having checked MDSUM etc etc) and it was lovely.

After a few weeks I started getting 'funny things' happening on boot up - essentially the monitor would be 'on' but screen blank.

Then I had a situation whereby it would boot up, I'd hear the drum roll, but the monitor would be 'asleep' or in no-input mode, so again, blank.

NOW even when I try to boot the screen does nothing. I can't even see the GRUB screens etc. on boot up. I no longer hear the drum roll. It's almost as if when I try to start the machine it goes immediately into some sort of hibernate or suspend mode.

This seems like a total disaster to me - i can't even re-install 8.04 which worked fine.

ANY IDEAS??????

(like others, this problem has really dented my enthusiasm for Ubuntu - up to now I have raved about it to everyone. It does seem a pity.)

Actually sounds like a hardware problem to me. Try booting the LiveCD or a Windows CD to see if you can get into a different OS. Also see if you can access your BIOS settings.

thoma83
June 27th, 2010, 01:11 PM
Hi
I've had this this problem for weeks and finally found a link to a site with the right solution to my boot up issues for my video card on a Toshiba NB200 running a GMA 950.

I successfully installed from USB stick but had to continually press shift to get the thing to boot.

Here is the link to the solution. Thanks to everyone for all the very useful posts on this issue. I'm a noob and have no bloody idea about computers or Linux commands and I've learnt a lot from this. Big shout to everyone.

http://idyllictux.wordpress.com/2010/04/26/lucidubuntu-10-04-high-resolution-plymouth-virtual-terminal-for-atinvidia-cards-with-proprietaryrestricted-driver/

sabret00the
June 28th, 2010, 01:11 AM
GRUB is the menu that some systems give to the user to choose which operating system to run. When you boot your machine, it will go through a sequence called POST. some machines show all the details, others give you a splash screen with a logo of some kind. there will be a period where you have a message sayimg "Press DEL" (or F1 or F6) to enter setup. once that message disappears, press and hold down the left shift key.

I don't have that screen.

I have my BIOS screen where I click F12 to get to boot options.
I have my boot options screen where I choose to boot from USB.
And then I have the Ubuntu splash screen with the dots.

womblet
July 21st, 2010, 05:19 AM
I'm getting the same screen as described previously (purple with two small icons). When I press F6, I then choose 'install' but nothing happens.

I'm trying to install this on a Dell Latitude D620 that is four years old. I would appreciate any suggestions as to what to do. Thanks

JCMB1
August 1st, 2010, 02:29 AM
Just a tid bit for new users. To access the GRUB menu after an install, hold down the SHIFT Key. Then follow the instructions in post 14.

Cheers

This is the most useful item in this whole post!

rooski15
October 8th, 2010, 03:53 AM
Hey there,

I didn't see any post similar to this as a solution (nor did i read all 12 pages) but i figured i would throw it out there. I am running:

AMD Phenom II x4 955
4gig DDR3 Ram
Asus M4A78TD-V Evo
Xfx Radeon HD 5670

Every time i tried to install ubuntu 10.04.1 64bit, through Wubi or other, i was having the same black screen problems. I decided to pull the video card (which is only DVI/HDMI, no VGA support) out and attach my monitor to the on-board VGA. After doing so i was able to load ubuntu and finish installation. Afterword i installed the suggested ATI graphics driver (the proprietary one) and restarted computer. After restart i shut down and reinstalled the video card, booted just fine. I am yet to have any issues or to have used it much, other than to do updates and jump on the net for a bit. Going to look into the capabilities of the card with the driver as well as try to force some bugs out of the wood work. I installed it via Wubi on a 17g partition in Win7 64 bit and am testing to make sure it will work fully before i buy a second HD to toss in and dual boot.

Cheers! :P

wlbragg
February 22nd, 2011, 01:00 AM
I'm tired of reading posts just to be able to use Ubuntu 10.4 with my new ATI4850. I have been using on-board nVidea with proprietary driver since 10.4 upgrade. I pop in the new ATI4850 and now loose the screen prior to the log-in prompt, I think. I'm not for sure because the screen goes blank. After considerable searching and reading I ended up at this relatively old post. After skimming through this thread I gather I may have to try one or more of the fixes in this thread. Does anyone know if I can get this fixed by going into the setup screen (left shift after post) as described and install an ATI proprietary driver to get this working again? What I am asking is can I gain access to the system or a terminal prompt in that way and run Linux commands. And yes it's all still new to me! I've been able to navigate well in the graphical interface but have never had to try to access the system from a shell prior to logging in at the GUI. Sorry for bumping this old of a thread but I'm really tired of reading novels just because I changed video cards.

wlbragg
February 22nd, 2011, 05:02 AM
Now I feel really dumb. I figured out you can boot in safe mode and install new drivers from there. It was my own fault for not addressing the driver issue prior to installing the new card. I guess I figured the system should be smart enough to figure this out on it's own, kind of like Windows, ouch! It's in the process of installing the FGLRX driver now, hope it works! Anyone know if the Open Source Radeon driver would be a better choice for this card?

MilesCampbell
December 3rd, 2011, 10:02 PM
Hello all

Just a quick note in the hope this may help someone out ... After reading everything I could find on the subject nothing seemed to help so these are the steps taken to rectify my issue. Please follow the steps EXACTLY (Yes turning the 2nd monitor really did help!)

**Machine
- Dell Optiplex GX270 Desktop with an Nvidia card GFORCE FX 5200 with two monitors connected via DVI.

**Problem 1
With the live CD of Ubuntu 10.4LTS a black screen was displayed
From this post (http://ubuntuforums.org/showpost.php?p=9195971&postcount=14) I used "At install screen press F6 and select nomodeset and install Ubuntu as usual."

**Problem 2
After installing from Live CD a black screen was displayed on both monitors
Turn off one of the monitors! (Yes really otherwise the GRUB screen cannot be edited)

At the grub screen (This is the text based screen where the operating system can be selected)
If you have not seen this before as Linux is the only OS you have loaded press F6 as SOON as the machine boots and there it is ..

From this post again (http://ubuntuforums.org/showpost.php?p=9195971&postcount=14) I used "On first boot after install, press e on getting the GRUB bootloader. Using arrow keys navigate to and delete quiet and splash and type the word nomodeset in their place Press Ctrl and X to boot"

In my case this didn't work so after much reading I deleted "quiet splash" including the extra space to "ro" and then entered "nomodeset xforcevesa" I'm sorry but I can't find where I found reference to using xforcevesa for Nvidia cards ..

Now the monitor should come to life with the 10.4 Login screen

On the top bar under System -> Administration -> Hardware drivers
Linux will now search for the correct drivers for the video card
I used the Recommended NVIDIA accelerated graphics driver (version 173)
After driver installation the machine needs to be restarted
NOW turn on the second monitor if you have one

May I suggest that the system is now updated using System -> Administration -> Update Manager

Thank you very much to everyone that helped in this issue
Hopefully this may help
Miles

rapq77
December 27th, 2011, 01:17 AM
Thanks nucleuskore

You helped me a lot !

Thanks :D