View Full Version : [ubuntu] [10.04] Unable to install Ubuntu server on RAID1 using or not LVM

April 25th, 2010, 07:29 PM
Hi all,

I tried several times to install Ubuntu 10.04 RC Server edition on a PC with 2GB memory without any success.

I want to have a RAID1 system (2x500GB drives) drived by a FASTTRAK 2300 PCI to SATA card.

I can easily setup RAID1 (assuming that only software RAID is managed by Linux) and also setup LVM volume but the bad thing is that is does not boot at all.

Here is the log:

Gave up waiting for root device. Common problems:
- Boot args (cat /proc/cmdline)
- Check rootdelay= (did the system wait long enough?)
- Check root= (did the system wait for the right device?)
- Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/mapper/myboxname-root does not exist. Dropping to a shell!

What is odd for me is that at the end of the installation, looking at the mount points I can successfully check that the partitions are up and running.

However, when GRUB starts it does not see at all the RAID partitions and that's it.

What can I do?
Any advice is welcome.


April 25th, 2010, 07:51 PM
Here is my grub commands:

insmod raid
insmod mdraid
insmod lvm
insmod ext2
set root='(alga-root)'
search --no-floppy --fs-uuid --set XXXXXXXXXXXXXXXXXXXX
linux /boot/vmlinuz-2.6.32-21-generic-pae root=/dev/mapper/alga-root ro quiet
initrd /boot/initrd.img-2.6.32-21-generic-pae

Question coming up; looking at the command script, does it mean that the /boot partition MUST be ext2 and not ext4?

Thanks in advance

April 30th, 2010, 11:55 PM
About the same problem here. I was able to install 9.10. But after the first kernel upgrade, I got the same error that you did. The only way to get it working was to use my first working kernel.

Today I upgraded to 10.04, and now my old kernel doesn't work either :(

Starting from the server CD and choosing the rescue mode, I'm able to get to my raid 1 partition and lvm partitions.

My guess is that there is something wrong with how Ubuntu generates the initrd.img file. And this bug has been around for a long time :(


May 1st, 2010, 08:34 PM
I'm having the same problem. I created a 2 disk RAID1 using mdadm, set up LVM on the array, and carved out a LV each for root, /home, and swap. This configuration worked fine with 9.10, but 10.04 doesn't seem to be able to boot with it. After installation I chroot'd into the LVM root and installed mdadm and lvm2, rebuilt the initramfs, and updated the grub configuration. None of this made any difference and I get the exact same error about not finding the root volume.

May 1st, 2010, 09:36 PM
apparently this is an issue with luicd that hans't been resolved my old setup with raid and lvm does not work as well and I am sent to busybox about lvm-root not being detected... just hope someone has an answer for this

May 3rd, 2010, 11:32 AM

Same problem here:

Ubuntu 10.04 x64 server.
3 x sata into RAID5
all of that into LVM for root and swap.
/boot on usb stick.

"Gave up waiting for boot device"

Pretty disastrous :(

Guess this needs to go on Launchpad really.


July 2nd, 2010, 09:07 PM
I may or may not be having the same problem. I'm struggling with something similar to what's described, except that my RAID 1 is not LVM, it's split into two partitions, and initramfs shows that one partition is assembled, but the root partition is not. Did anyone find a solution to this?

July 2nd, 2010, 11:50 PM
I figured out my issue, so maybe this will help some of you. For some reason, the upgrade changed my /etc/mdadm/mdadm.conf to specify that the /dev/md1 raid used /dev/sda2 and /dev/sdb2 where the partitions were actually /dev/sda5 and /dev/sdb5. I had forgotten that the partitions were extended, but I'm not sure why Ubuntu forgot too.

So try booting with a liveCD and make sure your /etc/mdadm/mdadm.conf matches the drives that show in /dev (or in your preferred partition manager).

July 5th, 2010, 02:18 PM
So try booting with a liveCD and make sure your /etc/mdadm/mdadm.conf matches the drives that show in /dev (or in your preferred partition manager).

In my case, despite being identical, only the mdadm.conf from initrd was 'faulty' : I had to run a liveCD to extract and modify my initramfs, forcing /dev/sd[abc]x instead of UUID style for the arrays detection into mdadm.conf. Automatic array assembly by superblock's UUID doesn't seem to work on initramfs.

PS: the caveats is that I have to do it each time my initrd is updated ! Any ideas on how to fix this permanently ? I'll open a new thread.
PS: I'm talking about Ubuntu Desktop (Alternate CD)

July 7th, 2010, 12:13 AM
I'm trying to install 10.04 server (i386) to a 2 disk RAID. Essentially, this is to be a NAS appliance with a pair of mirrored drives.

I've tried following the instructions at https://help.ubuntu.com/community/Installation/SoftwareRAID except that I'm manually creating partitions because the automatic setup looked too complicated. I created (on each drive)

- 4 GB partition to use as /
- 2 GB partition for swap
- rest of 2 TB drive to use for storage.

I set each of the 4GB and 2TB partitions for use in a RAID. That leaves me unable to set the 4GB partitions as bootable.

When it came time to install grub2, I could figure no combination that would install. Each time it just report an error. Not sure where the error is stored.

Nor could I figure out how to boot the drive from the install media (USB stick.)

Any help is appreciated.

Should I try installing 9.10 server?


July 7th, 2010, 01:39 AM
Should I try installing 9.10 server?
Same result.

I guess I'll 'unraid' my / partition and just boot off the first drive.