View Full Version : [ubuntu] can't format disk

April 24th, 2010, 09:04 AM
I had ubuntu 9.10 and windows vista ultimate dual boot installed on my computer.

I tried to format my windows drive and install win 7 on it without affecting my ubuntu. So I used the win 7 installation disk to overwrite my vista drive. But it gave me error messages, so I tried to delete my windows partition(C:) but somehow my C: drive (vista) merged with my D: drive and became a larger unallocated space. Now the problem is that I still can't format it!

I tried to use win 7's installation disk and ubuntu's disk utility, but both gave me error messages. I tried ubuntu's installation disk and gparted, but both only show one unallocated partition, which I'm afraid containing my ubuntu partition.

How can I can format my partitions without affecting my ubuntu? Thanks in advance!

April 24th, 2010, 09:41 AM
have similar problem, but with XP and want to erase old linux partition to make a fresh install of lucid

from a lucid live CD(release candidate, downloaded and burned yesterday) gparted see the whole disk as unallocated and I cant mount my old linux partition but I can see it, when I try to delete it, it gives a long error message, some of the words I snapped up was magic and msdos. I could try to find this error message again if you cant find a solution instantly

with a intrepid live CD I can mount the old linux partition but I can still not see any partitions in gparted.