PDA

View Full Version : [kubuntu] Disable passwordless logon?



mma8x
April 21st, 2010, 08:28 PM
Running a live usb of 9.10/kde, and i can't seem to get it to require a password for logon. i uncheck "enable passwordless logon" in the convenience tab in settings. if i log out/in, it requires a password, but if i reboot it will just boot directly to the desktop. i don't want it to be that easy to access my files if i lose this drive (in fact, i'd like to encrypt the drive, but that's another issue...we'll start with just needing a pw)

thomasaaron
April 21st, 2010, 08:56 PM
I believe you have to actually install Ubuntu to disable that feature. The USB image isn't really meant to be your permanent OS. It is for testing, performing installations, recovery work, etc...

Untitled_No4
April 21st, 2010, 09:49 PM
Still in Convenience tab, do you have "Enable Auto-Login" checked by any chance?

mma8x
April 21st, 2010, 10:32 PM
well, i don't see why it has to be temporary. i carry my usb drive with me rather than a laptop for use on work, friend's computers, etc. i know that it's secure for accessing my online accts or whatever, it's set up like i like, i can vnc into my home computer. and yes, "enable auto-login" IS checked. i uncheck, reboot, and there it is checked again...

lisati
April 21st, 2010, 10:40 PM
You might want to create a "persistent" copy on your USB device, mentioned here (https://help.ubuntu.com/community/Installation/FromUSBStick).

mma8x
April 21st, 2010, 10:51 PM
You might want to create a "persistent" copy on your USB device, mentioned here (https://help.ubuntu.com/community/Installation/FromUSBStick).

yeah, that's what i have. used usb-creator.

Untitled_No4
April 21st, 2010, 10:58 PM
I can't help you much besides telling you that I had it done once. May have been using the dd command to put the iso on the USB but I can't tell you for sure.