View Full Version : [ubuntu] Ubuntu 9.10 installation in HP Workstation 9400 - Dual Boot

April 21st, 2010, 02:35 PM
Dear All,

I tried to install Ubuntu 9.10 in HP Workstation 9400. I partitioned C drive and created 25GB free space. I have one more HP auto recovery drive (D) also. Then I installed ubuntu in this 25GB free space. Installation was successful. It showed grub loader first time and I booted into ubuntu. It is working fine. But once I restart the system and boot into windows XP, the grub loader is not at all coming. It directly going into windows XP.

I tried to install one more time in OEM manufacturer mode also. The same problem came here also. When I restart the system after booting into win XP, it is showing the following error.

No such disk
>Grub load error
>Grub rescue

Could anyone give suggestions how to make the system dual boot with win XP and ubuntu 9.10.

April 21st, 2010, 06:39 PM
Could anyone give some suggestions? I am really struggling with this problem.


with regards,

April 22nd, 2010, 01:50 AM
No one knows about this?:confused:

April 22nd, 2010, 01:14 PM
I tried to install grub loader from live cd and grub-update. Once I do this, I can see the grub loader and I can select the ubuntu or Win XP.

As long as I boot only into ubuntu, I can see the boot loader. But once I boot in to win XP, then I restarted my system, grub loader is not coming. And the following error is coming.

grub loading
error: no such disk
grub rescue>

I am totally frustrated. I dont know what to do now.

April 22nd, 2010, 02:28 PM
This should help you out

The Grub 2 Guide
(formerly Grub 2 Basics)

HP Machines Fails to Load Grub after Using Windows - Bug [URL="https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/441941"]bug/441941/URL]
After installing Grub 2 on a HP machine, the system boots normally until the first time it's booted into Windows. On the next boot, the system hangs at "Grub loading".

Workaround: HP protection tools are rewriting to the MBR when Windows is run. The protecttools app must be removed/disabled. Refer to post #10 in the Bug Report.

From http://ubuntuforums.org/showthread.php?t=1195275

April 23rd, 2010, 04:23 AM
Hi andrewthomas,

Thanks a lot for your help. Now I can boot in both OS in grub loader:P.

I have one clarification. I think that disabling "PC angel" is temporary solution. There is any bug fixing patch is available for this. I could not see in launchpad thread.

Anyway once again thank you....

with regards,