PDA

View Full Version : [SOLVED] 7.10 Has no IPv4 with eth0 = can't connect to LAN



aztoby
April 20th, 2010, 04:28 AM
Team, plz help. I have been searching for awhile now but haven't found my problem posted, let alone an answer.

Current problem: fresh, clean install of Ubuntu 7.10 on known good hardware does not use/produce/get/have an IPv4 associated with eth0, so cannot connect to my home network for Internet access.

Background: Have been wanting to build and maintain a home file server for some time now. Have also been wanting some hands-on practice to help me progress from Noob to Intermediate, eventually advanced Linux Tech. (I have two decades of tech support experience, but only small fraction of that using command lines and almost zero Linux.)

Anyway, every time I download and attempt to burn a recent distro on my Vista Shuttle, I only end up making drink coasters and mini-frisbees. so I thought that I might have better luck if I used a Linux Workstation to download and burn a server distro.

That's where I an now. I took one of my fully functional WinXP systems offline, replaced the WXP HDD with an old 3.2 GB, dug out my 2008 edition Linux Bible, popped in the DVD that came with it, and installed Ubuntu 7.10.

Everything else seems to have progressed smoothly, but I cannot seem to get the onboard Via chipset ethernet controller to talk to the router. When I run "ifconfig" in Terminal, I see IPv6 info, but nothing for IPv4.

When I try to configure eth0, it doesn't matter whether I set it up for DHCP or static... nothing works.

So what am I missing here? Is there a command line tht I can use in Terminal to manually configure eth0 to use IPv4?

snowpine
April 20th, 2010, 05:19 AM
Welcome to the forums!

First, a word of caution: Support for 7.10 has ended. You will find better answers here on the forums if you use a currently-supported release (8.04 is the current long term support, 9.10 is the current release, and 10.04 is in late beta, to be released later this month). Recent releases have better hardware support and may support your via ethernet "out of the box."

ipv6 is enabled by default in Ubuntu, maybe that is related to your ipv4 problems. Here are instructions for disabling ipv6 that you may find helpful: https://help.ubuntu.com/community/WebBrowsingSlowIPv6IPv4

aztoby
April 20th, 2010, 08:45 PM
Thanks for the assist. I don't know what happened between last night's shut down and today's power-up, but everything is working great now. Below is data copied from Terminal, just as a FYI. Now that I can connect to Internet, I will be downloading the latest stable versions of both, Ubuntu desktop and server.

FROM TERMINAL:
toby@Peregrine:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:0D:87:52:E5:A6
inet addr:192.168.3.111 Bcast:192.168.3.255 Mask:255.255.255.0
inet6 addr: fe80::20d:87ff:fe52:e5a6/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:117 errors:0 dropped:0 overruns:0 frame:0
TX packets:118 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:56896 (55.5 KB) TX bytes:11298 (11.0 KB)
Interrupt:11 Base address:0xe800

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

toby@Peregrine:~$ ping 192.168.3.1
PING 192.168.3.1 (192.168.3.1) 56(84) bytes of data.
64 bytes from 192.168.3.1: icmp_seq=1 ttl=64 time=0.972 ms
64 bytes from 192.168.3.1: icmp_seq=2 ttl=64 time=0.674 ms
64 bytes from 192.168.3.1: icmp_seq=3 ttl=64 time=0.678 ms
64 bytes from 192.168.3.1: icmp_seq=4 ttl=64 time=0.664 ms
64 bytes from 192.168.3.1: icmp_seq=5 ttl=64 time=0.666 ms

[1]+ Stopped ping 192.168.3.1
toby@Peregrine:~$

************************************************** **************

FROM FIREFOX:
http://192.168.3.1/ = successful access to router!
http://www.ubuntu.com/ = successful Ubuntu home-page!

Iowan
April 20th, 2010, 10:30 PM
You might give it a couple of days before you mark the thread [SOLVED] (https://wiki.ubuntu.com/UnansweredPostsTeam/SolvedThreads).