PDA

View Full Version : 10.04 B2 VNC issues



purduephotog
April 17th, 2010, 03:11 AM
I could use a little help.

I managed to get 10.04 B2 installed onto my Pico USB drive, but I can't bring up VNC anymore. I had been running 8.4- I disconnected all hard drives except for the new experimental one.

I could use some help getting the command line options right to get VNC server to run. When I run vncserver or vnc4server, I get errors in the log file:


hirsch@mythbox:~/.vnc$ more mythbox\:1.log
Unrecognized option: -extension
use: X [:<display>] [option]
-a # mouse acceleration (pixels)
-ac disable access control restrictions


etc etc.

I *used* to be able to just log in and take control of the MYTH session remotely.

Since this is set up on a CRT television, it's just a bit difficult to read the tiny fonts, which has rendered the screen pretty much useless.

Suggestions very much welcome.

purduephotog
April 17th, 2010, 07:53 PM
I did a full upgrade on the box and I no longer get the one error message- but now I get this one (See below in the log)



hirsch@mythbox:~$ more /home/hirsch/.vnc/mythbox\:1.log

Xvnc Free Edition 4.1.1 - built Apr 9 2010 15:59:33
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
Underlying X server release 40300000, The XFree86 Project, Inc


Sat Apr 17 14:50:38 2010
vncext: VNC extension running!
vncext: Listening for VNC connections on port 5901
vncext: created VNC server for screen 0
error opening security policy file /etc/X11/xserver/SecurityPolicy
Could not init font path element /usr/X11R6/lib/X11/fonts/Type1/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/misc/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/75dpi/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi/, removing from list!
exec: 5: /etc/X11/xinit/xinitrc: Permission denied




hirsch@mythbox:~$ more /etc/X11/xinit/xinitrc
#!/bin/bash

# /etc/X11/xinit/xinitrc
#
# global xinitrc file, used by all X sessions started by xinit (startx)

# invoke global X session script
. /etc/X11/Xsession

purduephotog
April 18th, 2010, 03:31 PM
When invoking tightVNC, you must specify the screen number apparently with the version of VNC installed with mythbuntu 10.04 B2 (and then upgraded).

so, IP:1 (for first display), :2 for second (or 5901, 5902).

Still looking for the root display window.

purduephotog
April 18th, 2010, 05:56 PM
apt-get install x11vnc

Reboot.

Start vncserver :2
connect via tight vnc to IP:2 (or IP:5902)

Start /usr/bin/myth-control-center from command line

Enable VNC
Add vnc password
reboot system

connect via tight VNC on port 0

Works.