View Full Version : [SOLVED] Network problem

April 17th, 2010, 02:10 AM
Hi, I've installed Ubuntu 9.10 few days ago, all worked fine
except that I just can load a few internet pages, (www.google.com,
www.thepiratebay.org) all the others never load. Neither can load the router configuration page ( by default)
The OS neither can get updates from Synaptic or apt/get command.
I've read that the problem can be caused by TCP Window Scaling parameter and the solution is disable it in the /etc/sysctl.conf
I did it, but it didn't work.
Other reason possible is IPv6, and is needed disable it in the /etc/sysctl.conf, but this didn't work neither.

My NIC is configured by DHCP, the route is correct (default gw), the resolv.conf (DNS) is ok and the probe is that some pages load very well.

I thought that it was the UFW package but is not installed neither Firestarter.

I ran Wireshark and made captures from visiting www.google.com
(load good) and www.cantv.net (never finish from load) it seems that still change the size of Window TCP.

Is there other place where disable the TCP window scaling?
If someone have any idea?

PD: sorry for my english I'm from Venezuela (speak spanish)

April 17th, 2010, 03:10 AM
Here (http://ubuntuforums.org/showthread.php?t=1376506) is a thread that discusses MTU - another potential source of trouble. Sometimes, for whatever reason, the interface will be configured with MTU=64 or something similar.

April 17th, 2010, 04:10 AM
It works...

Thanks a lot

I ran the following command:

sudo ifconfig eth0 mtu 1492

all perfect.

April 17th, 2010, 04:54 AM
[SOLVED] (https://wiki.ubuntu.com/UnansweredPostsTeam/SolvedThreads)? :)

April 17th, 2010, 05:05 AM
Sorry, it's my first post :)

April 17th, 2010, 05:46 PM
Sorry, it's my first post :)Welcome to Ubuntu and the forums. Don't be sorry - the link was offered as helpful hint, nothing more. :) I'm pleased you found a solution.