PDA

View Full Version : 5.1 surround via spdif/receiver



leeko
April 16th, 2010, 07:54 PM
Hi,

I'm running mythbuntu 10.04 beta, and am (so far unsuccessfully) attempting to set up my surround speakers. I have a zotac ion motherboard with 5.1 onboard, and I'm connecting to my Pioneer receiver via spdif.

I get sound via the receiver, but am not hearing anything from the subwoofer, center or rear speakers. I've tried speaker-test and aplay -D, with the same results. Sound only from left and right speakers. Rear channels are played through the front speakers.

I believe the settings are stuck on 2 speakers only. I don't see any option to enable 5.1 surround in the mixer or sound settings.

I've tried several things including alsamixer and gnome volume control. I even installed the full gnome desktop to see if the option would magically appear in the sound settings options, but no joy! Is there anything I can put in the /etc/asound.conf that will do it for me?

Can anyone help me figure this out? I believe the chipset is a realtec alc662.

Thanks in advance,

Lee

Cuppa-Chino
April 16th, 2010, 08:09 PM
odd question maybe but have you tried different sound files, like 2 channel, 5 channel test files? what setting have setup in the bios on my asus board, I had to fiddle with hdmi sound settings to make sure that spdif worked - I think I need to set to intenal and external codec with that board

just an idea

larsolav
April 16th, 2010, 08:56 PM
I have yet to try 10.4, but this link helped me (almost perfectly) for my 9.04/0.22 digital audio: http://www.mythtv.org/wiki/AllensDigitalAudioHowto

About a third of the way down:


Set Myth up for digital sound

There are several ways to the same end on this but the method below is the most straight forward at this point.

Audio output device: ALSA:default
Passthrough output device: Default
Max Audio Channels: Stereo (MUST BE SET TO STEREO as of 6/2/2009 for passthrough to work)
Upmix: Passive
Enable AC3 to SPDIF passthrough checked
Enable DTS to SPDIF passthrough checked
Aggressive sound card buffering off
Use internal volume controls off

AKADAP
April 16th, 2010, 09:17 PM
Speaker test only works with analog connections, with digital, it is stereo only.
In order to get surround through a spdif connection one must use a proprietary format. You need something that is already encoded in that format so it can be "passed through" without modification.

nickrout
April 17th, 2010, 12:12 AM
I have yet to try 10.4, but this link helped me (almost perfectly) for my 9.04/0.22 digital audio: http://www.mythtv.org/wiki/AllensDigitalAudioHowto

About a third of the way down:

This has changed in 0.23.

iitywygms
April 17th, 2010, 12:25 AM
I have the same setup as you except my receiver is a Onkyo. I am running karmic but using the mythbuntu daily builds so I am on mythtv .23
My setup is as follows.

Alsa default
5.1

Best
Alsa;iec958:{aes0 0x02}
dolby digital and dts checked

Everything works perfectly. Ota hd and movies play with 5.1 output as they should.
I did nothing special to set this up. No special asound.conf or anything.
Let me know if I can offer any more info.

leeko
April 17th, 2010, 12:47 AM
Hi,

Thanks for the link - ill give it a go when I get home.

To answer the question: I'm actually running all my tests with a 5.1 .ac3 sample file, and have tried with VLC, Mplayer and xine with no luck.

I understand speaker-test is only for analogue, but I thought aplay -D would test the spdif?

Thanks again,

Lee