View Full Version : [ubuntu] No mail in /var/spool/mail

dado prso
April 16th, 2010, 07:13 PM

I'm running sendmail and I believe that proc mail is no longer writing mail to my spool directory.

Any Idea why this would be happening?

Thank you,

April 17th, 2010, 03:08 AM
Was it ever working? If not then permissions would be my first port of call.

dado prso
April 19th, 2010, 06:47 PM
It was working, then I tried to replace var spool mail with a named pipe.

I have set the permission to write to the mail folder.

I think it has something to do with path directions:
my mail is now sent straight to var/mail/eric (eric is my username)
and get held there if I don't read them.

if i do read them they get saved in /home/eric/mbox.

I think I need to set up procmail? Is this a good idea?

Thanks for the suggestion!

dado prso
April 19th, 2010, 08:56 PM
Ok, so what I'm trying to do is have all mail that goes through my sendmail be sent to a named pipe so I can gather statistics.

I tried to get a .forward file working; I'm having trouble, but I believe this is the best way to go.

Any advice?