View Full Version : [ubuntu] Resolution settings messed up Ubuntu 9.10, Nvidia

April 14th, 2010, 12:54 AM

I loaded up Ubuntu earlier, and I noticed my resolution was messed up. The screen has shrunk from 1440x900 to so small that I can't even access the menus in the top left to run applications (they're covered by panel applets (launchers, etc.))

I tried:
sudo nvidia-settings

and at first the 1440x900 option was missing. Now that I've reboot once, I can't even select an option. The drop-down simply does nothing. I'm stuck at 640x480 and my system is completely unusable (exception of the terminal)

Here is my /etc/X11/xorg.conf:

johnny@johnny-desktop:~$ cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Fri Aug 14 18:33:37 PDT 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Virtual 1440 900

Is there any way I can fix this without unnecessary hacking? I don't even know why it messed up in the first place.

Can I reinstall the nvidia-drivers?

Can I generate a new xorg.conf?

Please, any help you can offer would be greatly appreciated. My machine is practically a brick right now, and I was in the middle of an important task that I'd like to get back to. Let me know if you need the output of any commands or the contents of any files.

April 14th, 2010, 04:07 AM
Every time I mess up my configuration I delete
and run
and restart

Or maybe you prefer to move xorg.conf somewhere else instead
of deleting it (backing up is recommended).

nvidia-xconfig will create a new xorg.conf for you.

April 14th, 2010, 04:58 AM
Hi azzamite, I've tried this, and I'm still stuck with the same problem.

I read that removing the HorizSync and VertRefresh options from xorg.conf can fix the problem. I commented these lines out, and now I can access higher resolutions (making the situation a bit more bearable), but I still can't get 1440x900.

I've also followed all the guides on the wiki for manually editing xorg.conf, but it seems the settings there have no effect on nvidia-settings. I'm very close to using some very strong curse words. The only thing I could imagine causing this would be a system upgrade (as it's the only new software that's been added since before the problem occurred).

April 14th, 2010, 07:19 PM
no one? :(