View Full Version : [ubuntu] Can get to my server using my DYNDNS name

April 12th, 2010, 10:20 PM
Hi there,

I have setup a web server, ftp, ssh with ubuntu server which is working with phpmyadmin and webmin installed with it as well. (I am considering upgrading to 10.04LTS when it comes out)

However I canít get to my website with the domain name that I am using from dyndns.
From on my LAN I can get to my server but using it ip address ( and it work fine with ssh and ftp as well. But when I try my public address or my name it does not work. I am using IE8 as I am using a windows machine.

Out side the network the domain name wonít work at all, but I tried my public address and everything worked perfectly.

I have recently installed ddclient to see if had made any difference but no luck. But I am keeping it there as it is working and updating my ip address.

I have been looking on Google and tried a few things but have had no luck at all at fixing the problem.

I am completely confused so any input is welcome so I can learn from this.

Ryan Dwyer
April 12th, 2010, 11:09 PM
You won't be able to use your domain name from inside your network.

You said you can access it from outside using your public IP address but not your domain name. You need to make sure your domain name resolves to your public IP address.

April 12th, 2010, 11:20 PM
Oh, that will resolve why i canít use my domain on my lan,

I have installed the ddclient which updates my public addresses for me but it still canít get to my website etc with the domain name out side my network.
I thought i had the wrong ip address on dyndns settings and installed ddclient to update the address for me.

April 13th, 2010, 02:20 AM
You won't be able to use your domain name from inside your network.

I can use my domain from inside my network.

If you access your server on the same network you dont need ddclient if you have dyndns. The updater should take care of that.

IF you are accessing your server on the same network that the server is on then just go to dyndns.com and click update my ip address.

If thats the same ip you have on your server then

Check to make shur your ports are open (I.E port 80 for http.)

If what i am saying is completely useless to you try


I was having the same problem as you but that helped me trouble shoot it.

Hope that helps.

April 14th, 2010, 03:19 AM
Do you have the necessary ports forwarded in your router?

April 14th, 2010, 12:23 PM
HI, the port forwarding was ok as i could connect with my public ip address, but i followed the link that cK` had put on his post and this helped me getting everything working ok.

Thanks for the help guys,