PDA

View Full Version : [ubuntu] 10.04 won't boot without monitor / keyboard (headless)



herrison
April 12th, 2010, 11:03 AM
I have several computers, both Ubuntu and windows xp. I have just put 10.04 onto a computer that I propose to boot without a monitor and to access from elsewhere using vinagre / vnc.
Having installed 10.04 (and very nice it is too!), the computer will not boot without a monitor attached. After powering up and attaching a monitor, I see a black screen that requires a hard power-down to escape from. Boots fine with a monitor attached, thereafter I can detach the monitor and vinagre fine.
I have reviewed this machine's bios (an HP desktop) and see no mention of suspending boot on no monitor.
I have replaced the /etc/X11/xorg.conf file with the failsafe and have edited and updated the grub conf file to "quiet" as recommended elsewhere. No joy.
I gather that this may be related to a monitor test that's performed when x starts up.
Thanks in advance for all help. I can see that there are a quite a few threads on this subject over the last year.

croco001
April 28th, 2010, 06:31 PM
I have the exact same problem.

Bug in launchpad : https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/568079

I found a fix , that work well for me. I restored an old xorg.conf file from my previous installation (8.04) and now, i can boot without monitor.:P


This is my xorg.conf, if that can help someone.



# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Sun Feb 1 20:21:04 UTC 2009


Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "CRT-1"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
EndSection

Section "Device"
Identifier "Default Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro FX 500/FX 600"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Default Device"
Monitor "Monitor0"
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select @1024x768 +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "nvidia-auto-select @1024x800 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

digitalencore
May 3rd, 2010, 02:17 PM
No luck for me.. Can you explain further how to solve the issue?

digitalencore
May 3rd, 2010, 02:50 PM
Has anyone try reconfigure the xorg.conf to be the basic configuration as follows:
Section "Device"
Identifier "VNC Device"
Driver "vesa"
EndSection

Section "Screen"
Identifier "VNC Screen"
Device "VNC Device"
Monitor "VNC Monitor"
SubSection "Display"
Modes "1024x768"
EndSubSection
EndSection

Section "Monitor"
Identifier "VNC Monitor"
HorizSync 30-70
VertRefresh 50-75
EndSection

cyanics
May 5th, 2010, 08:09 PM
Bump.

I am also having the same problem. Did an upgrade form a very stable 9.10 to 10.04 last night. It hosed my boot up. Upon reattaching KVM, it immediately rebooted up to the new gui. When i detached and rebooted, it was borked again.

I did a fresh install of 10.04 and was able to get it to work correctly, with no KVM attached, but without the monitor, it won't start GDM. I use GDM for some graphical network monitoring tools.

VNC works fine.

ceo51378
May 21st, 2010, 03:18 AM
Bump. I'm having the same issues as well with 10.04.

gunterhausfrau
May 21st, 2010, 03:43 AM
I think I may be having the same issue. Upgraded from 9.10 to 10.04 and since then cannot boot. Tried removing the KVM and plugging in the USB mouse/keyboard directly, didn't work, tried pulling that and plugging in an older keyboard, nothing, seems to be in boot up hell. I get endless messages, not sure what is significant. seems to stop sometime after "checking battery state" huh? I go to the recovery, and after choosing some flavor of 9.10 (only options) I get a menu where I should be able to chose several options (repair packages is one) but if I try to select a flash of full screen text shoots past and I'm back at the menu (cant select anything). Help please.

gogreenpower
May 27th, 2010, 11:28 AM
bump

same problems

michaelA1330
May 27th, 2010, 11:30 AM
bump bump
same problem here

ricardoph
May 30th, 2010, 04:13 AM
Same problem here... wrote a post, and found this one just now.... :(

kentoe
June 2nd, 2010, 10:35 PM
Won't work here either. I've tried multiple xorg.conf files including the one specified in the second post.

(I'm using an ATI onboard card on a compaq)

Seems as though there's no xorg.conf file in /etc/X11 and that X automatically tries to recognize devices now with the new 10.04. While that's neat and all, not having an xorg.conf causes this problem.

I've also tried using what is in xorg.conf.failsafe which is


Section "Device"
Identifier "Configured Video Device"
Driver "fbdev"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

But this hasn't helped at all.

kentoe
June 3rd, 2010, 08:48 PM
Hey guys, here's a workaround I found. However, unfortunately not as easy as just vncing into it. I'm sure if some script was made or some type of configuration was put in place it would work.

Installed ssh to ubuntu.
Installed vncserver

sudo apt-get install tightvncserver
Installed x11vnc

sudo apt-get install x11vnc

SSH into the system from another system

Start the vncserver

vncserver –geometry widthxheight –depth 24

This should output something relative to


YourServerName:1

This is a display vnc creates (Original display, which we can't get working is :0) If you run the vncserver command multiple times it will create a :2 :3 and so on.

Now is the time to get this up and working.


x11vnc -storepasswd
This creates a password.

Then we launch it,

x11vnc -usepw -display :1

:1 is the display we created with the original vncserver command.

Once correctly launched it should say something like this.

The VNC desktop is: yourdesktopname:1
PORT=5903


Go to your vnc client, enter


ipaddress: port

and it should connect!

crinkelcut_chip
June 5th, 2010, 12:08 AM
...easiest solution for this at the moment I'd say is

1) either
a) buy a dvi-vga adapter (if your computer has a dvi output on its graphics card)
b) buy a vga joiner or sorts if your computer has a vga output... like http://www.jaycar.com.au/productView.asp?ID=PA0898&keywords=vga&form=KEYWORD

2) Then buy 3 60-80ohm resisters (75ohm is ideal) (.25- .5w) like
http://www.radioparts.com.au/ProdView.aspx?popup=1&Category=SXLL7205&Product=37551268&ProdDesc=RMF68+68+OHM+1%2f4W+1%25+MF25

3) Push each end of a resister firmly into a hole on the socket
...you need to put the load between (on the vga socket of your adapter)
pins
1-6
2-7
3-8

Then plug into graphics card...

This will simulate a load on the graphics card... essentially the computer will think there is a generic monitor is attached..

Zlobomir
June 6th, 2010, 06:51 PM
Well, the solution in the last post is really geeky.
But I have a 10.04 server which needs X, and which is attached to KVM and monitor, so that I can't use the joiner, neither keep the CRT monitor constantly on. On each reboot or power loss I have to go to the next room, power on the monitor, login and type "start x".
Sorry for the harsh words, but the genius that has applied this has to be expelled from the team for good. Like the sound issues (line out identifies 1:1 digital) and therefore line out can't be attached .

Matt.Sleepy
June 8th, 2010, 10:40 AM
This tutorial helped me fixing the problem (tut is for 9.10 buts works perfectly with 10.04).
You only need a monitor connected while setting up your xorg.conf, than you can boot into X without monitor.

Howto (http://markbrewster.wordpress.com/2010/02/04/ubuntu-9-10-not-starting-up-at-full-resolution-with-tv-turned-off/)

gggie
June 13th, 2010, 03:42 AM
I can't believe there's not an easier solution to this... I don't have an nvidia card so I don't think the post above me will work.

The method in this thread (http://ubuntuforums.org/showthread.php?t=1297815) (editing xorg.conf) worked for me up to 9.10, but doesn't in 10.04.

Enthrall
June 14th, 2010, 04:47 AM
Nothing in 10.4 appears to work for me in xubuntu iv tried different xorg configs and they all end up with black screen like when I boot without a monitor.

EternalLiberty
June 24th, 2010, 09:35 PM
I may be having the same problem. I setup Ubuntu 10.04 on a new computer and enabled remote desktop. However, after I was done, I tried to restart the computer without the monitor but it never finished booting or started the VNC server. If I reconnect the monitor, it only display a blank screen. If I restart the computer with the monitor, it works fine.

I've been trying to get a Ubuntu computer working headless since Ubuntu 8.4, it always does this on all the computers I try.

Has anyone found a solution?

lusixhan
June 30th, 2010, 01:36 AM
Same problem. I'm even running the 10.04 server install!

bapool
July 2nd, 2010, 08:56 PM
This is getting frustrating. I just redid both my servers to 10.04 and put them in the closet, and then discovered this wonderful bug. Server works great if there is a monitor connected. I have mine boot to command line and then I putty in and startx only if I need to use the GUI. Of course I can't startx in 10.04 now since there is no monitor in the server closet (actually there is one and I move the vga extension cable to the server I need to mess with) but I digress.

If anyone finds a good solution to this please post it. If I do, I will likewise!

Brian

PS Actually it works fine without the monitor, except the remote in and startx bug.

bapool
July 3rd, 2010, 02:12 PM
YEA! I got it.

The answer is actually a combination of two separate solutions, each of which did not work separately. I have 10.04 now working headless on two different servers (different MB, Video...) and both are working great.

Step 1. Create a xorg.conf in /etc/X11 with the following. I tried Step 2 without doing this and it failed exactly as it had before.

Section "Device"
Identifier "VNC Device"
Driver "vesa"
EndSection

Section "Screen"
Identifier "VNC Screen"
Device "VNC Device"
Monitor "VNC Monitor"
SubSection "Display"
Modes "1024x768"
EndSubSection
EndSection

Section "Monitor"
Identifier "VNC Monitor"
HorizSync 30-70
VertRefresh 50-75
EndSection

Step 2. Disable KMS for your video card as described here https://wiki.ubuntu.com/X/KernelModeSetting

The jist is to know which video card manufacturer you have and use the command line entry below it to create the appropriate kms.conf file with the line "options...modeset=0" line in it. If you have access to the GUI you could just are easily create/modify the file and put the "options...modeset=0" in as appropriate.

The following are input into the terminal windows as a line command.

# ATI Radeon:
echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf

# Intel:
echo options i915 modeset=0 > /etc/modprobe.d/i915-kms.conf

# Nvidia (this should revert you to using -nv or -vesa):
echo options nouveau modeset=0 > /etc/modprobe.d/nouveau-kms.conf

Step 3. Reboot...Putty In...startx...GTG!


Brian

paosms
July 4th, 2010, 03:27 PM
hi there,
how to you actually turn the kms off?
i mean, where do i have to put the line

# Intel:
echo options i915 modeset=0 > /etc/modprobe.d/i915-kms.conf


?

or maybe i'm getting this wrong, i just have to create

a i915-kms.conf file

into modprobe.d

with a single line in it saying "echo options i915 modeset=0"

thanks

bapool
July 4th, 2010, 07:17 PM
hi there,
how to you actually turn the kms off?
i mean, where do i have to put the line

# Intel:
echo options i915 modeset=0 > /etc/modprobe.d/i915-kms.conf


?

or maybe i'm getting this wrong, i just have to create

a i915-kms.conf file

into modprobe.d

with a single line in it saying "echo options i915 modeset=0"

thanks

The entire line that you put in the terminal (or command line) is
echo options i915 modeset=0 > /etc/modprobe.d/i915-kms.conf

This creates the file i915-ams.conf in the /etc/modprobe.d/ directory with one line in it

options i915 modeset=0

It worked on both of my boxes (although mine is an ati card). Hope that gets it for you!

Brian

paosms
July 5th, 2010, 01:45 PM
Hi there!
I found another solution, perhaps simpler than the one just shown because it doesn't require to know or look for the video card supplier.

Since I couldn't access the /etc/modprobe.d/ directory (not even as root, dunno why!) I found that you can disable the kms at startup by modifying the grub file, it's really simple.

For systems -and for those only!- that use GRUB2 (like 10.04) do as follow, it worked for me:

STEP 1

#
sudo gedit /etc/default/grub

this will open the grub file. Now find the line that says GRUB_CMDLINE_LINUX and add "nomodeset".

you'll have to end up with something like this:
GRUB_CMDLINE_LINUX="nomodeset"

now update the grub from terminal with

#
update-grub

STEP 2
use bapool's xorg.conf file

STEP 3
You're done! reboot and unplug the monitor, ubuntu 10.04 will work headless and load vesa driver without any problems!

bigsigh
July 9th, 2010, 12:58 AM
Installed 10.04 Lucid server with/for raid 1.
Installed Ubuntu desktop with tasksel.

Failed to boot headless, without a monitor.

Used the above posts to achieve a headless install.

Created the xorg.conf in /etc/X11 with the following:

Section "Device"
Identifier "VNC Device"
Driver "vesa"
EndSection

Section "Screen"
Identifier "VNC Screen"
Device "VNC Device"
Monitor "VNC Monitor"
SubSection "Display"
Modes "1024x768"
EndSubSection
EndSection

Section "Monitor"
Identifier "VNC Monitor"
HorizSync 30-70
VertRefresh 50-75
EndSection

Then, edited the grub file: sudo gedit /etc/default/grub
and added the following line as such:

GRUB_CMDLINE_LINUX="nomodeset"

Thanks to the original posters.

lank23
July 11th, 2010, 11:36 PM
Tried the above solutions, but they did not work for me, but I did find a quick fix that did work ;).

I have a little different set up then above due my set up is for Mythtv.

The connections are as follows.




PC FX5200 DVI -> DVI+SPIF to HDMI "monoprice unit" -> 4-WAY HDMI selector "monoprice unit" -> TV "Sony 52 inch"



I narrowed it down that the PC would boot if a regular monitor was plugged into the PC FX5200 DVI, or if there was nothing plugged in to the PC. Looking at my logs there was never any boot log made when the PC was connected up normally as above, so the boot process must had been stopping at Grub. As report above I had no issue when running 8.04 but this used the old Grub, and 10.04 uses the new Grub. To fix the issue I did as follows.

Open a terminal and type in this command




sudo gedit /etc/default/grub



Find the line below and remove the "#" save the file and close gedit




GRUB_TERMINAL=console



Next update grub by doing this command in the terminal




sudo update-grub



Reboot the machine.

zurkog
July 14th, 2010, 04:37 PM
Got it working! I've tried several methods, but #24 (paosms' post) got it to work. I used his edit to grub, and bapool's xorg.conf file, and my Ubuntu 10.04 box now boots cleanly without a monitor attached (for the first time ever).

Thanks!

Steverman
July 14th, 2010, 08:32 PM
Got it working! I've tried several methods, but #24 (paosms' post) got it to work. I used his edit to grub, and bapool's xorg.conf file, and my Ubuntu 10.04 box now boots cleanly without a monitor attached (for the first time ever).

Thanks!

Please help me. I am new at linux community. I cannot create the xorg.conf inside the x11 folder. It does not let me do anything in this folder. If somebody can tell how to create the fbapool's xorg.conf file, i would be grateful.

Thanks

lank23
July 14th, 2010, 11:22 PM
Please help me. I am new at linux community. I cannot create the xorg.conf inside the x11 folder. It does not let me do anything in this folder. If somebody can tell how to create the fbapool's xorg.conf file, i would be grateful.

Thanks

open an terminal run "sudo gedit" open the file edit it then save and close gedit.
reboot machine.

zurkog
July 16th, 2010, 03:28 PM
Please help me. I am new at linux community. I cannot create the xorg.conf inside the x11 folder. It does not let me do anything in this folder. If somebody can tell how to create the fbapool's xorg.conf file, i would be grateful.

Thanks

That's because the /etc/X11 folder is owned by root, with permissions that only allow the root user to add/change/delete files within it. If you open up the terminal application, and enter:

sudo gedit /etc/X11/xorg.conf

and then enter your password, it will let you create that file (just remember to click "Save" when you're done). Copy and paste the config from post #21 into the Gedit window.

odLott
August 12th, 2010, 02:10 PM
Well I'll be damned. I really thought bapool's and paosms' solutions would fix it for me, but so far nothing is working.

hurt138
August 19th, 2010, 04:25 PM
YEA! I got it.

The answer is actually a combination of two separate solutions, each of which did not work separately. I have 10.04 now working headless on two different servers (different MB, Video...) and both are working great.

Step 1. Create a xorg.conf in /etc/X11 with the following. I tried Step 2 without doing this and it failed exactly as it had before.

Section "Device"
Identifier "VNC Device"
Driver "vesa"
EndSection

Section "Screen"
Identifier "VNC Screen"
Device "VNC Device"
Monitor "VNC Monitor"
SubSection "Display"
Modes "1024x768"
EndSubSection
EndSection

Section "Monitor"
Identifier "VNC Monitor"
HorizSync 30-70
VertRefresh 50-75
EndSection

Step 2. Disable KMS for your video card as described here https://wiki.ubuntu.com/X/KernelModeSetting

The jist is to know which video card manufacturer you have and use the command line entry below it to create the appropriate kms.conf file with the line "options...modeset=0" line in it. If you have access to the GUI you could just are easily create/modify the file and put the "options...modeset=0" in as appropriate.

The following are input into the terminal windows as a line command.

# ATI Radeon:
echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf

# Intel:
echo options i915 modeset=0 > /etc/modprobe.d/i915-kms.conf

# Nvidia (this should revert you to using -nv or -vesa):
echo options nouveau modeset=0 > /etc/modprobe.d/nouveau-kms.conf

Step 3. Reboot...Putty In...startx...GTG!


Brian

This worked for me, but I had to change

Driver "vesa"

to

Driver "nv"

For some reason I didn't have the vesa drivers and since I have a old nvidia card in the server I just went for the nv.

hexor
August 25th, 2010, 04:22 PM
thanks to paosms (http://ubuntuforums.org/member.php?u=659552) and bapool for the solution!

props from brazil :)

GiganticDays
August 28th, 2010, 09:51 AM
Just like to say thanks to bapool for his solution which works for me.
Only one fly in the ointment; when I VNC into my (now headless) server the only resolution I can get is 640 x 480.
Any ideas on how I can get this up?

Actually it's not just when I VNC in, I hooked up the monitor again and the screen resolution is fixed at 640 x 480

emas80
August 31st, 2010, 02:42 PM
Hi, the posted solution works well for me, but as GiganticDays said the resolution is fixed.

I will continue with "temporary" fix, an external monitor so that only x11vnc install and configuration is needed.

GiganticDays
August 31st, 2010, 03:12 PM
I found a solution to the resolution issue.

I stopped using TightVNC and am now using FreeNX instead. Works a treat and you can set whatever resolution you like.

manco1911
September 5th, 2010, 05:43 AM
I wasnt able to boot without monitor.

Followed paosms steps (including bapool xorg).
Now it works perfectly.

First time trying to do this.

Thanks guys.

PD: o also coulnt access modprobe.d, nor as user or root.

GiganticDays
September 5th, 2010, 10:47 AM
Check your BIOS and disable Halt on keyboard and any other "Halt On" options.

jkurtisr32
September 9th, 2010, 01:53 AM
Check your BIOS and disable Halt on keyboard and any other "Halt On" options.

Yeah, I would think that this could be a BIOS issue.

I found these settings, but I am unsure which selection will fix the issue.
Halt on............ [All , But keyboard] <<< Was default setting
[All errors]
[No errors] <<<< I assume this is the one I want

I guess I'll just try them all...

-Kurt

Ryuho
September 9th, 2010, 06:22 AM
I just tried bapool's solution (making /etc/X11/xorg.conf with the specified content, and then switching to root then running 'echo options i915 modeset=0 > /etc/modprobe.d/i915-kms.conf' since My graphics card was Intel) and it works!

Thanks for the solution :)

GiganticDays
September 9th, 2010, 07:37 AM
@jkurtisr32
[No errors] is the one you want

jkurtisr32
September 9th, 2010, 05:49 PM
Hey, thanks for specifying the selection, but unfortunately it didn't work. I did try all of the available selections, and NONE of them worked.

I might try some of these more complicated software workarounds described above, but I think that due to my limited knowledge of the operating system, I think I might just try a hardware fix.

The below quote contains a very clever workaround that would be an easy application.


...easiest solution for this at the moment I'd say is

1) either
a) buy a dvi-vga adapter (if your computer has a dvi output on its graphics card)
b) buy a vga joiner or sorts if your computer has a vga output... like http://www.jaycar.com.au/productView.asp?ID=PA0898&keywords=vga&form=KEYWORD

2) Then buy 3 60-80ohm resisters (75ohm is ideal) (.25- .5w) like
http://www.radioparts.com.au/ProdView.aspx?popup=1&Category=SXLL7205&Product=37551268&ProdDesc=RMF68+68+OHM+1%2f4W+1%25+MF25

3) Push each end of a resister firmly into a hole on the socket
...you need to put the load between (on the vga socket of your adapter)
pins
1-6
2-7
3-8

Then plug into graphics card...

This will simulate a load on the graphics card... essentially the computer will think there is a generic monitor is attached..

bontux
October 6th, 2010, 11:21 PM
Post #26 from lank23 work for my 10.04 Mythbuntu box. Thank you lank23!

lank23
October 7th, 2010, 05:41 PM
Post #26 from lank23 work for my 10.04 Mythbuntu box. Thank you lank23!

:) Welcome! Glad it worked.

static_g
October 17th, 2010, 03:30 PM
I previously configured this Lucid box to start tightvnc server so I could remote in. When I unplugged the monitor and rebooted, couldn't vnc in. I could ssh in. Plugging in the monitor gave a nice black screen.

lank23's post #26 did it for me. I can now vnc in when it boots with no monitor attached -- perfectly headless. Plugging in the monitor after reboot also works -- seems a low resolution, but a monitor will never be attached so I don't care. Into the closet it goes!

Thanks everyone. :)

InphekD
October 26th, 2010, 07:05 PM
Alternative:

1. Edit GRUB

sudo gedit /etc/default/grub2. Find & Uncomment

GRUB_TERMINAL=console3. Update GRUB

sudo update-grub or/and
su -c update-grub4. Create xorg.conf file.
Example:

Section "Monitor"
Identifier "VNC Monitor"
Modeline "1440x900_60.00" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync
Option "PreferredMode" "1440x900_60.00"
EndSection

Section "Device"
Identifier "VNC Device"
Driver "ati"
Option "VNC Monitor"
EndSection

Section "Screen"
Identifier "VNC Screen"
Device "VNC Device"
Monitor "VNC Monitor"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1440x900"
Virtual 1440 900
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "VNC Screen"
EndSection5. Restart

sudo shutdown -r nowFew notes:
- Now there is no need to turn off KMS.
- No tearing if you decide to attach a monitor.
- Can use power profile management with ATI OSS

marktyler
November 10th, 2010, 01:52 PM
It may also be worth checking your client as well. I was trying for ages with screensharing from the mac - it used to work in the past, possibly when a monitor was attached, but doesn't now. Downloading a different VNC client got me straight in. If only I'd tried that earlier.

vslice24
December 25th, 2010, 10:12 PM
So I'm having same issues as everyone here. I am runnign 10.04 LTS. i have a server/media center, that is plugged into my tv. If i have my TV off my server does not boot into ubuntu. I can ssh into it but can not vnc using tightvnc viewer. I have tried adding the xorg.conf file, changing grub, and adding the modeset=0. I have an intel board with onboard hdmi. Can anyone help me out with this problem? Thx

PaphosAL
January 26th, 2011, 07:20 PM
So I'm having same issues as everyone here. I am runnign 10.04 LTS...

Same version as me, but my setup is a bit weird compared to others in this thread. I have two Compaq D51S machines, one running XP Pro, and the other on Ubuntu 10.04

The Ubuntu system acts as a server for my two DM500S linux satellite receivers, on 24/7. But it also doubles as my dev platform for modding Neutrino and Enigma tuxbox images for the sat boxes. Both PCs share the same monitor, (which is a 22" LCD TV) via a passive '2 in - 1 out' vga switch box.

I wanted to set up a daily Gnome Scheduler cron job 'as' root to reboot the Ubuntu PC at 05:20 daily, 5 minutes before both sat boxes do their cron reboots. Getting the right command to do that in Ubuntu is another story, but here is the bottom line:

20 5 * * * /sbin/shutdown -r now

Fine, this does the job. Downside was, that as the monitor is invariably switched through to the XP machine, Ubuntu threw it's toys out of the pram at finding no monitor. It didn't halt, and was all working normally via ftp and telnet, and was still serving the sat boxes. But when I switched the monitor thru to Ubuntu, black screen, no GUI...

This is when I googled and found this very educational thread. Before following ALL the recommended steps in the more recent posts above, I had a good browse in Ubuntu itself, and found something rather interesting in System > Admin > View Logs

Here, I found the xorg logs, which suggested that 10.04 is looking for it's xorg config file in /usr/lib/X11/xorg.conf.d/ - so I tried bapool's xorg.conf from post #21 in that folder AND in /etc/X11 and no other mods whatsoever. I then set up a one-off cron reboot of Ubuntu for 13:20 then switched the monitor back to XP and shut XP down, leaving the Ubuntu machine running. Off to the pub...

Later, with XP fired up again, I accessed Ubuntu via telnet and did the uptime command. 3 hrs 10 mins was the reply, so the auto-reboot had worked. Then the acid test- switch monitor to Ubuntu. Voilá!! There's my beautiful Ubuntu Desktop GUI !!!

A very BIG thanks to everyone who has contributed to this thread, but especially to bapool - you're a star!!

Cheers- AL :P

PaphosAL
January 27th, 2011, 11:17 AM
By way of a postscript, I didn't like the ambiguity of my configuration, in terms of having two identical xorg.conf files on two different paths. So before turning in last night, I deleted the one I'd added into the usr/lib/X11/xorg.conf.d/ folder, leaving just the one in the recommended /etc/X11/ folder.

I checked the uptime status at 08:25 and this was reported as 3 hrs 5 mins, so the cron reboot worked fine at 05:20

Another bonus I've found is that the Refresh Rate for my 'unknown' monitor is now 76 Hz, wheras the previous config only gave 60 Hz. I hope this info helps any 10.04 LTS users who are still struggling with headless reboots. Bapool's xorg.conf in post #21 seems to do the job!

Cheers- AL :)

stiltzkin_
March 7th, 2011, 07:27 PM
Hi!

Im new to the forums and Ubuntu. As many others in this thread im trying to boot my PC without monitor.

What I´ve done so far is to add the "nomodeset" to GRUB and then I have created the xorg.conf file in /etc/X11.


When I then try to reboot it I get a message that says that my vesa driver ins´t functioning or is missing. I have tried to install it by using

sudo apt-get install xserver-xorg-video-vesa

but it says that it is already installed. Im confused as I have done these steps on the same computer for a couple of months ago, I have just switched harddrives.

Any help is appreciated.




UPDATE, this is the error-message i get:

(EE) VESA: Kernel modesettning driver in use, refusing to load
(EE) No devices detected.

mortenblaa
April 21st, 2011, 11:21 AM
I'm fairly new to Ubuntu but I would guess your system is trying to load two graphics kernels, and they conflict. Have you installed any nvidia or ati drivers?

Try using nv (nouveau) instead of vesa. It appears to have worked for others. Perhaps the nouveau driver is the problem and you have to disable it. I got errors using the nouveau drivers alongside nvidia drivers (it simply wouldn't boot the gui).

deonast
May 9th, 2011, 02:39 PM
I'd just like to say thanks to paosms and bapool especially but also to all the contributions on the site. Thanks to bapool's xorg.conf and paosms steps I was able to finally get a resolution when remoting my headless box via vino vnc of greater than 800x600.

I can't tell you how many hours I spent hunting through the web trying fixes that didn't seem to work for me. Seems it is always the edge cases that linux inflicts the greatest grief. I just wish ubuntu developers could see these threads and give a better system of manual monitor selection for those seeking a headless solution. Every version of Ubuntu I've tried previously always seems to have this issue.

PaphosAL
May 31st, 2011, 10:27 AM
There does seem to be one disadvantage with this fix. My Ubuntu always boots 'as' User = AL

But if I try to switch users to root - I no longer seem to be able to do this; the machine hangs and requires a manual reboot.

Are some additional mods required to account for other users, please?

Cheers- AL :(

duuso
June 23rd, 2011, 09:18 PM
Up we go! Co-signing: bug should be fixed.

djtrella
July 5th, 2011, 05:37 PM
Hi guys,
first of all I have to say I'm completely new to ubuntu, anyway I'm studing ....

I followed paosm (thanks! an thankls to baptool too) instruction at #24 (http://ubuntuforums.org/showpost.php?p=9549942&postcount=24) and i got tight vnc working without the monitor but the resolution is fixed to 800x600 as other users sad before. Did you find a solution for this (still using VNC)?

I've an asrock ion 3d (so a nvidia card) but I did'nt install nvidia driver for now.

What do u suggest?

Greetings
Trella

xsho3
July 17th, 2011, 04:03 PM
ciao a tutti .ho istallato ubuntu 10.04 desktop
a me serve che funziona senza monitor,ho fatto qsta correzione nel terminal sudo /etc/init.d/gdm stop
dopo fatto qsta scritta si e spento il ubbuntu e adesso non si vede piu una scritta nel monitor.non esce nemeno la scritta brios sckermo totalmente buoio
chi sa come posso uscirne da qsto problema
ciao e grazie

tochtliT
July 24th, 2011, 10:37 PM
Hi there!
I found another solution, perhaps simpler than the one just shown because it doesn't require to know or look for the video card supplier.

Since I couldn't access the /etc/modprobe.d/ directory (not even as root, dunno why!) I found that you can disable the kms at startup by modifying the grub file, it's really simple.

For systems -and for those only!- that use GRUB2 (like 10.04) do as follow, it worked for me:

STEP 1

#
sudo gedit /etc/default/grub

this will open the grub file. Now find the line that says GRUB_CMDLINE_LINUX and add "nomodeset".

you'll have to end up with something like this:
GRUB_CMDLINE_LINUX="nomodeset"

now update the grub from terminal with

#
update-grub

STEP 2
use bapool's xorg.conf file

STEP 3
You're done! reboot and unplug the monitor, ubuntu 10.04 will work headless and load vesa driver without any problems!

Thanks guys I just registered to the forum just to say your post solved my problem with one try! Excellent job!:)

wjamoore
August 27th, 2011, 12:55 PM
Neither method worked for me.

Using a ASUS E35M1 deluxe MB and all I see is a black screen if I have no monitor.

What a pain

cheers

wjamoore
August 27th, 2011, 03:32 PM
An more.

I tried to sudo gedit the xorg.conf, and it was empty.. That's strange I thought. I'm sure i saw stuff in there. So i just navigated to it and there was stuff in there (As per post24)

So back to sudo gedit /etc/x11/xorg.conf ..... empty. hmm

Pasted in the contents again and it wouldn't let me save it saying something about not existing.

Double checked the path... nope got it right. So what's going on??

I can look in /etc/x11/xorg.conf with nautilus and see the contents but if I sudo gedit /etc/x11/xorg.conf there's nothing in there and furthermore I cannot edit it.

arrgghh

any thoughts greatly appreciated

wjam

bab1
August 28th, 2011, 11:00 AM
An more.

I tried to sudo gedit the xorg.conf, and it was empty.. That's strange I thought. I'm sure i saw stuff in there. So i just navigated to it and there was stuff in there (As per post24)

So back to sudo gedit /etc/x11/xorg.conf ..... empty. hmm

Pasted in the contents again and it wouldn't let me save it saying something about not existing.

Double checked the path... nope got it right. So what's going on??

I can look in /etc/x11/xorg.conf with nautilus and see the contents but if I sudo gedit /etc/x11/xorg.conf there's nothing in there and furthermore I cannot edit it.

arrgghh

any thoughts greatly appreciated

wjam

The file should be at: /etc/X11/xorg.conf (capital X). If you are going to use a GUI text editor such as gedit then the incantation from the terminal should be
gksudo gedit/etc/X11/xorg.conf If you wish to use a terminal based editor such as nano or vim you can use
sudo nano /etc/X11/xorg.conf

The command sudo should only be used for terminal based apps. The command gksudo is used for GUI based apps (even if you are launching them from the terminal). FYI -- to detach the GUI editor from the terminal you can use an & at the end of the incantation. This will allow you to close or reuse the terminal without killing gedit. It looks like this
gksudo /etc/X11/xorg.conf &

neltron
October 6th, 2011, 07:00 AM
thank you.
this worked for me with post #21 bapools xorg.conf file as indicated
full boot to desktop with monitor plugged in.

neltron
October 6th, 2011, 07:01 AM
*without* monitor. (headless)

leonelgracias
October 12th, 2011, 06:09 PM
The post #24 work for me
I have a Ubuntu Lucid.

Just have to install x11vnc before change xorg.conf

Thanks.

ramsrom
November 2nd, 2011, 11:37 PM
For ubuntu 11.10 the only thin which worked was

1) Install dummy monitor by

sudo apt-get install xserver-xorg-video-dummy

2) Backup xorg.conf by

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

3) Then create a new xorg.conf

sudo gedit /etc/X11/xorg.conf

with:



Section "Device"
Identifier "Configured Video Device"
Driver "dummy"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
HorizSync 31.5-48.5
VertRefresh 50-70
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x800"
EndSubSection
EndSection


(seen on: http://blog.mediafederation.com/andy-hawkins/ubuntu-headless-vnc-vesa-800x600-fix/)

fruitytuter
February 29th, 2012, 03:08 AM
here's a simple hardware solution that causes computer to recognize a fake monitor, all you need is three, 75 ohm resistors.
here is the link
http://www.overclockers.com/forums/showthread.php?t=666716

SergeantPanda
August 25th, 2012, 02:14 AM
For ubuntu 11.10 the only thin which worked was

1) Install dummy monitor by

sudo apt-get install xserver-xorg-video-dummy2) Backup xorg.conf by

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak3) Then create a new xorg.conf

sudo gedit /etc/X11/xorg.confwith:



Section "Device"
Identifier "Configured Video Device"
Driver "dummy"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
HorizSync 31.5-48.5
VertRefresh 50-70
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x800"
EndSubSection
EndSection
(seen on: http://blog.mediafederation.com/andy-hawkins/ubuntu-headless-vnc-vesa-800x600-fix/)
Worked perfectly for me. Thanks!:p

varelov
September 7th, 2012, 11:42 PM
Sorry to dig up such an ancient topic from grave, but I need help. Trouble following instructions per /etc/default/grub. Such a file doesn't exist on my system, ubuntu 10.04. Boots otherwise just fine. What would the alternative to this file be?

SergeantPanda
September 22nd, 2012, 06:20 PM
Sorry to dig up such an ancient topic from grave, but I need help. Trouble following instructions per /etc/default/grub. Such a file doesn't exist on my system, ubuntu 10.04. Boots otherwise just fine. What would the alternative to this file be?
I think it's under "/boot/grub".

iRiKi
January 23rd, 2013, 03:33 PM
YEA! I got it.

The answer is actually a combination of two separate solutions, each of which did not work separately. I have 10.04 now working headless on two different servers (different MB, Video...) and both are working great.

Step 1. Create a xorg.conf in (...)
Step 2. Disable KMS for your video card (...)
Step 3. Reboot...Putty In...startx...GTG!

OH MAN I COULD KISS YOU RIGHT NOW!!!!!!!!!!!

Spend DAYS looking for this solution.. HEADLESS 10.04 LTS 64bits but nothing worked.. until you came and saved the day!!

If I weren't buried in depth and without a job, I would surely donate! Thank you, neoliberals!

Again, thank you so much!!

*NOTE* I had previously also installed the x11 dummy driver
(sudo apt-get install xserver-xorg-video-dummy) in case someone trying this.