View Full Version : [ubuntu] Integrated sound card not detected

April 9th, 2010, 09:00 PM
I have a DFI RS482 mobo with integrated sound. I am making a car puter and only have a 2GB CF card, so I installed a server install of Ubuntu. Then I got xserver-xorg, mplayer, and fluxbox. I downloaded and installed the latest nvidia driver.

Mplayer spit out tons of sound errors and that's when I realized the server install has no sound. So I installed the 'alsa', 'pulseaudio' and 'pavucontrol' packages. Now mplayer does not complain and acts like it is playing sound, but nothing happens sound-wise. Pavucontrol shows mplayer as playing sound and the volume as unmuted. However the PCM output is going to "dummy output" and the configuration tab says there are no cards to be configured. So I think my sound card is not being detected. I don't know what to do at this point. Can someone point me in the right direction?

lspci shows "Multimedia audio controler: ATI Technologies inc. IXP SB400 AC'97 Audio Controller (rev 80)"

alsamixer fails on "function snd_ctl_open failed for default: No such file or directory"

lsmod | grep 97 returns a bunch of stuff, but I'm not sure what it is.

April 10th, 2010, 03:59 AM
hardy or karmic?

What is the output of this command:

sudo fuser -v /dev/dsp* /dev/snd/* /dev/seq*

April 10th, 2010, 04:03 PM
chaz@argus:~/Videos$ sudo fuser -v /dev/dsp* /dev/snd/* /dev/seq*
/dev/snd/controlC0: chaz 1494 F.... pulseaudio

I thought the problem was my server install, so I gave up and used a spare hard drive to install a FULL ubuntu install. My sound, STILL DOES NOT WORK. It pretends that it is working. Really it does. But nothing comes out. I'm so fed up with this. I ran through the entire Ubuntu sound troubleshooting doc this morning and did all the normal stuff, and it still doesn't work. It acts like it's working, but it's not. I triple checked my sound hardware by plugging my mp3 player in instead of the computer, and it plays fine from the mp3 jack, just not my computer's jack. And the thing is, my other computer, with a different motherboard, acts exactly like this a lot of the time, although the sound has randomly worked before on that system. But most of the time, volumes are all up, applications all act like they are playing, and nothing.

Seriously, I have been using linux for like 2 years; I remember sound working....even with this hardware! What happened? I literally don't know what to do next except chuck the whole system in the trash. The whole point was to have it play video.

April 11th, 2010, 03:18 AM
I'm going to assume you're on karmic:

sudo apt-get update
sudo apt-get upgrade
sudo update-grub


April 11th, 2010, 05:23 PM
Actually, my friend gave me an ancient Creative sound card that just worked after reboot. I have no idea why the onboard sound doesn't work, even though it worked with linux a couple years ago.

April 11th, 2010, 11:08 PM
Don't look a gift horse in the mouth. ;-)