PDA

View Full Version : [ubuntu] updating nvidia driver



ankit singh
April 9th, 2010, 04:24 PM
i have ubuntu 9.10 and have nvidia 185.x.x driver and i want upgrade it to 195.x.x.
earlier experiments with this lead me to a crash system. i have a bad experience of watching video in karmic. Video gets torn in middle (like a photograph torn in middle and than joined using tapes. Here instead of tapes a thin black line appears). I am not sure know whether this problem is driver based or because of something else but i want to see if upgrading driver helps.

diesch
April 9th, 2010, 08:59 PM
On https://launchpad.net/~nvidia-vdpau there's a PPA containing up to date packages for nVidia graphic drivers.

Note that this packages are not supported by the Ubuntu team may cause problems, especially when updating to a new release.

For me they are working fine so far.

lidex
April 10th, 2010, 04:01 AM
i have ubuntu 9.10 and have nvidia 185.x.x driver and i want upgrade it to 195.x.x.
earlier experiments with this lead me to a crash system. i have a bad experience of watching video in karmic. Video gets torn in middle (like a photograph torn in middle and than joined using tapes. Here instead of tapes a thin black line appears). I am not sure know whether this problem is driver based or because of something else but i want to see if upgrading driver helps.

If you're using compiz, disable visual effects during video playback.
What is the output of this command:

lspci -nn | grep VGA

ankit singh
April 10th, 2010, 06:31 AM
If you're using compiz, disable visual effects during video playback.
What is the output of this command:

lspci -nn | grep VGA


00:10.0 VGA compatible controller [0300]: nVidia Corporation C73 [GeForce 7050 / nForce 610i] [10de:07e3] (rev a2)

ankit singh
April 10th, 2010, 01:47 PM
:( updating driver has again not solved this problem neither disabling video effect in compiz helps. anybody here knows why this happens :confused:

diesch
April 10th, 2010, 11:53 PM
What program do you use the play the video?

lidex
April 11th, 2010, 02:47 AM
Is your driver showing as enabled in "hardware drivers"? Do you have "nvidia-settings" installed? Have you tried running:

sudo nvidia-xconfig to generate xorg.conf?

ankit singh
April 11th, 2010, 07:02 AM
i have generated new xorg.conf . I have used vlc,xbmc,totem all of them have same problem.

lidex
April 11th, 2010, 08:49 AM
Did you reboot after xorg.conf reconfigure? Go to nvidia-settings="System>Administration>Nvidia XServer Settings" and navigate to "X Server XVideo Settings". Enable "Sync to VBlank"

ankit singh
April 11th, 2010, 05:23 PM
yes i rebooted my pc. i am giving up. I am planning to move to 9.04 comming weekend