View Full Version : [SOLVED] SSH Key Authorization problem

April 6th, 2010, 02:46 AM
Hello, i am very new to unbuntu or linux in general.
I just got unbuntu server edition installed on my server along with openssh-server.

Now i am trying to set ssh so i can log in with a key authentication. I am using this guide to do it through putty on my windows machine. http://support.suso.com/supki/SSH_Tutorial_for_Windows

After i installed ssh i logged in correctly. I then procceed to generate a key in putty.
Now my problem starts when i try and put that key onto my server.
The tutorial says to type in

mkdir .ssh

My server says it cannot make that directive because it is already created.
So i proceed to the next line. I believe this code sets permissions?

chmod 700 ~/.shh
nothing happens just goes to a new line

then i did this

cd .ssh

nano -w authorization_key

then i copyed and pasted the key i got from putty gen into this file pressed cntrl o and then cntrl x

when i try logging into my server using the key auth it simply asks for my login, once it is input it says authorization invalid then ask for my password.

Any feed back is much appreciated.


April 6th, 2010, 05:21 AM
How was this solved?