PDA

View Full Version : [all variants] AWStats and GeoIP



jordon
April 4th, 2010, 06:08 PM
I'm trying to install the GeoIP plugin for AWStats. I've installed the packages geoip-database, libgeoip1, and libgeo-ip-perl. geoip-database installs the database file at /usr/share/GeoIP/GeoIP.dat, so that's the path I'm using in my AWStats config file. When I try to run AWStats on my logs, it hangs without generating any files. No debug messages about this are printed when I enable them. I've also tried installing libgeo-ipfree-perl and uncommenting the geoipfree line in my conf file, but that didn't work either.

Possibly useful detail: I previously tried installing the GeoIP C library and Perl module manually, which didn't work, and then I tried installing the Pure Perl module manually, which also didn't work. I simply deleted them all, which I'm not sure was a good idea. I don't know anything about this stuff.

Wingthor
April 9th, 2010, 09:18 PM
Try this tutorial http://www.antezeta.com/awstats/geoip.html#geolin. I am not sure what kind of system you have got, but this is for both windows and linux. You also need to install PERL.

Regards

jordon
April 9th, 2010, 10:59 PM
Those were the directions I used for the manual installations that didn't work.