View Full Version : No wifi or ethernet on HP Mini 1030nr

April 2nd, 2010, 06:11 AM
I just installed UNR from a usb drive on my hp mini 1030nr. I followed a guide and got the drivers installed from the drive, but they would not activate in the restricted hardware dialog. I tried to run update over wired, but I couldn't get ethernet working. ifconfig -a anly shows lo, eth0 doesn't seem to exist. Could anyone tell me how to get wifi working?

April 2nd, 2010, 05:02 PM
Please post results of sudo lshw -C network

April 3rd, 2010, 12:27 AM
lshw -C network:

*-network UNCLAIMED
description: Network controller
product: BCM4312 802.11b/g
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: 01
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: latency=0
resources: memory:feafc000-feafffff

April 4th, 2010, 10:05 PM
I just installed remix on my mother's hp mini and Ubuntu doesn't even detect the hardware for wifi to be enabled :(

April 4th, 2010, 10:57 PM
Well, it's not showing a driver for the wireless - and doesn't even see the ethernet. I'll see if there are some similar threads that might help.

This (http://ubuntuforums.org/showthread.php?t=1347680) one claims success...
Another (http://ubuntuforums.org/showthread.php?p=9056823) that might help.
Yet another (http://ubuntuforums.org/showthread.php?t=1368699)...

April 10th, 2010, 06:48 AM
I get the same thing as well for my Broadcom BCM4322. The network is "unclaimed" and the ethernet doesn't appear in the list.

April 10th, 2010, 02:58 PM
I should add that I tried the solutions linked to by Iowan without success.

April 14th, 2010, 08:52 PM
I give up on Ubuntu. I simply cannot get Ubuntu to recognize my ethernet card no matter what I try, and the wifi will not work, no way no how.

I'm going back to Windows 7.

April 14th, 2010, 11:11 PM
Ubuntu isn't for everyone - good luck with Windows 7.

April 18th, 2011, 02:41 AM
I found a solution

download the windows atheros driver from softopia

sudo apt-get install ndisgtk

extract the windows atheros driver to a folder

start up ndisgtk and point it to the atheros driver inf. I used the one in the 8131 folder under win2k.

Once it is done installing restart the computer and create a network connection and you are good to go.