View Full Version : [SOLVED] Problem installing updates

April 1st, 2010, 09:42 PM
I'm new to Ubuntu. After I got the OS up and running (v9.10), I was prompted to download and install some updates. The download is complete, but when I try to install the updates, I receive the following message. What should I do?

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

April 1st, 2010, 09:48 PM
well it says to run

sudo dpkg --configure -a

maybe try that in terminal, but wait for someone else to confirm first. :)

April 1st, 2010, 09:58 PM
OR go into system/administration synaptic package manager then edit/fix broken packages

April 1st, 2010, 10:33 PM
Thanks. I tried the sudo dpkg command in the terminal, but kept getting more errors. But then I tried updating in the package manager. Doing that seems to have cleared up all of my problems. Thanks!

April 1st, 2010, 11:56 PM
Glad to help. And welcome to the forums.