View Full Version : Update Manager Problem

March 31st, 2010, 06:25 AM
I'm fairly new to ubuntu, but all of a sudden my update manager is no longer working. I'm running ubuntu 9.04 and was happy because I finally got the screen resolution to be a good size, but now I can't update anything or even upgrade ubuntu.
The message I get is

Could Not Initialize Package Information

An unresolvable problem occured while initializing the package information.

Please report this bug against the 'update-manager' package and include the following error message:

'E:Unable to parse package file /var/lib/dpkg/status (1), E:The package lists or status file could not be parsed or opened.'I've also had issues with installing new programs (specifically tried Boxee (64bit ver) and Last.fm Scrobbler), but was thinking these issues might be related to the updage-manager error.

Thanks for any help.

March 31st, 2010, 07:23 AM

I am totally new to Linux and sorry to post my question in this thread accidentally.

I can't log in Ubuntu (gnome session) whenever the resolution was changed to a lower one (e.g., 1280x1024), even though I can log in Ubuntu by logging into a command line mode (recovery mode) and typing 'startx'.

Any suggestion?

Thank you,

p.s., I am using old PC and small screen.

April 1st, 2010, 07:08 AM
Bump :?

May 4th, 2010, 10:21 PM
Not sure if you still need help, but I just ran into this and here is how I fixed it:

# Move into the directory
cd /var/lib/dpkg/
# Rename the old version to a backup copy
sudo mv status status.bak
# Create a new empty file (otherwise apt-get will complain)
sudo touch status
# Update...
sudo apt-get update

May 5th, 2010, 03:48 PM
I take it back...that fix only got me part way there...

The real problem was that my /var/lib/dpkg/status file had 1 bad character in it.

gksu gedit /var/lib/dpkg/status revealed this line had a bad character in it. In front of the word "Conflicts" is a bad character...it should be a new line.

Depends: libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libjpeg62, libstdc++6 (>= 4.1.1), libdjvulibre-text (>= 3.5.22-1ubuntu2)Conflicts: libdjvulibre1

It should be:

Depends: libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libjpeg62, libstdc++6 (>= 4.1.1), libdjvulibre-text (>= 3.5.22-1ubuntu2)
Conflicts: libdjvulibre1

Editing that line in Gedit fixed everything and I can run apt-get fine now.