View Full Version : [ubuntu] Test of 10.4 beta upgrade

March 30th, 2010, 10:44 PM

As there's still no way to report problems with the update process, as far as I can determine, and the assumption still seems to be that every user experiencing a bug will be able to report using an exact knowledge of what happened, I'll once again post about my update problems here, just in case anyone would be interested:

Experiencing a few problems with 9.10 I came looking when 10.4 was due. (Apparently I can't get it into my head that a release named after a month will not appear at the start of that month.) As there was a request on the website to try the beta, I did so. (Monday, 30 March 2010) These are some of the noteworthy things I experienced:

- I was told a number of software channels (Softwarekanalen) were switched off, and to use Synaptic to restore them afterwards. It's not just that an upgrade should be able to pass on such information and do the restoring itself, but it didn't give me any reason why they were removed, nor a list for restoring them.

- Curiously, there was some low rumbling sound going on during this part of the process. (I didn't realise it was audio until I switched off the monitorto let it continue unsupervised during the night. As it happens the process halted shortly afterwards.)

- Support was reported ended (no reason given) for a list of items. For most of these I have no idea what they do, and therefore no idea whether I would lose something if I continued. There's also no indication about what to do about it if I do lose functionality, beyond the message that some of the items might get community support, but I won't know which.

- As "ure" is installed, whatever it is, I'm told that the component registries may be corrupted etc., and if it will cause problems with openoffice.org etc., to do something that I then won't recall. I looked for the better safe than sorry option, to have that done immediately, but I couldn't find it.

- Either the process had run through it's entire flexibility before I noticed it waiting for interaction, today, or it simply halts on the first problem and sits doing nothing until someone notices, rather than handle unrelated parts of the upgrade.

- Something about Grub-PC offers me all sorts of locations for installing a booter, I think. What it doesn't do is tell me where the OS being upgraded currently has that functionality. No information at all is given about the current system, beyond the positional disk names. When at first I decline selecting something, I find that on the next page the back button is ghosted, meaning I can't correct the situation. In fact, I can go back, as not allowing it explicitly to go on will cause the next button to behave as a back button. The ghosted back button apparently is only there to scare the user when he doesn't know what to do anyway. Having called up the help, which also doesn't tell me how to find out what the current configuration is, I suddenly get the help text attached to the cursor whenever I enter the installer window. While obscuring half the window with the help text I make an educated selection.

- I notice that the progress window has now automatically extended to include a terminal window. It hasn't, however, re-centred itself; rather, it shows the actual new info beyond the bottom of the screen. This part is left to manual.

- Superfluous packets are then listed for removal. Nothing to tell me how or why they became superfluous. The entries of the list, however, in a fair number of cases include the note that the entries have been installed automatically. As far as I can see, the same holds for all the entries that do not carry that note.

- Starting this removal, I'm told that it may take one and a half hours, or something similar. Once started, the estimate is six minutes. Under way it quickly drops to 1 minute, but in actuality it's closer to 10.

- After all that, I'm warned to store any open documents, as if I've not been told earlier to close all running applications.

- The computer is restarted. No-one apparently told the USB-drive, which seems to start a desperate search for someone to talk to.

- That's the only activity. Either the educated selection was wrong, or the process still includes a bug that shows in my case. Switching off the disk, restarting, nothing made the system go. Eventually I went the same way as always: I installed from the latest CD I had, in this case back to Koala. That's the same method I eventually used to upgrade from Warthog to Hedgehog, and for every upgrade I tried since then.

The more things change, the more they stay the same.