PDA

View Full Version : [SOLVED] how to create boot choice xp & ubuntu



{RaW}ShrapNull
March 25th, 2010, 12:46 PM
I tried searching forums before posting, but it was hard to search due to the specific nature of what I want to do.

I have one hard drive with windows XP on it. Another with Ubuntu. As it stands there is no link between them. Is it possible to create a dual boot using these disks? - I do not want to reinstall any of them.
Preferably, I would like the boot choice (or booter? - not really sure what I'm talking about) to be on the newer Ubuntu drive.

It is on an old machine with 256MB Ram. So slow in fact, I'm going to change the desktop environment to Xubuntu - but that's mostly irrelevant.

As I understand it, I should make the Ubuntu drive master, XP as slave... but then what?

Thanks in advance,
\m/ shrap

byStanderone
March 25th, 2010, 01:52 PM
...is the xp on the first drive that you mentioned functional...and what flavor of ubuntu it is on the other drive?

{RaW}ShrapNull
March 25th, 2010, 02:55 PM
The XP is fully functional & boots normally, as does ubuntu.
The ubuntu version is the latest (koala I think) 386.

Thanks for swift reply

Mark Phelps
March 25th, 2010, 04:14 PM
OK, then all you should have to do is the following:
1) Boot from the Ubuntu drive
2) Once into Karmic, open a terminal and enter "sudo update-grub"

That should return entries in the terminal window for each kernel and OS it finds.

IF it works properly, it will generate a new GRUB menu, one that contains an entry for XP.

Once you reboot, you should be presented with a GRUB menu containing entries for all your Linux kernels and for XP.

{RaW}ShrapNull
March 25th, 2010, 04:32 PM
Thanks a million!! Much appreciated. Trying to wean my in-laws away from XP to ubuntu while giving them a safety net!

This community is great.

Thanks again
Shrap \m/

{RaW}ShrapNull
April 25th, 2010, 10:18 AM
Just an extra on this. I did what was recommended above, however when I tried to boot into windows I got an "error: invalid signature".

To fix this, in the terminal I typed: sudo grub-mkdevicemap
THEN typed: sudo update-grub

Just in case anyone runs into this error, this might help.

Thanks again all