View Full Version : [gnome] just background image when logged in after update

March 19th, 2010, 05:25 PM
as the title says let update manager do its stuff to 9.10 yesterday and now i doint get anything other than the background image after logging in with my user and pw. well, not strictly true as firefox still opens with 'ubuntu one' signin' screen - you cant move the window though - its like theres no gnome??

would like to try to boot an older kernel versio but i never could get the new grub to work when i installed so i use an old grub bootloader from mepis 8 which is also on the system

any suggestions to get my desktop back - could really do without a fresh install right now!!

cheers in advance


March 19th, 2010, 07:21 PM
no one? anyone??

March 19th, 2010, 10:11 PM
ive just got the same problem ..

March 20th, 2010, 12:12 AM
sorry to hear that but im glad im not alone in this- tried looking through the previous posts but nothing as of yet other than possible ownership premission issues of the home folders but im unsure how to look for the permissions via a terminal (i can log in using the xterm option)

heres hoping to a solution



March 20th, 2010, 12:26 AM
did u try changing the session on the login screen...? I had this 5 days back and it was apparently because the session was going to default and when I selected Gnome it started working fine.

HTH !!!

March 20th, 2010, 12:55 AM
ill give it a go tomorrow when im at the computer in question - thanks

March 20th, 2010, 08:06 AM
Yep me too.. looks like the window decoration had failed. Pressed Alt+T to fire up the terminal and then launch applications from there. The applications launch without title bar and the controversial windows buttons :)

Brandel Valico
March 20th, 2010, 08:10 AM
May have something to do with this issue


If this seems to fit your issue

Try this its a workaround provided by Nightwishfan

Workaround for a usable desktop:
Log in and press ctrl+alt+t to get a terminal, type:

Press alt+f2 and type:

Desktop should be usable, do not close terminal. You may also be able to press alt+f2 again and run:

killall gnome-terminal && gnome-terminal
See how it works for you.

March 20th, 2010, 11:31 AM
had the same problem got the terminal by ctl+alt+t and then gnome-panel then also tried by sudo apt-get update && sudo apt-get upgrade. A new fix seems to be up and it fixes this

March 20th, 2010, 05:32 PM
had the same problem got the terminal by ctl+alt+t and then gnome-panel then also tried by sudo apt-get update && sudo apt-get upgrade. A new fix seems to be up and it fixes this

no upgrade available here

plus ctrl alt t doesnt work = have to log in using xterm

March 21st, 2010, 11:46 PM
did you try changing the session from default to Gnome at the login screen? :-s

I tried it again just now and if I select default the desktop environment is just not there and when I select KDE or Gnome I get the correct setup...

March 22nd, 2010, 11:34 AM
dont have a default option as im only running gnome so no (kde style) default just gnome and xterm

i just need the relevant updates to make it my way - having no joy so far gnome-panel and nautlus are still versions 1.2.28 rather than 1.2.29 - which versions do you have and what mirrors / repositories are you using



March 22nd, 2010, 04:27 PM
I will let you know once am back home....I am sorry I can't be of more help...:(

March 23rd, 2010, 10:22 PM
gnome is 2.28 ang nuatilus is 2.28.1...hope this helps...