View Full Version : [SOLVED] Wifi usb adapter wont work under 64bit

March 6th, 2010, 11:01 PM
I need some help getting my Rosewill RNX-N1 usb wifi adapter to work in ubuntu.. what can i do, please help. I really wanna get started with unbuntu but with no internet is a bit hard. Thanks a lot for your help.

March 7th, 2010, 03:51 AM
guys come on, a little help here, i'be searched online and got the latest rt2870 drivers, i cant get anything to run decently. I need your help, i have at hand the above mentioned USB adapter and a D-link DWA-140. Any help would really save me some head aches. Thanks a lot.

March 7th, 2010, 07:14 AM
You might be aware that Rosewill is Newegg's house brand for devices manufactured by other companies. To find out what your wireless adapter really is, run this command in Accesories/Terminal:

According to this web page:
https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsDlink #USB

the D-Link adapter should "just work." The driver is built-in with Linux.

That means, when you boot up with the D-Link installed, you can right-click on the networking icon near the top-right of your screen, next to the volume control. Select Edit Connections. Select the Wireless tab and the Add button, provide the SSID of your router, the encryption type and password, and it should connect.

March 7th, 2010, 10:54 PM
Well i went ahead and tried with the Dlink being that its supposed to be more compatible or "work" with 9.10. The network manager does recognize the WLAN but it just didn't recognized any networks, i had to install the drivers for the RT2870 chipset which is what the D link 140 uses, this (http://www.apfelkraut.org/2009/02/howto-wlan-ralink-rt2870-usb-stick-kubuntu-810/)was what got me through, then reboot and everything worked. I really appreciate your reply.

March 12th, 2010, 04:08 AM
1.) First thing is to prepare the system for the driver compilation. Therefore it is needed to install certain tools and the headers of the running kernel:

* sudo apt-get install build-essential linux-headers-`uname -r`

2.) Now the source for the Linux driver needs to be downloaded from the Linux support page of Ralink Technology.

* Download this package (alternative mirror):
wget http://www.ralinktech.com/license_us.php?n=2&p=0&t=U0wyRnpjMlYwY3k4eU1EQTVMekV5THpFMUwyUnZkMjVzYjJG a05UYzBNVFExTkRNNU5TNWllakk5UFQxU1ZESTROekJmVEdsdW RYaFRWRUZmVmpJdU15NHdMakF1ZEdGeUxuUmhjZz09Qw%3D%3D (http://www.ralinktech.com/license_us.php?n=2&p=0&t=U0wyRnpjMlYwY3k4eU1EQTVMekV5THpFMUwyUnZkMjVzYjJG a05UYzBNVFExTkRNNU5TNWllakk5UFQxU1ZESTROekJmVEdsdW RYaFRWRUZmVmpJdU15NHdMakF1ZEdGeUxuUmhjZz09Qw%3D%3D )
* Extract it somewhere:
tar xvfj RT2870_LinuxSTA_V2.3.0.0.tar.tar.bz2

3.) Now the support of wpa_supplicant should be enabled in the file os/linux/config.mk of the driver package.

* Open the file with your favorite text editor, for example GNU Emacs:
emacs os/linux/config.mk
* Change the following attributes from “no (=n)”:

# Support Wpa_Supplicant

# Support Native WpaSupplicant for Network Maganger

… to value “yes (=y)”:

# Support Wpa_Supplicant

# Support Native WpaSupplicant for Network Maganger

4.) Afterwards the driver needs to be build and installed. Make sure to execute both commands in the root of the driver package and with superuser privileges:

* sudo make
* sudo make install

5.) Last thing is to add this driver to /etc/modules so that it is loaded automatically every time the system is rebooted.

* Open the file with your favorite text editor, for example GNU Emacs:
emacs /etc/modules
* Add the following line:

(others reported that they had only success by adding “alias ra0 rt2870sta“)

6.) If you do not want to reboot your machine, you should execute the following two lines with superuser privileges to load the driver and to integrate it in your networking configuration:

* sudo modprobe rt2870sta
* sudo /etc/init.d/networking restart