PDA

View Full Version : [ubuntu] badly broken package



bbc4
February 25th, 2010, 04:38 AM
I recently attempted to install snort through synaptic and when I tried the package broke. Now I cannot use synaptic to update or install other packages. I have tried apt-get -f install , apt-get clean, apt-get autoremove, and apt-get -f autoremove . here is the output from attempting a force install of the package.

b@Bbox:/etc$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 26 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up snort (2.8.4.1-3ubuntu1) ...
dpkg (subprocess): unable to execute installed post-installation script: Exec format error
dpkg: error processing snort (--configure):
subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
snort
E: Sub-process /usr/bin/dpkg returned an error code (1)
b@Bbox:/etc$

any help would be very appreciated.

n0dix
February 25th, 2010, 05:25 AM
sudo dpkg --force all --remove

bbc4
February 25th, 2010, 07:25 AM
No dice. Returns the exact same error as previously stated.

booshire
February 25th, 2010, 07:35 AM
No dice. Returns the exact same error as previously stated.

how about this?

$ sudo apt-get purge snort

bbc4
February 27th, 2010, 06:35 PM
That didn't work either. Is there any other information that I can post to make this easier?