PDA

View Full Version : [ubuntu] setup nagios



dsexton18
February 24th, 2010, 07:24 PM
I have installed Nagios 3 on ubuntu 9.10 server. How ever I need help with getting the web interface to show up. Appache is installed and working. I setup a sym link between /etc/nagios3 and /var/www/ thinking if I setup a sym link that would work but it just errors out when I type http://IPaddress/nagios I assume I am missing some thing but what.

Iowan
February 24th, 2010, 11:44 PM
Dunno if this (http://www.ghacks.net/2009/06/08/how-to-install-nagios-on-ubuntu-server/) article will answer any questions?
Another (https://help.ubuntu.com/community/Nagios3) help page.

joberly
February 25th, 2010, 01:58 AM
I don't mean to state the obvious, but your post indicates you are going to http://IPaddress/nagios when in fact the correct url would be http://IPaddress/nagios3.

kernelzilla
February 25th, 2010, 06:47 AM
I'm not sure what guide is telling you to create a symbolic link between /etc/nagios3 and /var/www, but this is unnecessary. The configuration for the /nagios3 URL is installed automatically by the package (at /etc/apache2/conf.d/nagios3.conf)

dsexton18
February 25th, 2010, 03:26 PM
I can't recall what guide I was using it dident work and I did not book mark it. The resion I setup a sym link is becuse when I went to /var/www it was empty. So I though if I setup a symlink it might work. I also thought maybe when nagios was installed an alis would be added to httpd.conf You will have to forgive me I don't know much about Apache.

And I also tried http://ipaddress/nagios3

dsexton18
February 26th, 2010, 03:50 PM
Now it seams like I have a problem with a config file. /etc/apache/conf.d/nagios3.conf it's contents look like this
It appears to be a sym link to /etc/nagios3/apache2.conf

# SAMPLE CONFIG SNIPPETS FOR APACHE WEB SERVER
# Last Modified: 11-26-2005
#
# This file contains examples of entries that need
# to be incorporated into your Apache web server
# configuration file. Customize the paths, etc. as
# needed to fit your system.

ScriptAlias /nagios/cgi-bin "/usr/local/nagios/sbin"

<Directory "/usr/local/nagios/sbin">
# SSLRequireSSL
Options ExecCGI
AllowOverride None
Order allow,deny
Allow from all
# Order deny,allow
# Deny from all
# Allow from 127.0.0.1
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user
</Directory>

Alias /nagios "/usr/local/nagios/share"

<Directory "/usr/local/nagios/share">
# SSLRequireSSL
Options None
AllowOverride None
Order allow,deny
Allow from all
# Order deny,allow
# Deny from all
# Allow from 127.0.0.1
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user
</Directory>





^G Get Help ^O WriteOut ^R Read File ^Y Prev Page ^K Cut Text ^C Cur Pos
^X Exit ^J Justify ^W Where Is ^V Next Page ^U UnCut Text ^T To Spell

dsexton18
February 26th, 2010, 04:17 PM
never mind i got it working. Thanks for you help every one