View Full Version : [SOLVED] 9.10 install - Partman doesn't detect disks, but GParted does

February 21st, 2010, 06:30 PM
Using install disc burned from ubuntu-9.10-desktop-amd64.iso ; disc verified.

Could not install because installation hung during partman. Booted into LiveCD (using same disc), and GParted works, but partman does not.

I've searched Google and this Forum with no luck; but perhaps I'm just not asking correctly. Any help - even a workaround - would be appreciated. Is there a way to use something other than partman, or to mount the root, home, and swap in a way that makes partman skip it during install?

Thanks in advance.

See screenshots:

GParted sees first SATA drive as /dev/sda:

Gparted sees second SATA drive as /dev/sdb:

Partman hangs for a bit, always at 47%:

And this is the result:

February 21st, 2010, 06:35 PM
This would usually happen if the disks were used in raid and they have raid settings remains on them. Sometimes they can have them even without being run in raid.

I guess you're not running raid from the pics. If you are NOT, it's safe to run the following from the live desktop:

sudo dmraid -E -r /dev/sda
sudo dmraid -E -r /dev/sdb
sudo apt-get remove dmraid

See if that made a difference.

Note: If you are actually running raid the above commands might destroy the array!

February 21st, 2010, 06:43 PM
ubuntu@ubuntu:/etc/init.d$ sudo dmraid -E -r /dev/sda
Do you really want to erase "via" ondisk metadata on /dev/sda ? [y/n] :y
ubuntu@ubuntu:/etc/init.d$ sudo dmraid -E -r /dev/sdb
Do you really want to erase "via" ondisk metadata on /dev/sdb ? [y/n] :y
ubuntu@ubuntu:/etc/init.d$ sudo apt-get remove dmraid
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 180kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 118835 files and directories currently installed.)
Removing dmraid ...
update-initramfs is disabled since running on read-only media
Processing triggers for man-db ...
Success! I had forgot that these discs used to be in a RAID array on my old machine. Thanks! Now how do I mark this thread as [SOLVED]? :)