View Full Version : [SOLVED] removed win7

February 21st, 2010, 03:18 PM
I have removed the trial of win 7 and want to use the empty space for Ubuntu 9.10, [46gb].
Opening disk utility shows 60gb hard drive, divided into system reserved 105mb, 46gb file system [Linux ext4 [version 1]], 13gb extended [contains no logical partitions], 13 gb [Linux ext4 [version 1]], 617mb swap space.
Because I have given the 46gb space the same name as the 13gp space i.e. [Linux ext4 [version 1]],will this now be used By Ubuntu for data storage or do I need to do a complete re-install?
Any comments/ advice welcome.

February 21st, 2010, 09:37 PM
For data storage - do you mean to store files and whatnot on it, or for SWAP space?

February 21st, 2010, 10:29 PM
You do not need to reinstall, just create a mount point, give it permissions and mount it. If you want to permanently mount it you can add the mount to fstab. You can mount it anywhere and use it or mount it somewhat hidden and use links to see the data folders in /home.

Share data partition
see ridgeland's post in ubuntu forums

Understanding fstab
Ownership and permissions of vfat / ntfs are set at the time of mounting. This is often a source of confusion.


NOTE: The mount point can be anywhere. If it's in your /home or /media folders it will show up under "Places". If it's directly off "/" or /mnt it will not.

$ sudo mkdir /Data
$ sudo mount /dev/sda5 /Data
where sda5 needs to be your drive, partition for the Data

if not known to list partitions
sudo fdisk -l

If you cannot read and write then change the permissions.
$ sudo chmod -R 777 /Data
sudo chown -R fred:fred /Data
where fred should be your login name

But it is a lot easier to use a graphical front end that both creates the mount point and edits fstab.
Try installing pysdm from the repos.
PySDM is a PyGTK Storage Device Manager

February 23rd, 2010, 02:52 PM
Sorry storage only, i.e. free space

February 23rd, 2010, 03:06 PM
I think it must be already sorted, when I open disk utilty there are two [as stated] Linux ext 4 [version 1] filesystems shwn.
Took your advice and loaded storage device manager this shows four partions only where as disk utilty shows [system reserved 105mb, 46gb file system [Linux ext4 [version 1]], 13gb extended [contains no logical partitions], 13 gb [Linux ext4 [version 1]], 617mb swap space.] shows five two of which have the same name so I take this to mean that both ext 4 are treated the same and just shown split?

February 23rd, 2010, 06:04 PM
If it is two partitions they are not the same but split unless you are running some special software that combines them. You just have to mount the data partition to be able to use it.

February 25th, 2010, 03:36 PM
Many thanks to you all it solved itself, the whole screen was black yesterday morning and needed a reinstall.