PDA

View Full Version : [ubuntu] Need to "do nothing" when laptop lid is closed



gigi1234
February 13th, 2010, 05:41 PM
Hi! I am running 9.10 on a Dell XPS m1330 laptop. I would like to find a way to have the computer "do nothing" when the laptop lid is closed. I close the lid frequently when moving around my house and don't want to computer to suspend or hibernate. Currently there is no menu option for this but maybe there is a file I could alter in the terminal?

Thanks!

m_duck
February 13th, 2010, 05:47 PM
If memory serves, if you right click the battery icon in the system tray and go to preferences, there is a tab relating to when the computer is on battery power, and in there is a drop down with different actions to take when the lid is closed, one of them being "no action".

x33a
February 13th, 2010, 05:47 PM
Well one way is to disable gnome-power-manager if you don't need its features.

switch10
February 13th, 2010, 06:25 PM
Go to System>Preferences>Power Management. It will say "when laptop screen is closed" and then there will be a drop down list. choose do nothing. On both AC power and Battery power tabs.

scared0o0rabbit
February 13th, 2010, 06:45 PM
Or you could always do what I accidentally did, break the sensor that tells the laptop it's screen is closed lol.

SOULRiDER
February 13th, 2010, 07:42 PM
Go to System>Preferences>Power Management. It will say "when laptop screen is closed" and then there will be a drop down list. choose do nothing. On both AC power and Battery power tabs.

That's what I do. However, making it turn off the monitor will help you save some battery.

HermanAB
February 13th, 2010, 09:20 PM
OK, but bear in mind that when you close the lid, the laptop will get very hot, so you may have to do something anyway, like spin down the hard disk, shut down the screen and so on.

dwhitney67
February 14th, 2010, 02:14 PM
OK, but bear in mind that when you close the lid, the laptop will get very hot, so you may have to do something anyway, like spin down the hard disk, shut down the screen and so on.

It is not uncommon to operate a laptop with the lid closed when using an external monitor. The heat issue you wrote of so far has not impacted my systems, both at home and at work.

Reathziel
February 21st, 2010, 01:19 AM
You can solve that typing gconf-editor in your terminal then go to
/apps/gnome-power-manager/buttons/lid_ac and set the value to "nothing" (without "")
It should work ;)

shimmo
April 9th, 2010, 12:28 PM
Sounded good ... looked promising in gconf-editor BUT does not work either.

vbmds
April 12th, 2010, 02:44 AM
I also use my laptops with an external monitor so this function is important for me also. I tried Reathziel recommended solution and it worked perfectly for me.

Now I can stash the laptop under my desk - I also use an external mouse and keyboard, so until the power button is next required, I don't need access to the the laptop now.

spillin_dylan
April 12th, 2010, 03:38 AM
Right click a Gnome Panel.

Add To Panel -> Inhibit Applet

One-click on/off solution to prevent suspend/hibernate/anything.


That's what I use, and it seems to work pretty good. I usually just have it on the inhibit power save mode all the time anyway.

alican timur
July 4th, 2010, 03:53 PM
it does for me.. are you sure you're "doin it rite"?

jonguitud
April 13th, 2012, 06:30 AM
You just need to open a terminal and type:


gsettings set org.gnome.settings-daemon.plugins.power lid-close-battery-action blank
and...


gsettings set org.gnome.settings-daemon.plugins.power lid-close-ac-action blankbe careful not to type "sudo" nor to login as "root".

See ya!

oldos2er
April 13th, 2012, 04:28 PM
Closed. Please don't bump old threads.