View Full Version : [all variants] Can't select multiple files for uploading

February 13th, 2010, 06:48 AM
I was helping someone today and needed to upload 15 pictures to post on a forum.
I pushed the browse button and selected the first picture, but I was unable to select all of the pictures.
This happened again on an email attempt to do the same thing.

In the gnome environment, I am able to select the first then hold down shift, and select the last pic and all the ones in between will be selected.
I expected this behavior when selecting for upload, but it didn't happen.
I had to select each one, one at a time and upload each one.

I tried making a folder to upload the whole folder and that would not select at all.

Am I doing something wrong? or is this just not often needed?

thanks for any help,


February 13th, 2010, 10:00 AM
That may depend upon the forum software, browser side scripting used for the forum, and forum policies. Simple file upload without browser scripting might just be one file at a time. Or some forums may not even allow uploading images, but just links to images elsewhere.

You did not say if it was a forum here or some other site. So it may have nothing to do with the OS or browser.

February 14th, 2010, 01:10 AM
I will try it here.
It was gmail and another forum.

I just went through the paces here, and the file management for uploading here will let me browse and choose still only one at a time, but they can all be uploaded at once when I am finished. So, this makes it easy here.

Aside from that,
My multiple selection capability seems not to work with an upload.
It appears to be the same, where the home folder is seen and I can dig down into folders in the same way, but I can only select one at a time.

I can handle it.
Maybe I am used to a script that goes along with a mac, and I never realized it.

thanks for your reply and help,


March 15th, 2010, 09:22 AM
I would like to continue this thread, and report the same issue on attempting to upload files in Gmail, Google Docs, etc. under Firefox in Linux Mint OS. Holding down Shift or Control has no effect, and it is possible to upload only one file at a time.

September 10th, 2010, 07:29 PM
I have the same issue. I believe it to be an issue on the OS side, as Firefox and Windows produced excellent results, whereby i can just ctrl+click multiple files and upload them in a single selection.

though, i could possibly be mistaken as i don't have much experience regarding web scripting etc...

update: i tried it on mediafire.

March 20th, 2011, 01:54 AM
I would just like to say this problem is ridiculous. I also can't upload multiple files at the same time. I'm frustrated right now, but I did install one program called Nautilus Facebook Uploader (http://gnome-look.org/content/show.php/Nautilus+Facebook+Uploader?content=136513)
I'm still an amateur when it comes to Ubuntu, but I am just going to copy all of my files to a usb and move them to my windows partition.
Sorry I can't help, but would like to offer my condolences to you because I'm plagued by the same problem.

May 15th, 2011, 08:36 PM
Any update on this? It is actually impossible to choose multiple attachments at once when using Gmail. If I am not mistaken, there should be an easy fix for this somewhere in the gconf-editor settings. Ubuntu 10.10.

May 15th, 2011, 08:51 PM
Edit to the previous post: A working workaround is to setup Gmail in Evolution, which allows attaching multiple files at the same time.

And I edit again: It is actually possible to upload multiple files to Google Docs from Ubuntu. This makes me think that this is actually a Gmail bug.

Edit: https://mail.google.com/support/bin/answer.py?hl=en&answer=99915

"Please note that this feature is not supported on Linux."

Very strange, since Gdocs manages this.

June 9th, 2011, 01:16 PM
I'm having the same problem, thank you for any help!!
working with 11.04 64B