PDA

View Full Version : [SOLVED] PICO820 9.10 Installation Problems



tonyl1956
February 11th, 2010, 02:58 PM
Hi,

My first post, though I've been a lurker and a user for some time.

I'm trying to install 9.10 on a PICO820, a small Atom-based board from Axiomtek, for a work project. 9.10 runs well from a USB stick made using unetbootin, so I anticipated it would install to a hard drive without too many issues. However, I don't seem to be getting anywhere fast. The HDD is a new 3.5" SATA cheapie of 250GB capacity.

I'm trying to install by from the desktop icon.

The first issues I had were when using the auto partition/format option at step 4. After completing the other screens, the machine started the process but halted at 5% of the partitioning phase. Repeated attempts lead always to the same result. I cleared the partly finished partitions using gparted, either on the machine itself or attached to a desktop also running 9.10. Sometimes, the failure to partition was accompanied by screen effects - flashing and blurring.

To get around the partition issues, I partitioned the disk manually attached to the desktop machine - 1 extended partition containing 3 logical partitions (swap, Ext3 root, Ext3 home). Interestingly, attempts to partition the disk from the PICO failed. Successful partitioning attached to the desktop has now allowed install to commence and it reaches 28% before freezing on the display.

I'm at a bit of a loss as to know what to do next. I've checked the MD5 checksum of the .iso file and redone the unetbootin stage. I've also run the smart tools check of the HDD.

If anyone has any ideas, I'd be very grateful.

Tony

mrgs
February 12th, 2010, 02:24 PM
You could try installing 9.04 for a comparison:

http://releases.ubuntu.com/9.04/

tonyl1956
February 15th, 2010, 01:54 PM
Thanks.

I might well try that today. I believe the application we want to run on it will work with 9.04 and maybe, with more tweaks, on 8.xx

I have now tried the alternate iso for 9.10 and that wouldn't install either. I found that it really doesn't like a system without a CD unless you connect to the internet, so I tried that but it still froze part way through the process.

The thing I'm going to check first, though, is whether the BIOS has recognised the HDD correctly, as it seems always to fail at points where it's trying to do disk-related activities.

Tony

tonyl1956
February 16th, 2010, 12:26 PM
Humble Pie time!

I tried 9.04, as suggested and the installation stopped at almost exactly the same point.

However, just before it stopped, i noticed the current draw on the 5v line rise - we've got it connected to a bench top power supply at this stage. Tried a different power supply with a higher current limit and the whole installation process went through without a problem.

I've no doubt 9.10 will install as well.


The lesson is that these lower power boards only consume low power themselves. Peripherals take what they take!

Tony

mrgs
February 16th, 2010, 07:33 PM
Thanks for sharing. I didn't know that.

dasankir
June 10th, 2010, 04:25 PM
Have you managed to properly install the gma 500 drivers??

I've tryed many ways including the ppa and lucozade's script without success.
(see thread: http://www.google.es/url?sa=t&source=web&cd=1&ved=0CBoQFjAA&url=http%3A%2F%2Fubuntuforums.org%2Fshowthread.php %3Ft%3D1229345&ei=IwMRTLfCCMiv4QbZx4HNBw&usg=AFQjCNHw19MbTFAizg0HSJiHbfX2Hr-Vaw)

It runs in low graphic mode or by defaulr in vesa mode, wich reduces the performance a lot.