View Full Version : [ubuntu] 8.04LTS networking (and compiling) problems

February 11th, 2010, 12:14 PM
I've installed Ubuntu 8.04 LTS on a new machine which is to be used for running a set of dedicated spreadsheets at a club.


1) It won't see the network and so it can't see the 'net. When I run the 9.10 live CD it finds the wired network and uses it, the 8.04 live CD doesn't. Actually the 8.04 live CD does see the network on this machine. Odd

Actually it's going to have to network wirelessly so I plugged in a Ralink USB wireless dongle instead when I installed but that didn't connect. It comes with drivers in a tarball on CD but they need to be compiled. Which brings us to

2) gcc seems to be present but deeply crippled, /usr/include has not much in it, not even stdio.h, so I can't compile; I tried a small prog which is needed for the eventual setup and just got a cascade of errors, at a glance mostly lack of header files. So I can't compile the drivers for the wireless dongle and I can't connect to the web to get the header files (and there doesn't seem to be an obvious package that would provide them).

Further complication is that I am clueless about setting up wireless networking so advice on that would be welcome too.

I'd like to use Ubuntu, Windows users might have heard of it, but I do want to use an LTS version, 6 monthly upgrades on a machine at a remote site I can get into at weekends only - Yuk - plus, perhaps more importantly 9.10 uses Openoffice 3 which is appallingly slow compared to 2. Fallback is Debian Lenny.

February 11th, 2010, 11:46 PM
You may need to install the build-essential pfackage.