PDA

View Full Version : [SOLVED] Free Outside vulnerability scan that works with Ubuntu Server



bakegoodz
February 11th, 2010, 06:22 AM
Is there a free online vulnerability scanner where either I can give them the IP address to scan or can be initiated from the console command, tool, or text based browser. I use GRC's Shields Up when I have a GUI, but I want a scan ran on my website that runs Ubuntu 8.04 server on a hosted VPS.

Thanks

cariboo
February 11th, 2010, 07:04 AM
IF you don't have any friends that run a Linux variant, you can download a Windows version of nmap here (http://nmap.org/download.html), and have them run a scan against your server.

unspawn
February 11th, 2010, 10:58 AM
There's port scanner at http://www.derkeiler.com/Service/PortScan/, an advanced firewall test at http://www.auditmypc.com/firewall-test.asp, an advanced port scanner at http://www.pcflank.com/scanner1.htm and a basic security audit at http://www.securityspace.com/smysecure/basic_index.html, all free to use but some are better configurable compared to others. Also note the latter does handle http://www.securityspace.com/smysecure/last30.html (CVEs I mean) which the others don't. Then there's a Nmap scan at http://nmap-online.com/, a Nessus scan at http://www.port-scan.de/lynx/nessus.php and for more see http://www.alken.nl/online-security-check.htm.

HTH

Sarmacid
February 11th, 2010, 02:07 PM
If you want to do this yourself, I'd suggest downloading Nessus and setting it up to scan your server. Not only does it tell you what ports are open, like nmap, but it tests those ports for known vulnerabilities.

mkvnmtr
February 11th, 2010, 02:40 PM
Doing it yourself is the answer. It will take about an hour to download Nmap and zenmap and run the scans. With the zenmap front end it is easy and you can do it from anywhere. Then a s you learn more you will find other apps to supliment your checking. Most are in the repositories. Trudting some site on the internet to scan your system does not seem like a good idea to me.

bakegoodz
February 11th, 2010, 09:04 PM
Thanks unspawn, I tried all the links. Securityspace and Alken would not work with Elinks, but the rest worked fine.