View Full Version : [ubuntu] Cairo Dock Acting Funny.

February 10th, 2010, 05:43 PM
Hi Everyone,
This is the second time I have been trying to use Cairo-Dock in 9.10. I had a beautiful little version installed in 9.04. It didn't have many options but it looked just right. I like when it auto-hides, and then when i need to look at something it pops up over whatever is on my screen. I just installed the Cairo-Dock with openGL, and it is doing something weird.

When it is open on the screen it pushes the open windows up to make room for it instead of laying over the top. (see picture) It does the same thing when i auto-hide it. Does anyone know how I can fix this?

Thanks a lot.

February 10th, 2010, 05:49 PM
Of course as soon as I make a post, I go and figure out the problem on my own. There is an option in the cairodock configuration menu that says, "reserve space at edge of screen for the dock?". thats it.

Pauly BC
February 10th, 2010, 07:32 PM
I've been having a struggle with Cairo dock as well - the black box. People have said it can be solved by turning on compositing and running the OpenGL graphics driver. I have ATI Catalyst running the latest version and compositing enabled, but still the nasty black box. Is there a setting in Cairo to get rid of it?


February 10th, 2010, 08:45 PM
I have run cairo dock many times on my personal computer, and it is great. I just installed it on my friend's computer. (Intel i7 CPU, Ndivia graphics card) and the black box came up. I haven't had time to try to fix it though, I will try to see if i can get it.

February 10th, 2010, 09:05 PM
I just found in another post the answer. I got the black box to go away on my friend's computer. You just have to enable desktop effects. This, in turn with enable compositioning.