View Full Version : [mythbuntu] xfs 2nd HDD gparted mythbuntu 9.10

February 5th, 2010, 07:57 PM
I'm trying to format/partition my second HDD with xfs using gparted, most of the file system type options are greyed out any idea why ?

and how to resolve ?


February 12th, 2010, 01:44 PM
You need to unmount the partition before making any changes with Gparted.

February 14th, 2010, 02:19 PM
Thanks for your reply,
I pretty sure this isn't the cure.
I can delete all the partitions on the drive so it's definitely not mounted

When it comes to re partitioning and formatting, I only get the option of EXT2,3,4 FAT16,32,linux-swap & unformatted.

hfs,hfs+,jfs,ntfs,reiser4,ufs & xfs are all greyed out.

My thought is that support for these filesystems has been removed from Mytbunut 9.10. or I've set an option somewhere that stops me from selecting these file types.

Any mroe ideas

February 14th, 2010, 03:40 PM
Try it using Gparted Live or the Karmic disc.

February 17th, 2010, 08:41 PM
getting somewhere, It must be mythbuntu 9.10 filesystem support.

Booting from Fedora10 live USB install on flash drive.
I now have the extra option of ntfs which wasn't there before.

all the others types remain as they were before.

April 16th, 2011, 12:54 PM
@sbrattonuk: have you managed to format your drive?

April 17th, 2011, 07:36 PM
Yes I got it sorted.
Installing the partition manager on the mythbuntu system was sufficient to do the job.

I did need to chown -R as the mythbuntu user to make it read/writeable once formatted.

Then mount the drive as the recordings directory on the main file system.

The filesystem type also needs to be supported by the host OS. (mythbuntu). Creful if you use another means of formatting the drive (eg live CD from another distro).


April 17th, 2011, 07:39 PM
I also managed to activate more filesystems in Gparted after I've install more mkfs packages. Seems that it is just the matter of what have been installed by default.