PDA

View Full Version : Help a noob with video codecs



mairuzu
February 5th, 2010, 07:44 PM
Hi I'm a total Ubuntu noob.

I have Ubuntu9.10 and have installed MPlayer, VLC Player and Miro, but as soon as I open any AVI file they just close and disappear without a word!

I have had a look to see how to install codecs, but to no avail.

Please could someone give me a complete dummy's step by step guide to resolving this problem?

FYI - I'm using a laptop on which I had no problem playing everything through VLC on XP, but have ended up using exclusively Ubuntu after the first attempt at installing a dual boot completely fried my version of XP and now I can't go back! Which I'm kind of happy about if I can get things working in Ubuntu.

Glenn nl
February 5th, 2010, 07:46 PM
Did you try installing the ubuntu-restricted-extras package?

mairuzu
February 5th, 2010, 07:54 PM
I did - but to be honest, I don't really understand what it is or does...

mairuzu
February 5th, 2010, 07:56 PM
Just had a look and I'm assuming that it's something I wouldn't necessarily see or be aware of once it's installed? Am I right?

Cabs21
February 5th, 2010, 08:03 PM
did you install cairo dock? I have had an issue with VLC and cairo dock before. try opening VLC alone without a video, go to preferences in the options, tools, or edit tab. on the left in the preferences window there should be a video tab. Under that tab find the output bar and change it to GNOME or GLopen or something like that. Close VLC and try opening a video file again. If no luck try a different format. If still no luck then I cant help you. This issue happened to me while cairo dock was installed. When I reinstalled a fresh 9.10 and VLC the issue did not happen and has not happened yet. I have not installed cairo dock yet. Good luck. Let us know if it worked or not.

lisati
February 5th, 2010, 08:08 PM
Maybe FF&H isn't the best place for this discussion.....

Elfy
February 5th, 2010, 08:09 PM
moved to ABT

nhasian
February 5th, 2010, 08:49 PM
VLC doesnt need codecs installed. it plays all the video formats natively. If VLC fails to play your video file there is probably something wrong with your video file.

open up a terminal from Applications->Accessories and try to play the video file with vlc from there. then if it crashes you can see what the output message is.


I have Ubuntu9.10 and have installed MPlayer, VLC Player and Miro, but as soon as I open any AVI file they just close and disappear without a word!

andrew.46
February 5th, 2010, 09:16 PM
Hi mairuzu,


I have Ubuntu9.10 and have installed MPlayer, VLC Player and Miro, but as soon as I open any AVI file they just close and disappear without a word!

This is often a sign that your media players are asking for a default video mode that is not suitable for your system. To test this try altering the 'video out' setting in vlc to something like x11. This setting can be found in vlc by following:

Tools --> Preferences --> Video --> Output

and altering the settings in the dropdown box.

All the best,

Andrew

mairuzu
February 6th, 2010, 01:12 AM
Fantastic! thank you - seems to work a treat!

andrew.46
February 6th, 2010, 03:38 AM
Hi mairuzu,


Fantastic! thank you - seems to work a treat!

Excellent news :). If you are also a keen MPlayer user the same trick will work there but I would advise you to think about using the gui SMPlayer rather than the default gui (gmplayer) that normally comes with MPlayer. This can be loaded from the developer's PPA as follows, in a single command:



sudo add-apt-repository ppa:rvm/smplayer && \
sudo apt-get update && \
sudo apt-get install smplayer


and then the video out can be altered in a similar fashion:

Options --> Preferences --> General --> Video --> Output Driver

All the best,

Andrew