PDA

View Full Version : [ubuntu] 9.10 Network is erratic, tried disable ivp6 and setting mtu



Jense
February 4th, 2010, 01:44 PM
Hi,

I setup 9.10 for a friend after he got so frustrated with Xp constantly crashing that he was willing to give linux a try. Installlation went smooth, but relly weired problem with the network.

Firstly, the router provides an internetconnection just fine (working under windows and also if I connect my laptop, using arch).

Right after the installation, I was able to ping the router as well as sites outside the network, but no applications could connect to the internet. So I searched some and found that this might be due to two problems.
1. The mtu - changed it, but didn't help
2. ipv6 - So I disabled ipv6 in grub, this seemed to have done it.

Firefox worked well enough, but connecting to the update server didn't work to well (timeouts). Changing the updateserver to Main (from country specific) seemed to fix that too, but right after the first update..
the Network was completly gone!!!
So I searched and searched and finally disabled one network card in the bios (the computer has two on board network cards) and then it worked again. All seemed fine, two reboots, etc.. but this morning he calls me and the internet is gone, again!
The weired thing: I can connect to his computer using a remote desktop connection over the internet!

So, below is the ifconfig output, all seems well I guess. I am really out of ideas.



[sudo] password for michael:
eth0 Link encap:Ethernet Hardware Adresse xxxxxxxxxxx
inet Adresse:192.168.178.2 Bcast:192.168.178.255 Maske:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
RX packets:8638 errors:0 dropped:0 overruns:0 frame:0
TX packets:10414 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenl�nge:1000
RX bytes:719854 (719.8 KB) TX bytes:5828324 (5.8 MB)
Interrupt:21 Basisadresse:0x2000

lo Link encap:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metrik:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenl�nge:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

michael@michael-desktop:~$


So if you know anything, please help.. :-) thx

Jense
February 4th, 2010, 01:49 PM
I forgot to add, now I can ping the router, but I can't ping sites outside the LAN. This results in an unknown host error. I can, however connect to his computer using RDC.

Jense
February 4th, 2010, 03:37 PM
Well, nobody? I have attached the output of /var/log/messages/ which is quite full an there are some error messages, but I googling them did no turn up any eye opening realizations. Maybe somebody else can make more of this...dmesg is attached as well..
Got to run now but I will be back later, please help if you have any idea..

superprash2003
February 4th, 2010, 03:42 PM
try posting output of route -n did he install firestarter or gufw or anything similar recently?

Jense
February 4th, 2010, 06:44 PM
Thx for your answer. Here is the output you requested


michael@michael-desktop:~$ route -n
Kernel-IP-Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
192.168.178.0 0.0.0.0 255.255.255.0 U 1 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 eth0
0.0.0.0 192.168.178.1 0.0.0.0 UG 0 0 0 eth0
michael@michael-desktop:~$


This is a fresh install, newly created partitions, etc... WinXP is installed on a separate partition. There are virtually no packages installed, not included in the standard installation (except restricted extras for mp3, flash, etc...).

BT1
February 4th, 2010, 07:06 PM
Dude, I hope you didn't publish his real Mac address. :P

Jense
February 4th, 2010, 07:25 PM
ups, thx for pointing that out :-)

BT1
February 4th, 2010, 11:11 PM
Also, try posting this in the networking section. Sometimes I find answers in the other forums because those experts seem to avoid absolute beginner talk sometimes due to the repetitive issues there.

Still, I hope things turn out well.

warfacegod
February 5th, 2010, 03:20 AM
The troubleshooting section may be of some help to you:

http://ubuntuforums.org/showthread.php?t=1193567

Jense
February 5th, 2010, 01:56 PM
Okay, I posted this problem in the networks section, please follow the links if you feel you can contribute to the solution.

http://ubuntuforums.org/showthread.php?p=8777986#post8777986