PDA

View Full Version : [ubuntu] Compiling Net::Packet to test for vulnerabilitites



payload101
February 3rd, 2010, 08:30 PM
I have been attempting to compile the Net::Packet perl modules to use to create crafted packets to test for vulnerabilities and have not been able to get one of the dependencies compiled libdnet under Ubuntu 9.10. I was wondering if anyone has had success with compiling it.

Not being a programmer has not helped me either.

Thanks and regards.

cariboo
February 4th, 2010, 03:17 AM
I use cpan to install perl modules, Have a look here (http://www.livejournal.com/doc/server/lj.install.perl_setup.modules.html) scroll down to Using cpan.

Cpan should be installed by default.

payload101
February 4th, 2010, 10:15 PM
Yep tried that before posting. All my efforts have ended in failure to get Net::Packet working mostly due to it not being able to find Libdnet. the perl install of Net::Libdnet fails as it can not find the libdnet library.

Thanks for your reply.....

Really frustrated

olii3
February 6th, 2010, 08:28 AM
hey i've been having issues with this as well. i'd be really helpful if someone could please shed some light on how we can take care of this matter. thank you

cariboo
February 6th, 2010, 08:50 AM
Have a look at SevenMachines' post in this thread (http://ubuntuforums.org/showthread.php?p=8769070), it may help solve the problem.