PDA

View Full Version : [SOLVED] 9.1 install failure. What now?



Al Fischer
February 1st, 2010, 12:13 AM
So I downloaded 9.1. Made the CD. Put an 80g HD in. Ran Gparted to clean ALL partitions off. Proceeded to install 9.1 using whole drive (no other system. Ran without incident.

on boot get msg:
error: no such device: 20f5ea16-9e37-463f-a5bf-52649e22a99f
Failed to boot default entries.

Press any key to continue..



So I press a key and get the same msg.

Now what do I do?

nhasian
February 1st, 2010, 12:18 AM
as i understand you, you successfully burned the iso to CD media, and completed the installation process of ubuntu. Upon rebooting your computer, then grub is telling you the partition its looking for doesnt exist?

boot off the liveCD and go to system->administration->disk utility click on more information and see if there are any problems with your hard disk like bad sectors, etc.

Al Fischer
February 1st, 2010, 12:30 AM
HD shows as healthy. I ran the short self test. No errors.

CJay554
February 1st, 2010, 12:47 AM
to get some more information we need you to go into you LiveCD and mount the partition into where you installed ubuntu
open up a terminal and go into the root of that installation dir then run

ls -l dev/disk/by-uuid
This will tell us the partition UUID's (that big number that grub reports to not be able to load)

and post what you have here,

then go into your /grub folder (make sure your going into the Partition and not your LiveCD). the Grub should be in /boot/grub, inside either attach the grub.cfg or copy and paste it here. This is just to see what number Grub is using in comparison to the number we check with by-uuid.

So overall...
copy and paste

ls -l dev/disk/by-uuid
from the root of your ubuntu installation on hard drive

attach or copy/paste
/grub/boot/grub.cfg
from your ubuntu partition (make sure its not from LiveCD, ubuntu should be found under the /media folder after mounting)

Al Fischer
February 1st, 2010, 01:06 AM
The UUID is the sam as it says it cannot find.
I attached the grub.cfg

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s /boot/grub/grubenv ]; then
have_grubenv=true
load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
saved_entry=${prev_saved_entry}
save_env saved_entry
prev_saved_entry=
save_env prev_saved_entry
fi
insmod ext2
set root=(hd0,1)
search --no-floppy --fs-uuid --set 20f5ea16-9e37-463f-a5bf-52649e22a99f
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=640x480
insmod gfxterm
insmod vbe
if terminal_output gfxterm ; then true ; else
# For backward compatibility with versions of terminal.mod that don't
# understand terminal_output
terminal gfxterm
fi
fi
if [ ${recordfail} = 1 ]; then
set timeout=-1
else
set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/white
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry "Ubuntu, Linux 2.6.31-14-generic" {
recordfail=1
if [ -n ${have_grubenv} ]; then save_env recordfail; fi
set quiet=1
insmod ext2
set root=(hd0,1)
search --no-floppy --fs-uuid --set 20f5ea16-9e37-463f-a5bf-52649e22a99f
linux /boot/vmlinuz-2.6.31-14-generic root=UUID=20f5ea16-9e37-463f-a5bf-52649e22a99f ro quiet splash
initrd /boot/initrd.img-2.6.31-14-generic
}
menuentry "Ubuntu, Linux 2.6.31-14-generic (recovery mode)" {
recordfail=1
if [ -n ${have_grubenv} ]; then save_env recordfail; fi
insmod ext2
set root=(hd0,1)
search --no-floppy --fs-uuid --set 20f5ea16-9e37-463f-a5bf-52649e22a99f
linux /boot/vmlinuz-2.6.31-14-generic root=UUID=20f5ea16-9e37-463f-a5bf-52649e22a99f ro single
initrd /boot/initrd.img-2.6.31-14-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
if [ ${timeout} != -1 ]; then
if keystatus; then
if keystatus --shift; then
set timeout=-1
else
set timeout=0
fi
else
if sleep --interruptible 3 ; then
set timeout=0
fi
fi
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

Al Fischer
February 1st, 2010, 01:12 AM
with only 1 HD and one partition, shouldn't it show hd0,0?

I looks like it is set for hd,1

Fire$torm
February 1st, 2010, 01:36 AM
Hello Al,

If the above suggestions do not help solve your problem, you can always try reinstalling.
I have a solution but it requires booting your system from a USB thumb drive/stick.
If you can bootup in this manner this pendrivelinux.com how-to link --> boot-iso-from-usb-flash-drive (http://www.pendrivelinux.com/boot-iso-from-usb-flash-drive/) <-- will show you how to setup a thumb drive for booting memtest86+, parted magic 4.5 or Ubuntu 9.10 Desktop LiveCD from a single device. Parted Magic is a GUI for a set of utilities including gparted partition manager which is my favorite utility for such work.

Hope this helps and good luck.

Peace.

lidex
February 1st, 2010, 01:56 AM
Go here:
https://help.ubuntu.com/community/Grub2
Scroll down to section:
"Command Line & Rescue Mode"

That should get you up and running.

Al Fischer
February 1st, 2010, 02:19 AM
OK I will download GRUB2 and try it.

HOWEVER, just to be thorough, I just finished reloading to a different HD and it booted fine. The original drive was a PATA drive that worked and tested fine. The new drive is a SATA.

Strange that this will not go on an 80 gig WD PATA.

System is a ASUS P6T with 6g of ram and loads and boots DOS, XP, WIN 7 and Ubuntu 8.1 fine. But none of these reside on the PATA IDE port. Always on SATA.

I had a copy od Legacy Grub and it did not seem to work like I remember from when I installed 8.1

This smells like a BIOS or IHC10 problem. Gonna talk to ASUS in the morning, but tonight I will play with GRUB 2.

The fire's out. Not an UBUNTU problem! THANKS to ALL for the replies.

lidex
February 1st, 2010, 03:47 AM
Is this an nVidia chipset? Have seen problems relating to that.

lidex
February 1st, 2010, 03:59 AM
Looks like grub2 to me. The actual version number is 1.97, legacy grub is .xx .

Al Fischer
February 1st, 2010, 02:04 PM
This is an Intel X58 chipset, so not an nVidia problem. I have come to the conclusion that there is something wrong with the Marvell 88se6111 SATA/PATA chip on the MB.

Checked drive jumpers. OK
Tried another HD
Tried another DVD drive
another cable
swapped positions of he HD/DVD--- IT WORKS!
(no problem if installed on a SATA drive)

HD and DVD jumpered for cable select as always.

When HD is on end/bleck/master connector it works.
BUT if the DVD is on end/black/master it fails.
Properties in WIN7 show them properly recognized by device id (don't know where this is found in Linux)

Several days ago I needed WIN98 and it wouldn't load - obviousle the same problem! Will try again.

Path of least resistance is leave the drives the way they work. HD as master, DVD as slave. OR, play with ASUS support for several days while escalating (and I am GOOOD at that!).

Right now, however, I am more interested in my multiboot project and this idiosyncracy of the P6T motherboard can wait.

SO, the end result was caused by a master/slave problem causing GRUB or Ubuntu to think there were two drives and it needed to be multi-booted. As it is set up now on boot a message of grub selecting shows briefly and then Ubuntu starts. No select screen fom GRUB (as expected).

Fire$torm
February 1st, 2010, 11:42 PM
Path of least resistance is leave the drives the way they work. HD as master, DVD as slave.

It has been my experience with "HDD as Master" is the correct way to setup PATA. One of the reasons for this is that a while back many optical drives took a long time to completely initialize, or at least longer than HDD's. So the problem is probably an issue with your DVD drive. Also, you want the HDD to be master because the master controls the data link and you need to have the fastest device doing that.

Peace.

no2498
February 2nd, 2010, 12:32 AM
? you on a dell computer

Al Fischer
February 6th, 2010, 03:30 PM
This is not a Dell. It's a homebuilt using ASUS P6T. Anyhow, looks like a basic hardware issue.

nhasian
February 7th, 2010, 06:40 PM
dont use cable select for jumper selection on PATA drives. if both devices are on the same cable, set one for master and the other for slave. if both devices are on their own cables, set them both for master. some hard disks have a different jumper selection for single drive mode.