PDA

View Full Version : [ubuntu] 9.10 printing to Windows USB printer



NutmegCT
January 31st, 2010, 02:07 PM
Good day all.

I have 9.10 on my laptop, updates all up to date.

I turned on my WinXP machine and its USB printer.

I crank up my Dell laptop running Ubuntu 9.10 and want to print to the Windows printer (Canon Pixma MP160).

I choose System,Admin, Printing.

I choose Network printers, Windows SAMBA, and Ubuntu does indeed find the Windows machine on the network, and does indeed find the Canon printer. I then enter the correct driver name, and proceed.

I see the SMB setting, then click Verify, enter the Windows machine username and password, and get:

"Print Share Inaccessible - Invalid Argument."

Seems that if Ubuntu could find the printer, and I accept all the settings with OK ... why do I get inaccessible - invalid argument?

Could someone please suggest how to fix this config problem?

Thanks.
Tom
PS - I previously posted this in Wireless and Networking, but maybe that's the wrong place for Windows network printer problems?

Psumi
January 31st, 2010, 04:43 PM
The MP160 doesn't have wireless/network capabilities itself.

Also, by the look of the google search results... it looks like you're going to have a hard time with this printer. I couldn't get my MP190 working very well, so I ended up giving it away to someone who uses windows... and got myself an HP printer/scanner/copier (HP Wireless Officejet 6500.)

http://www.google.com/#hl=en&source=hp&q=MP160+ubuntu&aq=f&aqi=g-m1&oq=&fp=64df356c6a3f8304

halitech
January 31st, 2010, 04:54 PM
according to openprinting.org, its supposed to work perfectly

http://www.openprinting.org/show_printer.cgi?recnum=Canon-PIXMA_printer_mp160

are you using a windows user login and password or your Ubuntu username and password?

oldfred
January 31st, 2010, 07:11 PM
It is definitely not the printer as mine works just fine as directly plugged in to USB port. New install of Karmic showed printer immediately. Scanner works but windows driver is still better.

You may see old posts with issues as three years ago I did have lots of issues getting the MP160 working.http://ubuntuforums.org/images/icons/icon9.gif

NutmegCT
January 31st, 2010, 07:42 PM
according to openprinting.org, its supposed to work perfectly

http://www.openprinting.org/show_printer.cgi?recnum=Canon-PIXMA_printer_mp160

are you using a windows user login and password or your Ubuntu username and password?

Thanks all.

The printer is connected via USB to the WinXP machine. It's a shared network printer on the WinXP box.

When I try to send a print job, I'm asked for the username, workgroup, and password. So I'm entering my WinXP machine username, workgroup, and password.

Keep in mind that when I try adding a new printer on the 9.10 laptop, I choose Network Printer, Windows SAMBA, and 9.10 finds the Windows network, workgroup, and the printer itself.

I enter the WinXP username and password, click Verify, and get the "Print Share inaccessible ...". If I don't click Verify, and just click Forward, the printer sets up in 9.10 printer config, but when I click Test Page, I'm asked for (and enter) the WinXP username/pw, and see the job enter the 9.10 queue. Queue says "processing" - but sits there forever and never prints (or completes, or clears, or gives a queue error).

Tom

maitchy
February 2nd, 2011, 08:37 AM
I also cannot print from a Linux computer* via samba to a USB printer on a Windows XP system, but I can print from a Windows Vista laptop to the shared printer (so sharing is working from the XP side). My problem is that it rejects every password I try (even if I turn the guest account on in XP so I shouldn't need a password).

I don't get the "Invalid Argument" problem though (that might have something to do with limited resources at the Windows end? Reminds me of a problem with Vista shares that required a registry value set... can't be more helpful just at the moment, but it might be enough of a clue for a successful google search if the problem lies in that neck of the woods).

The odd thing is that I *used to* be able to print from linux computers to an HP 5550 printer on the same computer; I "upgraded" to an HP 1050 and then could not print... although the problem might have come a little earlier because any printing to the old printer was having lots of trouble for a while.

The ODDER thing (and probably a big clue) is: I can mount shares from either of the XP or Vista computers on the linux systems but not mount the Vista shares on the XP computer. So I suspect a (domain) authentication problem (but why does it only apply to printers? And I've tried security = user and security = domain, although I could never get the option "password server = *" to work). I also wondered about IP v6 and tried sorting out entries in /etc/hosts of the type ::ffff... without success. So far I don't see any samba logs or anything in /var/log changing when the error happens.

* tried from two Ubuntu systems and one Fedora 12, without success - all got in a password loop.

woozalia
September 3rd, 2011, 07:06 PM
I had this same problem with Ubuntu 11.04 trying to connect to a printer on Win98SE. The problem turned out to be that Ubuntu doesn't like spaces in share names.

The dialog won't let you enter them, and when you browse for a printer that has a space in its sharename, the space gets replaced with "20" -- not "%20", which worked in KDE's printer module on a slightly older version of Kubuntu. The dialog also won't let you enter the "%" character.

When we edited the share on the Windows machine to replace the space with an underscore ("_"), that solved the problem.

This looks to me like a BUG in Ubuntu's implementation of Samba printing.