View Full Version : [ubuntu] 9.10 - No sound with X-Fi Xtreme Audio Notebook

January 23rd, 2010, 09:55 PM
I have just recently installed Ubuntu 9.10, now that I think I have my hard locks worked out (apparently 9.10 doesn't like it if you don't have a monitor plugged in) so now I am trying to get my sound card working.

I have 2 sound devices, both work perfectly fine in windows btw (a bit of a surprise with the creative product). Onboard sound (Realtek HD I think) simply marked as Internal Audio in Sound Preferences. The other is my X-Fi Xtreme Audio Notebook, listed as [SB X-Fi Xtreme Audio] CA0110-IBG. A link to the products page for the card: http://www.soundblaster.com/products/product.asp?category=1&subcategory=208&product=16642

I noticed that I got no audio (no system sounds) with the X-Fi selected so I started trying to figure some things out.

For a test I start up Rhythmbox with some music (aside - I love that programs can see network shares now!) with Sound Preferences set to do output to the Internal Audio device. At the far right edge of Rhythmbox I get how much time of the song has been played, oh and audio.

If I then stop the audio (either by pausing, stoping, or closing Rhythmbox) and switch the output to my X-Fi not only do I get no sound but the time counter displays unknown, generally not right away either but if I let it sit a moment trying to play some music.

I have tried following a thread on how to install OSS (and remove ALSA), apparently the thread was created before ALSA supported creative cards... much. I succeeded only in breaking my audio completely, neither card worked. I then re-installed Ubuntu as I had just installed it and hadn't built up much data in it yet (a couple of favorites, backed up to another drive).

So now that ALSA is supposed to work with creative cards now, I am wondering if anyone has some more up to date tidbits to try. I would rather not break things again as by now I have gotten a lot of neat tweaks put in place (like double and triple mouse clicks as well as application dependent mouse events ala UberOptions Logitech). I can't seem to find good tidbits regarding 9.10 either.

January 24th, 2010, 12:25 PM

March 5th, 2010, 08:26 PM
I am the owner of Creative SB X-Fi Xtreme Audio Notebook aswell. I have the Ubuntu 9.10 64-bit recently, as just as you, I am trying to run my music card and use my full 5:1.
I am sure you all know that if I want use full 5:1 power, I need to connect my speakers by docking module or optical in ( which I do not use, so let stick with docking module ). I can connect my speakers to card with one jack, but this is only for hearing anything ...
Do you run this in any of Ubuntu releases ( especially 9.10 version ) ? I would REALLY appreciate any answer, because it is driving me crazy ! I have spent pretty much money for this set, and I do want to use it under Linux as well as I use it under Win 7.
I am interested in this topic for pretty good time and few months ago I've found out that in 9.10 kernel, there should have been support for this card. Is it truth ? Many people told me it should for with no word, but not in my case :( ...
Please, help me out !

March 5th, 2010, 09:35 PM

Time has passed, and in the meantime 10.04 has become a really good release. It is only in alpha now, but it works on all machines where I have tried it.

Rather than fighting with 9.10 I would recommend that you try 10.04.


March 7th, 2010, 01:36 PM
Is it the newest one ?

March 7th, 2010, 05:04 PM
The numbers indicate year and month, so 10.04 is due to be released in april 2010. It can not be any newer than this :-)

It is in third stage of the alpha test, but as I mentioned I think it behaves really well.

March 8th, 2010, 02:44 PM
I ment which alpha version is it :).
Anyway. I have just installed fresh 9.10 64-bit ... and card is not working. I have instert it into my notebook, reboot but at the beginning only laptop's speakers were working. I opened system sound preferences and tried all options. When I turned on my card the sound just stopped working. Totem stopped playing the currect mp3 and it was just paused. When I picked up integrated sound card again it worked back. What am I doing wrong ? How can I turn it on for 100 % ? Plese help me guys. I have reinstall whole system only for that stupid sound card which I am trying to turn on for pretty long time.
In lsmod, lspci and lsusb all seems to be okay. If you want to I can paste it in here.
Regards, Maciek.

March 8th, 2010, 10:19 PM
I ment which alpha version is it :).

It is in third stage of the alpha test. Has not changed since I wrote post #6

March 9th, 2010, 01:58 PM
Anyway, do you have got any ideas how can I run it ?

March 9th, 2010, 10:10 PM
It works like any other Ubuntu. Just burn the CD and boot the machine with it, then you can run as a live CD or install.

March 9th, 2010, 11:24 PM
Ohhh man :-P. I know how to install alpha, I have already done it. I asked you about how to run this card under 10.04.

April 3rd, 2010, 12:32 PM
I'm running 10.04 Beta 1 and this card is still not working by default.

April 4th, 2010, 09:07 AM
I would disable the onboard sound in the bios before even installing the card.