PDA

View Full Version : [ubuntu] nvidia-settings GPU scaling detecting wrong resolution



markp1989
January 21st, 2010, 09:00 PM
in my media pc i have a geforce 8400, attached to a 32" 720p lcd using a dvi to vga adapter, and it is miss detecting the resolution

it detects the resolution as 1080p, so when i try to enable full gpu scaling it gets the resolution wrong resulting no image on the screen.

how do i manualy set the "back end resolution"


thanks Markp1989

smo0th
January 21st, 2010, 09:01 PM
try reconfiguring the xserver


sudo dpkg-reconfigure -phigh xserver-xorg

markp1989
January 21st, 2010, 09:06 PM
try reconfiguring the xserver


sudo dpkg-reconfigure -phigh xserver-xorg

thanks for the reply:)

i have already done this, no luck

i think i need a edid file to set the resolutoion to 1280x720 does any one know a source for these, or is willing to tell me how i edit the edid.bin file on my pc?



thanks Markp1989

markp1989
January 21st, 2010, 09:23 PM
i have used parse-edid to see what edid is detecting about my screen:


parse-edid</etc/X11/edid.bi
parse-edid: parse-edid version 2.0.0
parse-edid: EDID checksum passed.

# EDID version 1 revision 3
Section "Monitor"
# Block type: 2:0 3:ff
# Block type: 2:0 3:fc
Identifier "QHTF42"
VendorName "QHD"
ModelName "QHTF42"
# Block type: 2:0 3:ff
# Block type: 2:0 3:fc
# Block type: 2:0 3:fd
HorizSync 31-80
VertRefresh 56-120
# Max dot clock (video bandwidth) 160 MH
# DPMS capabilities: Active off:no Susp

Mode "1920x1080" # vfreq 58.224Hz
DotClock 148.000000
HTimings 1920 2030 2070 2
VTimings 1080 1085 1090 1
Flags "+HSync" "+VSync"
EndMode
# Block type: 2:0 3:ff
# Block type: 2:0 3:fc
# Block type: 2:0 3:fd
EndSection

as you can see there is no setting for 720p, how do i edit this file, its a bin?


thanks Markp1989

rsrohitrs
January 25th, 2010, 06:52 PM
Hi,
I am new to Ubuntu but I have everything working on it perfectly but there is one problem.
I am using Dell Inspi 1720 with Nvidia 8600M GT 256MB card and the resolution I am getting is 1920x1200.
I cannot change it to lower using the Nvidia settings or anything.
I opened my xorg.conf file and it has the following output:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Fri Aug 14 17:54:58 PDT 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection


Everything looks very small in this resolution so I want to lower it.
Please help me.


Thank you.

misterspider
September 6th, 2010, 05:39 AM
SubSection "Display"
Depth 24
Modes "1024x768" "640x480"
EndSubSection
Try adding something like this.

ingeon
November 18th, 2010, 05:41 PM
Thanks a million. I have an Acer 1932 and it`s always give me trouble.
At last it is fixed. I got so tired of switching off 'Force Full GPU scaling' manually every single time :roll:


Section "Monitor"
Identifier "Monitor0"
VendorName "Acer AL1932"
ModelName "AcerMFMAV"
HorizSync 30.0 - 80.0
VertRefresh 56.0 - 75.0
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 260"
Option "FlatPanelProperties" "Scaling = Native"
:KS