View Full Version : [kde] OpenGL stopped working for desktop effects

January 21st, 2010, 05:42 AM
Hello! Ok, so I've had Kubuntu 9.10 for awhile now and loved it, and I started trying to get the desktop effects to go faster. In the beginning, under 'Desktop Effects' in 'System Settings', the compositing type was OpenGL and the OpenGL mode was 'Texture to Pixmap'. This all worked great until I (in search of free speed) changed the OpenGL mode to 'Fallback'. Now, the compositing will only enable if the compositing type is Xrender (slow) or if the OpenGL mode is set to 'Fallback' (also very slow). Attempting to change the OpenGL mode back to either 'Shared' or 'Texture to pixmap' either results in an error message or, if I disable the functionality checks, results in the windows being outlined but no other details (such as text, or my wallpaper) are visible.

So basically, this is my fault, and I don't want to have to reinstall Kubuntu to fix it. Please help!

64-bit architecture
Nvidia 8400GS

January 23rd, 2010, 05:50 PM